Safari 3.0.4 et Mac OS X 10.4.11.

Le
Jacques Perrocheau
Bonjour,

Au moins sur une machine, le déploiement du menu Bookmarks me gèle
Safari (Safari (Not responding) de manière permanente (et utilise tout
ce qui reste de CPU). Certe j'ai un nombre important de bookmark dans ce
menu (1373) mais la version 2.0.4 ne plantait pas avec même fichier de
Bookmark.

En retirant le fichier "~/Library/Safari/Bookmarks.plist", cela règle le
problème. L'exportation des anciens bookmarks (je rappelle: par
"drag&drop") et la réimportation ne règle pas le pb. Bon comme je ne
veux pas passer mon temps à voir si c'est le nombre élevé ou un bookmark
qui met le boxon, je laisse en l'état, j'évite de passer sur le menu
Bookmark ;-(.

Des observations similaires ?


Pour info j'ai comme plug-ins Safari:

"/Library/InputManagers/Ecamm/Plugins/DownloadComment.plugin"

"/Library/Application Support/SIMBL/Plugins/AcidSearch.bundle"
"/Library/Application Support/SIMBL/Plugins/SafariSource.bundle"

Tout ça en dernière version.

l'AcidSearch.bundle en version 0.7.b3 sur cette machine me donne dans la
Console un message au lancement de Safari (feed back fait au
développeur) :


2007-11-21 15:17:24.923 Safari[18476] ##### BEFORESWIZZLE
2007-11-21 15:17:24.931 Safari[18476] ##### AFTERSWIZZLE
2007-11-21 15:17:24.947 Safari[18476] ##### SWIZZLING: keyDown: WITH:
pz_keyDown: IN: NSTableView
2007-11-21 15:17:24.947 Safari[18476] ##### SWIZZLING: menuForEvent:
WITH: pz_menuForEvent: IN: NSTableView
2007-11-21 15:17:27.799 Safari[18476] ##### updateSearchFields
2007-11-21 15:17:28.045 Safari[18476] cell: <SearchFieldCell: 0x4c9e80>
2007-11-21 15:17:28.045 Safari[18476] ##### updateCell:
<SearchFieldCell: 0x4c9e80>
2007-11-21 15:17:28.279 Safari[18476] ##### updateImageForCell:
<SearchFieldCell: 0x4c9e80>

Sur une autre machine en réinstallant AcidSearch.bundle en version
0.7.b3 avec désinstallation préalable de la version précédente ce
message a disparu, mais sur cette machine (PowerMac G4 PCI) pas moyen de
reproduire la manip.

En passant l'installateur est écrit "vite fait sur le feu" et mets le
boxon dans les privilèges de la hiérarchie du plug-in.

--
Jacques PERROCHEAU
Synthèse et Electrosynthèse Organiques, C.N.R.S. UMR 6510
Université de Rennes I, Campus de Beaulieu, F-35042 RENNES Cedex
Tel: +33 2 23 23 63 74, Fax: +33 2 23 23 63 74
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jperrocheau
Le #2920791
Jacques Perrocheau
Au moins sur une machine, le déploiement du menu Bookmarks me gèle
Safari (Safari (Not responding) de manière permanente (et utilise tout
ce qui reste de CPU). Certes j'ai un nombre important de bookmark dans ce
menu (1373) mais la version 2.0.4 ne plantait pas avec même fichier de
Bookmark.


Je complète, sur une machine un peu plus puissante (G4 800 MHz), le
phénomène est le même mais en laissant "oeuvrer", Safari mouline,
mouline pendant 4 minutes et rend la main. A partir de ce moment le menu
"Bookmark" est utilisable.

J'ai cru un moment que ce pouvait être une "conversion silencieuse" de
mon ancien fichier "~/Library/Safari/Bookmarks.plist" (440 Ko) (rien vu
de changé en ouvrant le dit fichier avec Property List Editor).

Malheureusement, le phénomène réapparaît après chaque nouveau lancement
de Safari. ;-(

Donc pour le moment, je ne quitte plus Safari... ;-)

Visiblement, il y a un "lézard" quelque part.


Pour info j'ai comme plug-ins Safari:

"/Library/InputManagers/Ecamm/Plugins/DownloadComment.plugin"

"/Library/Application Support/SIMBL/Plugins/AcidSearch.bundle"
"/Library/Application Support/SIMBL/Plugins/SafariSource.bundle"

Tout ça en dernière version.

l'AcidSearch.bundle en version 0.7.b3 sur cette machine me donne dans la
Console un message au lancement de Safari (feed back fait au
développeur) :
[snip]
Sur une autre machine en réinstallant AcidSearch.bundle en version
0.7.b3 avec désinstallation préalable de la version précédente ce
message a disparu, mais sur cette machine (PowerMac G4 PCI) pas moyen de
reproduire la manip.


Je rectifie, sur cette même machine (G4 800 MHz) le phénomène est le
même:

2007-11-21 21:09:40.442 Safari[14601] ##### BEFORESWIZZLE
2007-11-21 21:09:40.496 Safari[14601] ##### AFTERSWIZZLE
2007-11-21 21:09:40.503 Safari[14601] ##### SWIZZLING: keyDown: WITH:
pz_keyDown: IN: NSTableView
2007-11-21 21:09:40.503 Safari[14601] ##### SWIZZLING: menuForEvent:
WITH: pz_menuForEvent: IN: NSTableView
2007-11-21 21:09:47.026 Safari[14601] ##### updateSearchFields
2007-11-21 21:09:47.070 Safari[14601] cell: <SearchFieldCell: 0x1215a10>
2007-11-21 21:09:47.071 Safari[14601] ##### updateCell:
<SearchFieldCell: 0x1215a10>
2007-11-21 21:09:47.328 Safari[14601] ##### updateImageForCell:
<SearchFieldCell: 0x1215a10>



--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:

Jacques Perrocheau
Le #2920381
In article (Jacques Perrocheau) wrote:

Au moins sur une machine, le déploiement du menu Bookmarks me gèle
Safari (Safari (Not responding) de manière permanente (et utilise tout
ce qui reste de CPU). Certes j'ai un nombre important de bookmarks dans ce
menu (1373) mais la version 2.0.4 ne plantait pas avec même fichier de
Bookmark.



Je continue mon enfilade solo...

En fait sur cette machine pas très puissante (PM G4 PCI), Safari rend la
main au bout de ... 10 minutes et le menu est alors utilisable.

Apple fait comme Microsoft, "ralentir" ses logiciels pour obliger à
acheter un nouvelle machine... :-(

Ah! et puis nouvelle découverte, on peut toujours copier un "bookmark"
dans la fenêtre des Bookmarks mais on ne peut plus le couper, vraiment
bizarre.

--
Jacques PERROCHEAU
Synthèse et Electrosynthèse Organiques, C.N.R.S. UMR 6510
Université de Rennes I, Campus de Beaulieu, F-35042 RENNES Cedex
Tel: +33 2 23 23 63 74, Fax: +33 2 23 23 63 74


tino
Le #3160821
Jacques Perrocheau
In article (Jacques Perrocheau) wrote:

Au moins sur une machine, le déploiement du menu Bookmarks me gèle
Safari (Safari (Not responding) de manière permanente (et utilise tout
ce qui reste de CPU). Certes j'ai un nombre important de bookmarks dans ce
menu (1373) mais la version 2.0.4 ne plantait pas avec même fichier de
Bookmark.



Je continue mon enfilade solo...

En fait sur cette machine pas très puissante (PM G4 PCI), Safari rend la
main au bout de ... 10 minutes et le menu est alors utilisable.

Apple fait comme Microsoft, "ralentir" ses logiciels pour obliger à
acheter un nouvelle machine... :-(


Je ne sais pas s'il s'agît du même phénomène, mais j'ai aussi
l'impression que la safari beta 3 avait plus de répondant et gèlait
moins que cette mouture livrée avec la dernier maj.

--
MR <°))))>< °°°°°
So have I heard and do in part believe it.



Jacques Perrocheau
Le #3160681
In article (Martin Rass) wrote:

Je ne sais pas s'il s'agît du même phénomène, mais j'ai aussi
l'impression que la safari beta 3 avait plus de répondant et gèlait
moins que cette mouture livrée avec la dernier maj.


C'est juete ce point qui coince chez moi. Pour les reste Safari 3.0.4
semble effectivement plus rapide que la version 2.0.4 pour la plupart
des autres actions (lancement, affichage, latence pour quitter,...),
sauf peut-être enregistrer un bookmark.

--
Jacques PERROCHEAU
Synthèse et Electrosynthèse Organiques, C.N.R.S. UMR 6510
Université de Rennes I, Campus de Beaulieu, F-35042 RENNES Cedex
Tel: +33 2 23 23 63 74, Fax: +33 2 23 23 63 74

tino
Le #3160641
Jacques Perrocheau
In article (Martin Rass) wrote:

Je ne sais pas s'il s'agît du même phénomène, mais j'ai aussi
l'impression que la safari beta 3 avait plus de répondant et gèlait
moins que cette mouture livrée avec la dernier maj.


C'est juete ce point qui coince chez moi. Pour les reste Safari 3.0.4
semble effectivement plus rapide que la version 2.0.4 pour la plupart
des autres actions (lancement, affichage, latence pour quitter,...),
sauf peut-être enregistrer un bookmark.


je ne sais déjà plus depuis le temps que j'utilisais la beta ...


--
MR <°))))>< °°°°°
So have I heard and do in part believe it.


minfiu
Le #3160551
Jacques Perrocheau
In article (Martin Rass) wrote:

Je ne sais pas s'il s'agît du même phénomène, mais j'ai aussi
l'impression que la safari beta 3 avait plus de répondant et gèlait
moins que cette mouture livrée avec la dernier maj.


C'est juete ce point qui coince chez moi. Pour les reste Safari 3.0.4
semble effectivement plus rapide que la version 2.0.4 pour la plupart
des autres actions (lancement, affichage, latence pour quitter,...),
sauf peut-être enregistrer un bookmark.


Et bien chez moi, je n'ai toujours pas trouvé ce qui cloche... Il m'est
toujours impossible de fermer une fenêtre de Safari (3.04 - Mac OS X
10.4.11), que ce soit par le bouton rouge, par un Pomme-W ou par le menu
Fichier/Fermer. Dans mon dossier "Application Enhancers", je n'ai que
"The Bad APE.ape" et "SharedMenus.ape", mon logiciel "URL Manager Pro"
auquel je tiens beaucoup, réclamant l'usage du panneau de préférences
"Application Enhancer". Si je le désactive, je n'ai plus accès à mes
signets directement dans Safari. Et, préférant Safari à Firefox, je suis
un peu enquiquiné sur ce coup. Au cas où, comment revenir à Safari 2 ?

Serge

--
Léda Atomica Musique...
Une visite s'impose ;-)


tino
Le #3160341
Serge Horrent
Jacques Perrocheau
In article (Martin Rass) wrote:

Je ne sais pas s'il s'agît du même phénomène, mais j'ai aussi
l'impression que la safari beta 3 avait plus de répondant et gèlait
moins que cette mouture livrée avec la dernier maj.


C'est juete ce point qui coince chez moi. Pour les reste Safari 3.0.4
semble effectivement plus rapide que la version 2.0.4 pour la plupart
des autres actions (lancement, affichage, latence pour quitter,...),
sauf peut-être enregistrer un bookmark.


Et bien chez moi, je n'ai toujours pas trouvé ce qui cloche... Il m'est
toujours impossible de fermer une fenêtre de Safari (3.04 - Mac OS X
10.4.11), que ce soit par le bouton rouge, par un Pomme-W ou par le menu
Fichier/Fermer. Dans mon dossier "Application Enhancers", je n'ai que
"The Bad APE.ape" et "SharedMenus.ape", mon logiciel "URL Manager Pro"
auquel je tiens beaucoup, réclamant l'usage du panneau de préférences
"Application Enhancer". Si je le désactive, je n'ai plus accès à mes
signets directement dans Safari. Et, préférant Safari à Firefox, je suis
un peu enquiquiné sur ce coup.


Je n'utilise plus URL Manager pro, as-tu regardé s'il y a une mise à
jour ?
A part cela ce sont plutôt les inputmanagers qui peuvent poser problème,
surtout s'ils ne sont pas à jour, il y a peu qui sont aussi bien fait
qeu saft, t'avertissant à chaque mise à jour de safari si minime
soit-elle d'aller voir sur site pour télécharger la mise à jour.

Au cas où, comment revenir à Safari 2 ?


Je ne m'y risquerai pas à moins de vouloir revenir à 10.4.10.
Safari 2 doit être sur ton DVD install, puis il faudrait restaurer
10.4.10 et surtout réparer les permissions.




--
MR <°))))>< °°°°°
So have I heard and do in part believe it.



minfiu
Le #3160221
Martin Rass
Serge Horrent
Jacques Perrocheau



... Il m'est toujours impossible de fermer une fenêtre de Safari (3.04 -
Mac OS X 10.4.11), que ce soit par le bouton rouge, par un Pomme-W ou
par le menu Fichier/Fermer. Dans mon dossier "Application Enhancers", je
n'ai que "The Bad APE.ape" et "SharedMenus.ape", mon logiciel "URL
Manager Pro" auquel je tiens beaucoup, réclamant l'usage du panneau de
préférences "Application Enhancer". Si je le désactive, je n'ai plus
accès à mes signets directement dans Safari. Et, préférant Safari à
Firefox, je suis un peu enquiquiné sur ce coup.


Je n'utilise plus URL Manager pro, as-tu regardé s'il y a une mise à
jour ?


Oui, oui, j'ai bien la dernière version.

A part cela ce sont plutôt les inputmanagers qui peuvent poser problème,
surtout s'ils ne sont pas à jour, il y a peu qui sont aussi bien fait
qeu saft, t'avertissant à chaque mise à jour de safari si minime
soit-elle d'aller voir sur site pour télécharger la mise à jour.


Je vais voir de ce côté, merci.

Au cas où, comment revenir à Safari 2 ?


Je ne m'y risquerai pas à moins de vouloir revenir à 10.4.10.
Safari 2 doit être sur ton DVD install, puis il faudrait restaurer
10.4.10 et surtout réparer les permissions.


Bon... dans ce cas je laisse tomber ! J'utiliserai Firefox en attendant
de trouver la solution ou une mise à jour de Safari ou encore le passage
à Léopard un de ces jours.

Serge

--
Léda Atomica Musique...
Une visite s'impose ;-)


punzonen1
Le #3160211
Serge Horrent

Bon... dans ce cas je laisse tomber ! J'utiliserai Firefox en attendant
de trouver la solution ou une mise à jour de Safari ou encore le passage
à Léopard un de ces jours.

Serge


Et pourquoi pas SeaMonkey?

--
René Chamayou

pour m'écrire décoder en rot 13 :

minfiu
Le #3160081
René Chamayou
Serge Horrent

Bon... dans ce cas je laisse tomber ! J'utiliserai Firefox en attendant
de trouver la solution ou une mise à jour de Safari ou encore le passage
à Léopard un de ces jours.

Serge


Et pourquoi pas SeaMonkey?


J'essaierai, mais j'aime bien Safari, qui me convenait tout à fait.

Serge

--
Léda Atomica Musique...
Une visite s'impose ;-)


Publicité
Poster une réponse
Anonyme