Samba, Cups, XPpro et gros problèmes d'impression

Le
JKB
Bonjour à tous,

J'ai actuellement un très gros problème d'impression avec des postes
XPpro qui sont sur un réseau avec un PDC debian (lenny).

Le domaine (avec les sessions) itinérantes fonctionne parfaitement.
J'arrive à voir l'imprimante (une HP1320n donc réseau) que Windows
refuse de voir comme une imprimante réseau mais passons. Il la voit
comme une imprimante au cul du serveur Samba.

Ce serveur est monté avec un CUPS qui fonctionne. J'arrive à
imprimer une page de test depuis l'interface CUPS (et je vois le
trafic réseau vers l'imprimante). Pas de problèm.

Bon me disé-je. Si j'arrive à imprimer depuis le serveur, je vais
partager l'imprimante par samba et cela devrait contourner le bug
Windows. J'ajoute donc l'imprimante visible dans le voisinage
réseau (avec le pilote postscript HP installé localement sur le
poste Windows). J'essaye d'imprimer une page de test. Rien Que
dalle Nada

un watch -n0,2 ls /tmp me montre que le poste Windows envoie bien un
fichier PRN dans le spool de samba (/tmp). Celui-ci disparaît aussi
rapidement que possible mais cupsd ne génère aucun trafic réseau
vers l'imprimante. Je ne vois vraiment pas ce que j'ai pu rater.
Il n'y a aucune erreur dans les logs de cups (en mode debug). Mon
fichier samba commence par :


[global]
netbios name = aboulafia
workgroup = sda
passdb backend = tdbsam
os level = 65
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \aboulafia%Uprofiles
logon home = \aboulafia%U
logon drive = W:
netbios name = aboulafia
workgroup = sda
passdb backend = tdbsam
os level = 65
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \aboulafia%Uprofiles
logon home = \aboulafia%U
logon drive = W:
logon script = netlogon.cmd
log file = /var/log/samba/log.%m
passwd chat = *EntersnewsUNIXspassword:* %n
*RetypesnewsUNIXspassword:* %n
socket options = TCP_NODELAY
obey pam restrictions = no
encrypt passwords = true
passwd program = /usr/bin/passwd %u
wins support = yes
dns proxy = no
server string = %h server (Samba %v)
unix password sync = yes
syslog = 0
log level = 1
panic action = /usr/share/samba/panic-action %d
max log size = 1000
load printers = yes
printing = cups
printcap name = cups
deadtime = 1
profile acls = yes

[printers]
comment = Imprimantes
path = /tmp
printable = yes
public = yes
guest ok = yes
writable = yes
browseable = yes
create mode = 0700

[HP1320n]
comment = Hewlett-Packard LaserJet 1320n
path = /tmp
default devmode = yes
writeable = yes
printable = yes
guest ok = yes
public = yes
browseable = yes
create mode = 0700
use client driver = yes


Une idée, parce que sèche et que google n'est pas mon ami sur ce
coup

JKB


--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
sansflotusspam
Le #1918952
JKB wrote:

Bonjour à tous,

J'ai actuellement un très gros problème d'impression avec des postes
XPpro qui sont sur un réseau avec un PDC debian (lenny).

Le domaine (avec les sessions) itinérantes fonctionne parfaitement.
J'arrive à voir l'imprimante (une HP1320n donc réseau) que Windows
refuse de voir comme une imprimante réseau mais passons. Il la voit
comme une imprimante au cul du serveur Samba.

Ce serveur est monté avec un CUPS qui fonctionne. J'arrive à
imprimer une page de test depuis l'interface CUPS (et je vois le
trafic réseau vers l'imprimante). Pas de problèm.

Bon me disé-je. Si j'arrive à imprimer depuis le serveur, je vais
partager l'imprimante par samba et cela devrait contourner le bug
Windows. J'ajoute donc l'imprimante visible dans le voisinage
réseau (avec le pilote postscript HP installé localement sur le
poste Windows). J'essaye d'imprimer une page de test. Rien... Que
dalle... Nada...

un watch -n0,2 ls /tmp me montre que le poste Windows envoie bien un
fichier PRN dans le spool de samba (/tmp). Celui-ci disparaît aussi
rapidement que possible mais cupsd ne génère aucun trafic réseau
vers l'imprimante. Je ne vois vraiment pas ce que j'ai pu rater.
Il n'y a aucune erreur dans les logs de cups (en mode debug). Mon
fichier samba commence par :


[global]
netbios name = aboulafia
workgroup = sda
passdb backend = tdbsam
os level = 65
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \aboulafia%Uprofiles
logon home = \aboulafia%U
logon drive = W:
netbios name = aboulafia
workgroup = sda
passdb backend = tdbsam
os level = 65
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \aboulafia%Uprofiles
logon home = \aboulafia%U
logon drive = W:
logon script = netlogon.cmd
log file = /var/log/samba/log.%m
passwd chat = *EntersnewsUNIXspassword:* %nn
*RetypesnewsUNIXspassword:* %nn
socket options = TCP_NODELAY
obey pam restrictions = no
encrypt passwords = true
passwd program = /usr/bin/passwd %u
wins support = yes
dns proxy = no
server string = %h server (Samba %v)
unix password sync = yes
syslog = 0
log level = 1
panic action = /usr/share/samba/panic-action %d
max log size = 1000
load printers = yes
printing = cups
printcap name = cups
deadtime = 1
profile acls = yes

[printers]
comment = Imprimantes
path = /tmp
printable = yes
public = yes
guest ok = yes
writable = yes
browseable = yes
create mode = 0700

[HP1320n]
comment = Hewlett-Packard LaserJet 1320n
path = /tmp
default devmode = yes
writeable = yes
printable = yes
guest ok = yes
public = yes
browseable = yes
create mode = 0700
use client driver = yes


Une idée, parce que sèche et que google n'est pas mon ami sur ce
coup...

JKB




où est, dans /etc/samba/smb.conf, la section :

[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
# to allow user 'guest account' to print.
guest ok = yes
writable = no
printable = yes
create mode = 0777
# ==================================== # print command: see above for details.
# ==================================== **** print command = lpr-cups -P %p -o raw %s -r # using client
side printer drivers.
# print command = lpr-cups -P %p %s # using cups own drivers (use
generic PostScript on clients).
# If you install drivers on the server, you will want to uncomment
this so
# clients request the driver
# use client driver = yes

pour info, c'est la ligne repérée par **** (à ne pas mettre dans le
fichier) qui gère l'impression depuis les postes Win$$ ...

JKB
Le #1918951
Le 10-01-2008, à propos de
Re: Samba, Cups, XPpro et gros problèmes d'impression,
sansflotusspam écrivait dans fr.comp.os.linux.configuration :
JKB wrote:

Bonjour à tous,

J'ai actuellement un très gros problème d'impression avec des postes
XPpro qui sont sur un réseau avec un PDC debian (lenny).

Le domaine (avec les sessions) itinérantes fonctionne parfaitement.
J'arrive à voir l'imprimante (une HP1320n donc réseau) que Windows
refuse de voir comme une imprimante réseau mais passons. Il la voit
comme une imprimante au cul du serveur Samba.

Ce serveur est monté avec un CUPS qui fonctionne. J'arrive à
imprimer une page de test depuis l'interface CUPS (et je vois le
trafic réseau vers l'imprimante). Pas de problèm.

Bon me disé-je. Si j'arrive à imprimer depuis le serveur, je vais
partager l'imprimante par samba et cela devrait contourner le bug
Windows. J'ajoute donc l'imprimante visible dans le voisinage
réseau (avec le pilote postscript HP installé localement sur le
poste Windows). J'essaye d'imprimer une page de test. Rien... Que
dalle... Nada...

un watch -n0,2 ls /tmp me montre que le poste Windows envoie bien un
fichier PRN dans le spool de samba (/tmp). Celui-ci disparaît aussi
rapidement que possible mais cupsd ne génère aucun trafic réseau
vers l'imprimante. Je ne vois vraiment pas ce que j'ai pu rater.
Il n'y a aucune erreur dans les logs de cups (en mode debug). Mon
fichier samba commence par :


[global]
netbios name = aboulafia
workgroup = sda
passdb backend = tdbsam
os level = 65
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \aboulafia%Uprofiles
logon home = \aboulafia%U
logon drive = W:
netbios name = aboulafia
workgroup = sda
passdb backend = tdbsam
os level = 65
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \aboulafia%Uprofiles
logon home = \aboulafia%U
logon drive = W:
logon script = netlogon.cmd
log file = /var/log/samba/log.%m
passwd chat = *EntersnewsUNIXspassword:* %nn
*RetypesnewsUNIXspassword:* %nn
socket options = TCP_NODELAY
obey pam restrictions = no
encrypt passwords = true
passwd program = /usr/bin/passwd %u
wins support = yes
dns proxy = no
server string = %h server (Samba %v)
unix password sync = yes
syslog = 0
log level = 1
panic action = /usr/share/samba/panic-action %d
max log size = 1000
load printers = yes
printing = cups
printcap name = cups
deadtime = 1
profile acls = yes

[printers]
comment = Imprimantes
path = /tmp
printable = yes
public = yes
guest ok = yes
writable = yes
browseable = yes
create mode = 0700

[HP1320n]
comment = Hewlett-Packard LaserJet 1320n
path = /tmp
default devmode = yes
writeable = yes
printable = yes
guest ok = yes
public = yes
browseable = yes
create mode = 0700
use client driver = yes


Une idée, parce que sèche et que google n'est pas mon ami sur ce
coup...

JKB




où est, dans /etc/samba/smb.conf, la section :

[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
# to allow user 'guest account' to print.
guest ok = yes
writable = no
printable = yes
create mode = 0777
# ==================================== > # print command: see above for details.
# ==================================== > **** print command = lpr-cups -P %p -o raw %s -r # using client
side printer drivers.
# print command = lpr-cups -P %p %s # using cups own drivers (use
generic PostScript on clients).
# If you install drivers on the server, you will want to uncomment
this so
# clients request the driver
# use client driver = yes

pour info, c'est la ligne repérée par **** (à ne pas mettre dans le
fichier) qui gère l'impression depuis les postes Win$$ ...


Et ? Pour info aussi, je me tape malheureusement du samba depuis la
version 1 dans des environnements hétérogènes, donc je connais. ;-)

Par ailleurs, le problème n'était absolument pas dans le fichier
smb.conf. J'ai dû changer les locales du serveur pour que Windows
daigne à nouveau utiliser l'imprimante réseau car depuis une mise à
jour de inénarrable Ouïndowzerie, celle-ci s'est mis à envoyer de
l'ISO-8859-15 (!) à l'imprimante. Bref, ni cups ni samba n'y étaient
pour quelque chose... Mais il a fallu bricoler dans le samba une
conversion au vol vers de l'UTF8.

Je ne remercierais jamais assez Microsoft pour m'avoir permis de
perdre des heures de boulot comme ça...

Cordialement,

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.


Publicité
Poster une réponse
Anonyme