Sauvegarde Thunderbird par Robocopy en réseau

Le
Sibusate
Bonsoir à tous,
Tout d'abord, mes plus plates excuses Je ne sais pas à quel saint m=
e
vouer (à quel Forum ou Groupe de discussion m'adresser).

Sur le PC XP+SP3 (à jour) de mon épouse, je lance 1 à 2 fois par se=
maine
un .BAT pour exécuter un Robocopy (celui de Windows 2003 Serveur
Resource Kit téléchargé depuis le site de Microsoft lui-même) pou=
r
sauvegarder sur mon propre PC (Win7) les nouveaux fichiers et les
fichiers modifiés (sur la base du bit d'Archive) d'un dossier complet
(22 répertoires, 7551 fichiers, 16,7GB). Cela ne fait donc en fait, en
moyenne, qu'une grosse centaine de fichiers à copier réellement.

Contenu du fichier .BAT on ne peut plus simple :
Net USE Z: \pcpersoi$ password /user:administrateur
Robocopy H:annick Z:annick *.* /e /m /r:5 /w:1 /log:d:obo.log /TEE

Les 2 PC sont reliés par un routeur; le PC de mon épouse en Wifi, le
mien en Ethernet. Aucun souci d'accès.

Le dossier source (H:Annick) contient en fait une sauvegarde
quotidienne de ses dossiers perso (c:documents and settingsannickmes
documents + messagerie + Favoris).
Ces fichiers sur H:Annick ne sont donc pas en cours d'utilisation. Et
- par précaution - quand je fais cette sauvegarde hebdomadaire, toutes
les applications sont arrêtées.

A peu près 3 à 4 fois sur 5, ce .BAT se plante, toujours sur le mêm=
e
fichier PREFS.JS du profile de Thunderbird. (je vous rappelle qu'il ne
s'agit que d'une sauvegarde du fichier Prefs.js de Thunderbird et que,
de surcroit, Thunderbird est arrêté).
Quand je dis que le BAT se plante, en fait, il plante le PC : plus la
main ni au clavier, ni à la souris, impossible de démarrer le
Gestionnaire de tâches. Pas de retry de la part de Robocopy.

Si je démarre le Gestionnaire de tâches avant de lancer le .BAT en
question, je peux interrompre l'application (elle disparait), mais le
process Robocopy reste actif et je ne peux pas l'interrompre. Si je
relance mon .BAT il se replante sur le même fichier PREFS.JS.. et
ainsi de suite. Hier soir j'avais ainsi 6 process ROBOCOPY tous plantés=
.
Et il me semble que le processeur n'était utilisé qu'à 2 ou 3% (=
pas
sûr..)
Seul moyen de m'en sortir : éteindre le PC à la sauvage et le
redémarrer. A la seconde fois, le fichier PREFS.JS passe sans
problème et toute la suite se termine bien.
Enfin, ce fichier PREFS.JS ne fait que 15KB environ alors que les
fichiers Inbox ou SENT qui font eux, 135MB et 90MB passent sans aucun sou=
ci.
Ce ne me semble donc pas un problème de réseau et encore moins de
Thunderbird. Robocopy ? Windows ?
Voilà pourquoi je ne sais sur quel forum poster (Thunderbird ?
Scripting ? Réseau ? XP ? ????)
Pardonnez moi d'avoir été aussi long.
Si quelque Gourou avait une idée lumineuse à me suggérer pour compr=
endre
avant de debugger, je suis preneur.
SVP, ne me proposez pas de remplacer Robocopy par autre chose, le Wifi
par de l'Ethernet (ça va venir), etc.. je cherche à comprendre,
seulement, et à résoudre ensuite.
Merci de votre aide,
François
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ascadix
Le #21002761
Le 18/01/2010, Sibusate a supposé :
Bonsoir à tous,
Tout d'abord, mes plus plates excuses... Je ne sais pas à quel saint me
vouer... (à quel Forum ou Groupe de discussion m'adresser...).

Sur le PC XP+SP3 (à jour) de mon épouse, je lance 1 à 2 fois par semaine
un .BAT pour exécuter un Robocopy (celui de Windows 2003 Serveur
Resource Kit téléchargé depuis le site de Microsoft lui-même) pour
sauvegarder sur mon propre PC (Win7) les nouveaux fichiers et les
fichiers modifiés (sur la base du bit d'Archive) d'un dossier complet
(22 répertoires, 7551 fichiers, 16,7GB). Cela ne fait donc en fait, en
moyenne, qu'une grosse centaine de fichiers à copier réellement.

Contenu du fichier .BAT on ne peut plus simple :
Net USE Z: \pcpersoi$ password /user:administrateur
Robocopy H:annick Z:annick *.* /e /m /r:5 /w:1 /log:d:robo.log /TEE

Les 2 PC sont reliés par un routeur; le PC de mon épouse en Wifi, le
mien en Ethernet. Aucun souci d'accès.

Le dossier source (H:Annick) contient en fait une sauvegarde
quotidienne de ses dossiers perso (c:documents and settingsannickmes
documents + messagerie + Favoris).
Ces fichiers sur H:Annick ne sont donc pas en cours d'utilisation. Et
- par précaution - quand je fais cette sauvegarde hebdomadaire, toutes
les applications sont arrêtées.

A peu près 3 à 4 fois sur 5, ce .BAT se plante, toujours sur le même
fichier PREFS.JS du profile de Thunderbird. (je vous rappelle qu'il ne
s'agit que d'une sauvegarde du fichier Prefs.js de Thunderbird et que,
de surcroit, Thunderbird est arrêté).
Quand je dis que le BAT se plante, en fait, il plante le PC : plus la
main ni au clavier, ni à la souris, impossible de démarrer le
Gestionnaire de tâches.... Pas de retry de la part de Robocopy.

Si je démarre le Gestionnaire de tâches avant de lancer le .BAT en
question, je peux interrompre l'application (elle disparait), mais le
process Robocopy reste actif et je ne peux pas l'interrompre. Si je
relance mon .BAT il se replante sur le même fichier PREFS.JS..... et
ainsi de suite. Hier soir j'avais ainsi 6 process ROBOCOPY tous plantés.
Et il me semble que le processeur n'était utilisé qu'à 2 ou 3%... (pas
sûr..)
Seul moyen de m'en sortir : éteindre le PC à la sauvage et le
redémarrer. A la seconde fois, le fichier PREFS.JS passe sans
problème... et toute la suite se termine bien.
Enfin, ce fichier PREFS.JS ne fait que 15KB environ alors que les
fichiers Inbox ou SENT qui font eux, 135MB et 90MB passent sans aucun souci.
Ce ne me semble donc pas un problème de réseau et encore moins de
Thunderbird. Robocopy ? Windows ?
Voilà pourquoi je ne sais sur quel forum poster...... (Thunderbird ?
Scripting ? Réseau ? XP ? ????)
Pardonnez moi d'avoir été aussi long....
Si quelque Gourou avait une idée lumineuse à me suggérer pour comprendre
avant de debugger, je suis preneur.
SVP, ne me proposez pas de remplacer Robocopy par autre chose, le Wifi
par de l'Ethernet (ça va venir...), etc.. je cherche à comprendre,
seulement, et à résoudre ensuite.
Merci de votre aide,
François



T'as quoi comme anti-virus ..

avec quels réglages ?

peut-tu le désactiver le temps d'une copie ..voir ce que ça fait ?

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Sibusate
Le #21003321
Ascadix a écrit :
T'as quoi comme anti-virus ..
avec quels réglages ?
peut-tu le désactiver le temps d'une copie ..voir ce que ça fait ?



Bonsoir ascadix,
J'ai AVAST (V4.8) avce les réglages par défaut.
6/7 en exécution, seul Outlook Exchange est arrêté because j'utilis e
Thunderbird...
Je vais essayer de l'arrêter.... bien que je n'y croie pas trop....
J'ai oublié de préciser que je ne rencontre pas ce problème avec le s
sauvegardes quotidiennes. Certes elles ne sont pas faites par Robocopy
mais par un vieux freeware que j'utilise depuis bien longtemps
(LeBackupLight) qui se base seulement sur le bit d'archive.
Merci en tous cas de ton aide
François
thierry SALARD
Le #21003311
Sibusate a écrit :
Bonsoir à tous,
Tout d'abord, mes plus plates excuses... Je ne sais pas à quel saint me
vouer... (à quel Forum ou Groupe de discussion m'adresser...).

Sur le PC XP+SP3 (à jour) de mon épouse, je lance 1 à 2 fois par semaine
un .BAT pour exécuter un Robocopy (celui de Windows 2003 Serveur
Resource Kit téléchargé depuis le site de Microsoft lui-même) pour
sauvegarder sur mon propre PC (Win7) les nouveaux fichiers et les
fichiers modifiés (sur la base du bit d'Archive) d'un dossier complet
(22 répertoires, 7551 fichiers, 16,7GB). Cela ne fait donc en fait, en
moyenne, qu'une grosse centaine de fichiers à copier réellement.

Contenu du fichier .BAT on ne peut plus simple :
Net USE Z: \pcpersoi$ password /user:administrateur
Robocopy H:annick Z:annick *.* /e /m /r:5 /w:1 /log:d:robo.log /TEE

Les 2 PC sont reliés par un routeur; le PC de mon épouse en Wifi, le
mien en Ethernet. Aucun souci d'accès.

Le dossier source (H:Annick) contient en fait une sauvegarde
quotidienne de ses dossiers perso (c:documents and settingsannickmes
documents + messagerie + Favoris).
Ces fichiers sur H:Annick ne sont donc pas en cours d'utilisation. Et
- par précaution - quand je fais cette sauvegarde hebdomadaire, toutes
les applications sont arrêtées.

A peu près 3 à 4 fois sur 5, ce .BAT se plante, toujours sur le même
fichier PREFS.JS du profile de Thunderbird. (je vous rappelle qu'il ne
s'agit que d'une sauvegarde du fichier Prefs.js de Thunderbird et que,
de surcroit, Thunderbird est arrêté).
Quand je dis que le BAT se plante, en fait, il plante le PC : plus la
main ni au clavier, ni à la souris, impossible de démarrer le
Gestionnaire de tâches.... Pas de retry de la part de Robocopy.

Si je démarre le Gestionnaire de tâches avant de lancer le .BAT en
question, je peux interrompre l'application (elle disparait), mais le
process Robocopy reste actif et je ne peux pas l'interrompre. Si je
relance mon .BAT il se replante sur le même fichier PREFS.JS..... et
ainsi de suite. Hier soir j'avais ainsi 6 process ROBOCOPY tous plantés.
Et il me semble que le processeur n'était utilisé qu'à 2 ou 3%... (pas
sûr..)
Seul moyen de m'en sortir : éteindre le PC à la sauvage et le
redémarrer. A la seconde fois, le fichier PREFS.JS passe sans
problème... et toute la suite se termine bien.
Enfin, ce fichier PREFS.JS ne fait que 15KB environ alors que les
fichiers Inbox ou SENT qui font eux, 135MB et 90MB passent sans aucun
souci.
Ce ne me semble donc pas un problème de réseau et encore moins de
Thunderbird. Robocopy ? Windows ?
Voilà pourquoi je ne sais sur quel forum poster...... (Thunderbird ?
Scripting ? Réseau ? XP ? ????)
Pardonnez moi d'avoir été aussi long....
Si quelque Gourou avait une idée lumineuse à me suggérer pour comprendre
avant de debugger, je suis preneur.
SVP, ne me proposez pas de remplacer Robocopy par autre chose, le Wifi
par de l'Ethernet (ça va venir...), etc.. je cherche à comprendre,
seulement, et à résoudre ensuite.
Merci de votre aide,
François





j'ai deja eu le cas, comme si thunderbird gardait des droits sur le
fichier même après son arrêt.
Sibusate
Le #21003481
thierry SALARD a écrit :
j'ai deja eu le cas, comme si thunderbird gardait des droits sur le
fichier même après son arrêt.



Mais il ne s'agit là que d'une copie du fichier tenu par Thunderbird... ..
A moins que XP ne se trompe à cause du nom de fichier identique....
mais pourquoi ne ne se tromperait-il pas sur le fichier Inbox ou Sent ?
Merci quand même
François
Ascadix
Le #21003931
Sibusate a formulé la demande :
Ascadix a écrit :
T'as quoi comme anti-virus ..
avec quels réglages ?
peut-tu le désactiver le temps d'une copie ..voir ce que ça fait ?



Bonsoir ascadix,
J'ai AVAST (V4.8) avce les réglages par défaut.
6/7 en exécution, seul Outlook Exchange est arrêté because j'utilise
Thunderbird...
Je vais essayer de l'arrêter.... bien que je n'y croie pas trop....
J'ai oublié de préciser que je ne rencontre pas ce problème avec les
sauvegardes quotidiennes. Certes elles ne sont pas faites par Robocopy mais
par un vieux freeware que j'utilise depuis bien longtemps (LeBackupLight) qui
se base seulement sur le bit d'archive.
Merci en tous cas de ton aide
François



T'as déjà vérifier coté permissions NTFS je pense ?

Tu peux aussi essayer de regarder au moment du plantage si un process à
verouillé le fichier pref.js ( avec UNLOCKER ou Process Explorer )
..quoique j'y crois pas trop car dans ce genre de blocage, robocopy
saute sans rester bloqué sur le fichier.

Reste aussis comme hypothése limite un pb disque ... un bon coup de
CHKDSK /R si t'as le temps

Un autre test pour voir si ça bloque sur le nom du fichier ou son
contenu :
- rennome le PREF.JS en toto.truc
- fais-en une copie avec un autre nom genre bidule.dat
- prend un p'tit fichier texte tout bête copie-le en le renomant
PREF.JS

et relance le batch ... il se passe quoi ?

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Sibusate
Le #21004871
Bonjour Ascadix,
Pas de souci avec CHKDSK passé, suite à ta suggestion, à la fois su r le
volume Source et sur le volume Cible.
Je vais vérifier avec Process Explorer si le fichier n'est pas
vérouillé, mais je n'y crois pas trop...
Côté permissions NTFS rien de spécial : mon épouse est administra teur du
poste a bien le contrôle total sur le fichier (sur tous les fichiers de s
2 volumes et sur les 2 volumes) et aucun droit refusé.... Mêmes règ les
pour tous les fichiers et tous les volumes.
Et comme les autres fichiers ne posent pas de problème au niveau de la
copie... ni la sauvegarde quotidienne vers le volume H: ni la
sauvegarde hebdomadaire depuis ce volume H: je ne vois vraiment pas en
quoi les permissions NTFS pourraient être en cause....
Merci en tous cas pour la piste...
Je vais essayer ta suggestion concernant le nom de fichier....
Depuis hier soir j'ai multiplié les essais sans rencontrer le même
problème.... comprends plus !!
@+
François
Publicité
Poster une réponse
Anonyme