scanimage non root

Le
Raphaël POITEVIN
Bonjour,

J'ai fait l'acquisition d'un HP Scanjet G4010 qui ne semble pas
supporté par le paquet sane de Debian squeeze (je suis en 64 bits)
mais très bien par la dernière release de sane ; je travaille donc sur
une version compilée.

J'arrive à faire tourner le scanner en root, mais pas en utilisateur.
J'ai recopié le fichier libsane.rules provenant des sources dans
/etc/udev/rules.d ; celui-ci contient bien la déclaration de mon
appareil, mais :
$ scanimage -L
répond qu'il ne détecte aucun scanner. Par conséquent, aucun moyen de
lancer la numérisation.

J'ai stoppé, redémarré udev et udev-mtab, mais rien à faire.

Toutes mes recherches m'amène au udev. Il doit sûrement y avoir
quelque chose que je ne maîtrise pas bien dans udev.

Un grand merci à vous pour tout éclaircissement.
--
Raphaël POITEVIN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/CAMmtCiUHrn31qGzMCeEsDfeM4uAgFmvfHehZBfv_GQ0dXeP=Gw@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JF Straeten
Le #25126012
Lo,

On Thu, Jan 10, 2013 at 12:16:30AM +0100, Raphaël POITEVIN wrote:

[...]
$ scanimage -L
répond qu'il ne détecte aucun scanner. Par conséquent, aucun moyen de
lancer la numérisation.

J'ai stoppé, redémarré udev et udev-mtab, mais rien à faire.

Toutes mes recherches m'amène au udev. Il doit sûrement y avoir
quelque chose que je ne maîtrise pas bien dans udev.



Les règles udev donnent les permissions d'utilisation au groupe
'scanner'

Ton compte est-il bien dedans ?

Vérifie aussi que les règles se déclenchent bien au branchement du
scanner.

A+


--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël POITEVIN
Le #25126022
Le 10/01/13, JF Straeten
Les règles udev donnent les permissions d'utilisation au groupe
'scanner'





Oui, j'ai oublié de le préciser.> Ton compte est-il bien dedans ?

Vérifie aussi que les règles se déclenchent bien au branchement du
scanner.



Hmm, une partie que je ne maîtrise pas. Ça sevérifie comment ? Je n'a i
rien vu en faisant un dmesg.

Merci,

Raphaël

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #25126062
On Thu, 10 Jan 2013 00:26:50 +0100
Raphaël POITEVIN
> Vérifie aussi que les règles se déclenchent bien au bran chement du
> scanner.

Hmm, une partie que je ne maîtrise pas. Ça sevérifie comme nt ? Je n'ai
rien vu en faisant un dmesg.



Si c'est comme je le pense un scanner USB sans interrupteur
d'alim, ça n'est absolument pas normal que tu ne vois rien dans
ton dmesg.

Donc, c'est au niveau de base (udev) qu'il va te falloir bricoler.

Mais une question Rafe, je croyais que t'étais nœnœil? Comme nt
tu vas savoir si tu scannes le bon côté de la page? ;-)

--
<coon> J'ai le pouvoir Mwahaha
* coon was kicked by Mama ("Et moi le pouvoir absolu")
* Mama was kicked by Léo ("Tout est relatif")

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
JF Straeten
Le #25126072
Re,

On Thu, Jan 10, 2013 at 12:26:50AM +0100, Raphaël POITEVIN wrote:

Oui, j'ai oublié de le préciser.> Ton compte est-il bien dedans ?



Ok


> Vérifie aussi que les règles se déclenchent bien au branchement du
> scanner.

Hmm, une partie que je ne maîtrise pas. Ça sevérifie comment ? Je n'ai
rien vu en faisant un dmesg.



Mais tu vois le branchement du scanner à la fin de dmesg ?

Dans ce goût là :

[18550.040013] usb 1-6: new high speed USB device using ehci_hcd and address 9
[18550.173304] usb 1-6: New USB device found, idVendorb8, idProduct26
[18550.173311] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[18550.173315] usb 1-6: Product: EPSON Scanner
[18550.173318] usb 1-6: Manufacturer: EPSON
[18550.173467] usb 1-6: configuration #1 chosen from 1 choice
[29639.672320] usb 1-6: USB disconnect, address 9


Ensuite, regarde dans /proc/sys/usb (ou /sys/bus/usb, j'oublie
toujours lequel...) si tu vois apparaître un fichier représentant le
scanner (dans un sous-directory numéroté).

C'est lui qui doit recevoir les bons droits + groupe, qui lui sont
normalement appliqués par les règles udev au branchement.

Je peux faire un branchement de scanner dès que je serai devant la
bonne machine pour essayer d'être plus précis si ça ne va pas...

Hih,

--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël POITEVIN
Le #25126052
Le 10/01/13, Bzzz
Si c'est comme je le pense un scanner USB sans interrupteur
d'alim, ça n'est absolument pas normal que tu ne vois rien dans
ton dmesg.



C'est un scanner USB avec interrupteur.

$ dmesg | tail

[203053.725314] usb 6-1.4: new full speed USB device using uhci_hcd
and address 21
[203053.828315] usb 6-1.4: not running at top speed; connect to a high spee d hub
[203053.854317] usb 6-1.4: New USB device found, idVendorf0, idProduct E05
[203053.854325] usb 6-1.4: New USB device strings: Mfr=1, Product=3,
SerialNumber
[203053.854331] usb 6-1.4: Product: HP Scanjet G4000 Photo series
[203053.854336] usb 6-1.4: Manufacturer: Hewlett-Packard
[203053.854341] usb 6-1.4: SerialNumber: CN28FAC2BN05
[203053.854570] usb 6-1.4: configuration #1 chosen from 1 choice

Donc, c'est au niveau de base (udev) qu'il va te falloir bricoler.



Aïe !

Mais une question Rafe, je croyais que t'étais nœnœil? Comment
tu vas savoir si tu scannes le bon côté de la page? ;-)



Pour le moment on en est pas là, mais oui, c'est pour m'essayer à un
OCR style tesseract. Pour le moment, j'utilise un logiciel qui pilote
finereader sous W$.

Merci,

Raphaël

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAMmtCiVU+2_d92M3UFfarDV5Y-8+t06RK4vLc8y6hJD=yYH=
JF Straeten
Le #25126132
Re,

On Thu, Jan 10, 2013 at 12:57:22AM +0100, Raphaël POITEVIN wrote:

[...]
$ dmesg | tail

[203053.725314] usb 6-1.4: new full speed USB device using uhci_hcd
and address 21
[203053.828315] usb 6-1.4: not running at top speed; connect to a
high speed hub



Sans vouloir me mêler d'une question non posée, t'aurais peut-être
intérêt à essayer de régler cela aussi dans la foulée, sinon le
scanner va se traîner...

Soit il est vraiment connecté à un port 1.1, soit ça peut être aussi
le port qui ne lui donne pas assez de jus (vu sur un client léger dont
l'alim allait tirer sa révérence...).

A+


--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #25126122
On Thu, 10 Jan 2013 00:57:22 +0100
Raphaël POITEVIN
C'est un scanner USB avec interrupteur.

$ dmesg | tail

[203053.725314] usb 6-1.4: new full speed USB device using uhci_hcd
and address 21
[203053.828315] usb 6-1.4: not running at top speed; connect to a high sp eed
hub [203053.854317] usb 6-1.4: New USB device found, idVendorf0,
idProductE05 [203053.854325] usb 6-1.4: New USB device strings: Mfr =1,
Product=3, SerialNumber
[203053.854331] usb 6-1.4: Product: HP Scanjet G4000 Photo series
[203053.854336] usb 6-1.4: Manufacturer: Hewlett-Packard
[203053.854341] usb 6-1.4: SerialNumber: CN28FAC2BN05
[203053.854570] usb 6-1.4: configuration #1 chosen from 1 choice



Ah ben si, c'est bon: ton dmesg voit bien le branchement!

Quel nom a-t-il dans /dev et quels sont: droits/grp/usr
du device?

--
<deadways> Si tu sais faire quelque chose tu le fais, sinon, tu l'enseignes

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël POITEVIN
Le #25126092
Le 10/01/13, JF Straeten
Sans vouloir me mêler d'une question non posée, t'aurais peut-être
intérêt à essayer de régler cela aussi dans la foulée, sinon le
scanner va se traîner...



Toute question non posée est une ouverture à de nouvelles connaissances . :)
Le message est certainement lié au fait que l'appareil est connecté à
un vieux HUB alimenté. mais j'imagine que cela ne devrait pas beaucoup
jouer vu que le scanner est lui-même alimenté. Me trompe-je ?


Soit il est vraiment connecté à un port 1.1, soit ça peut être au ssi
le port qui ne lui donne pas assez de jus (vu sur un client léger dont
l'alim allait tirer sa révérence...).



Euh, je ne sais pas si j'ai des USB 2.

Merci,

Raphaël

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAMmtCiW=
Bzzz
Le #25126182
On Thu, 10 Jan 2013 01:09:40 +0100
Raphaël POITEVIN
Toute question non posée est une ouverture à de nouvelles conna issances. :)



Et toute connaissance est une ouverture pour poser une nouvelle question ;)

Le message est certainement lié au fait que l'appareil est connect é à
un vieux HUB alimenté. mais j'imagine que cela ne devrait pas beauco up
jouer vu que le scanner est lui-même alimenté. Me trompe-je ?



Sur le côté alim, non; sur le côté vitesse, si.
Parce qu'entre USB 1.1 et 2.0 il y a un univers d'écart
en terme de vitesse (12Mbps et 480Mbps).


Euh, je ne sais pas si j'ai des USB 2.



Ben branche le scanner en direct et tu verras bien ce que te sort le dmeg.

--
* Fennec_pause_devoir fait du ukele
<Bardaf> il manque ul

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
JF Straeten
Le #25126162
Re,

On Thu, Jan 10, 2013 at 01:09:40AM +0100, Raphaël POITEVIN wrote:

[...]
Toute question non posée est une ouverture à de nouvelles
connaissances. :)



C'est beau, les colistiers open mind ! :-)


Le message est certainement lié au fait que l'appareil est connecté
à un vieux HUB alimenté. mais j'imagine que cela ne devrait pas
beaucoup jouer vu que le scanner est lui-même alimenté. Me
trompe-je ?



Et bien j'ai vu le problème avec deux scanners différents, alimentés
tous les deux... En changeant l'alim (de la machine), ça a été résolu.
Donc, peut-être que si le port ne donne pas assez de jus, il ne
« voit » pas qu'il pourrait bosser en 2.0, ou quelque chose comme ça
(?)


> Soit il est vraiment connecté à un port 1.1, soit ça peut être aussi
> le port qui ne lui donne pas assez de jus (vu sur un client léger dont
> l'alim allait tirer sa révérence...).

Euh, je ne sais pas si j'ai des USB 2.



Dans ce cas, ça serait réglé... Mais sauf si ta carte mère date de
l'Arche de Noé, c'est plutôt rare, pas d'USB 2, non ? :)

A+

--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme