Scinder le contenu d'une cellule dans deux autres cellules

Le
MEB
Bonjour,

J'ai une colonne qui contient un numéro d'employé à 7 caractères sa=
ns
tiret ni espace. Je voudrais scinder ce numéro dans une même cellule
mais avec un tiret après les 3 premiers chiffres. EX : Numéro
d'origine 1234567 Numéro désiré : 123-4567

Je suis convaincu qu'il existe une fonction qui nous permet de faire
cette transcription. J'ai tenté d'utiliser la fonction convertir dans
le menu Données mais je n'ai rien trouvé de potable..

Merci de m'aider
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #20440271
Bonjour.
Tu peux mettre la cellule au format : 000"-"0000
ou utiliser la formule :
=GAUCHE(A1;3)&"-"&DROITE(A1;4)
ou :
=TEXTE(A1;"000-0000")
dans une autre cellule.
Cordialement.
Daniel

Bonjour,

J'ai une colonne qui contient un numéro d'employé à 7 caractères sans
tiret ni espace. Je voudrais scinder ce numéro dans une même cellule
mais avec un tiret après les 3 premiers chiffres. EX : Numéro
d'origine 1234567 Numéro désiré : 123-4567

Je suis convaincu qu'il existe une fonction qui nous permet de faire
cette transcription. J'ai tenté d'utiliser la fonction convertir dans
le menu Données mais je n'ai rien trouvé de potable..

Merci de m'aider


Abigael
Le #20440461
bonjour,

Si le numéro fait toujours 7 caractères :
=CONCATENER(GAUCHE(A1;3);"-";DROITE(A1;4))

Abigael

"MEB" a écrit :

Bonjour,

J'ai une colonne qui contient un numéro d'employé à 7 caractères sans
tiret ni espace. Je voudrais scinder ce numéro dans une même cellule
mais avec un tiret après les 3 premiers chiffres. EX : Numéro
d'origine 1234567 Numéro désiré : 123-4567

Je suis convaincu qu'il existe une fonction qui nous permet de faire
cette transcription. J'ai tenté d'utiliser la fonction convertir dans
le menu Données mais je n'ai rien trouvé de potable..

Merci de m'aider
.



Abigael
Le #20440551
Mais bien sûr ! je n'avais pas pensé au format : c'est vraiment le plus simple.

Bonne journée

Abigael

"Daniel.C" a écrit :

Bonjour.
Tu peux mettre la cellule au format : 000"-"0000
ou utiliser la formule :
=GAUCHE(A1;3)&"-"&DROITE(A1;4)
ou :
=TEXTE(A1;"000-0000")
dans une autre cellule.
Cordialement.
Daniel

> Bonjour,
>
> J'ai une colonne qui contient un numéro d'employé à 7 caractères sans
> tiret ni espace. Je voudrais scinder ce numéro dans une même cellule
> mais avec un tiret après les 3 premiers chiffres. EX : Numéro
> d'origine 1234567 Numéro désiré : 123-4567
>
> Je suis convaincu qu'il existe une fonction qui nous permet de faire
> cette transcription. J'ai tenté d'utiliser la fonction convertir dans
> le menu Données mais je n'ai rien trouvé de potable..
>
> Merci de m'aider


.



Modeste
Le #20440651
Bonsour® MEB avec ferveur ;o))) vous nous disiez :

J'ai une colonne qui contient un numéro d'employé à 7 caractères sans
tiret ni espace. Je voudrais scinder ce numéro dans une même cellule
mais avec un tiret après les 3 premiers chiffres. EX : Numéro
d'origine 1234567 Numéro désiré : 123-4567



=TEXTE(1*A1;"000-0000")
@+
michdenis
Le #20441011
Bonjour Modeste,

Est-ce que c'est pour faire plus long que tu as ajouté le "* 1" dans ta formule ?
| =TEXTE(1*A1;"000-0000")


Salutations
Modeste
Le #20443151
Bonsour® michdenis avec ferveur ;o))) vous nous disiez :

Est-ce que c'est pour faire plus long que tu as ajouté le "* 1" dans
ta formule ?
=TEXTE(1*A1;"000-0000")





Ouppppssss !!!
en effet non testé ;o)))
ça a été extrapolé de mémoire d'un mien format pour récupérer une date importée

i-e :
240259 => 1*TEXTE(A1;"00/00/00")=> 21605 => format date 24-Fév-1959
Publicité
Poster une réponse
Anonyme