Scsi installation bloque le boot

Le
alain vanranst
--0016e6d77e88da65a904851f176d
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Scsi installation bloque le boot

Bonjour,

La situation: PC avec
motherboard Supermicro P4SCi
1 HD sata 160 G avec le systeme
Debian 5.0 Lenny; kernel 2.6.26-2-686

Tout fonctionne parfaitement.

Je decide d'installer un raid 0 avec 6 disques scsi
Carte : adaptec 39160 (bi-canal)
6 HD scsi 36.4G

Je reboot, et
la carte scsi est identifiée
les 6 disques sont reconnus
puis vient le message

Booting Debian Gnu/Linux, kernel 2.6.26-2-686
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet



Decompressing Linux Parsing ELF done
Booting the kernel
Loading, please wait

and I Wait, I Wait, I wait .

après un certain délai, on passe sous BusyBox v1.10.2
et le message :
ALERT /dev/sda1 does not exist. Dropping to a shell!

En essayant avec 1 seul canal scsi à la fois (je debranche une nappe scsi=
),
j'obtiens parfois une ligne de message en plus :
Target 0:0:1: Wide Transfer Fail

En essayant avec la carte mais les 2 nappes scsi debranchées, tout
fonctionne.

Quelqu'un a-t-il une idée.
Ai-je fais une erreur quelque part ?
Ai-je oublié quelque chose ?


Merci.

--0016e6d77e88da65a904851f176d
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Scsi installation bloque le boot<br><br>Bonjour,<br><br>La situation: PC av=
ec<br>motherboard Supermicro P4SCi<br>1 HD sata 160 G avec le systeme<br>De=
bian 5.0 Lenny; kernel 2.6.26-2-686<br><br>Tout fonctionne parfaitement.<br=
>
<br>Je decide d&#39;installer un raid 0 avec 6 disques scsi<br>Carte : adap=
tec 39160 (bi-canal)<br>6 HD scsi 36.4G<br><br>Je reboot, et <br>la carte s=
csi est identifiée<br>les 6 disques sont reconnus<br>puis vient le messag=
e <br>
<br>Booting Debian Gnu/Linux, kernel 2.6.26-2-686<br>root (hd0,0)<br>Filesy=
stem type is ext2fs, partition type 0x83<br>kernel /boot/vmlinuz-2.6.26-2-6=
86 root=/dev/sda1 ro quiet<br><br><br><br>Decompressing Linux ..=
. Parsing ELF done<br>
Booting the kernel<br>Loading, please wait <br><br>and I Wait, I Wait, I wa=
it  .<br><br>après un certain délai, on passe sous BusyBox v1.10.2=
<br>et le message :<br>ALERT /dev/sda1 does not exist. Dropping to a shell!=
<br>
<br>En essayant avec 1 seul canal scsi à la fois (je debranche une nappe =
scsi), j&#39;obtiens parfois une ligne de message en plus :<br>Target 0:0:1=
: Wide Transfer Fail<br><br>En essayant avec la carte mais les 2 nappes scs=
i debranchées, tout fonctionne.<br>
<br>Quelqu&#39;un a-t-il une idée.<br>Ai-je fais une erreur quelque part =
?<br>Ai-je oublié quelque chose ?<br><br><br>Merci.<br>

--0016e6d77e88da65a904851f176d--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/l2pd6bae7a91004260054g1b41627atb1bd23632a76d728@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bernard.schoenacker
Le #21630501
----- Mail d'origine -----
De: alain vanranst À: debian Envoyé: Mon, 26 Apr 2010 09:54:57 +0200 (CEST)
Objet: Scsi installation bloque le boot

Scsi installation bloque le boot

Bonjour,

La situation: PC avec
motherboard Supermicro P4SCi
1 HD sata 160 G avec le systeme
Debian 5.0 Lenny; kernel 2.6.26-2-686

Tout fonctionne parfaitement.

Je decide d'installer un raid 0 avec 6 disques scsi
Carte : adaptec 39160 (bi-canal)
6 HD scsi 36.4G

Je reboot, et
la carte scsi est identifiée
les 6 disques sont reconnus
puis vient le message

Booting Debian Gnu/Linux, kernel 2.6.26-2-686
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
...
...
...
Decompressing Linux ... Parsing ELF ... done
Booting the kernel
Loading, please wait

and I Wait, I Wait, I wait ....

après un certain délai, on passe sous BusyBox v1.10.2
et le message :
ALERT /dev/sda1 does not exist. Dropping to a shell!

En essayant avec 1 seul canal scsi à la fois (je debranche une nappe s csi),
j'obtiens parfois une ligne de message en plus :
Target 0:0:1: Wide Transfer Fail

En essayant avec la carte mais les 2 nappes scsi debranchées, tout
fonctionne.

Quelqu'un a-t-il une idée.
Ai-je fais une erreur quelque part ?
Ai-je oublié quelque chose ?


Merci.

bonjour,

le disque dur n°1 Sata est en adresse sda1

le premier disque scsi est en /dev/mapper/"n"

les deux modes de fonctionnement ne sont pas compatibles ....

la seule solution consisterai d'installer un système de base en
mode raid sur la partie scsi et ensuite de prendre les données et
de les transférer en en copie sur le montage raid

@+
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #21631511
Salut,

Prière d'éviter le HTML la prochaine fois.

alain vanranst a écrit :

La situation: PC avec
motherboard Supermicro P4SCi
1 HD sata 160 G avec le systeme
Debian 5.0 Lenny; kernel 2.6.26-2-686

Tout fonctionne parfaitement.

Je decide d'installer un raid 0 avec 6 disques scsi
Carte : adaptec 39160 (bi-canal)
6 HD scsi 36.4G

Je reboot, et
la carte scsi est identifiée
les 6 disques sont reconnus
puis vient le message

Booting Debian Gnu/Linux, kernel 2.6.26-2-686
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet



Déjà, en cas de problème, enlever l'option "quiet" pour afficher les
messages.

[...]
après un certain délai, on passe sous BusyBox v1.10.2
et le message :
ALERT /dev/sda1 does not exist. Dropping to a shell!

En essayant avec 1 seul canal scsi à la fois (je debranche une nappe
scsi), j'obtiens parfois une ligne de message en plus :
Target 0:0:1: Wide Transfer Fail

En essayant avec la carte mais les 2 nappes scsi debranchées, tout
fonctionne.



Je soupçonne que l'un des disques SCSI a pris le nom sda du disque SATA.
Si ce disque SCSI n'est pas partitionné, alors sda1 n'existe pas.
Eplucher les messages du noyau pour voir dans quel ordre ils sont
énumérés et nommés. Dans ce cas il faudra envisager d'identifier la
partition racine par son UUID ou label plutôt que par son nom.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
alain vanranst
Le #21637541
Bonjour,


Effectivement, en supprimant le disque sata et en installant le système
sur l'un des disques scsi le problème a été résolu.

Question subsidiaire : est-il possible d'installer conjointement un
disque sata et un disque scsi sans provoquer ce conflit de nom ?

Merci pour votre aide.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
steve
Le #21637631
Le mardi 27 avril 2010 à 08:44:10 tu as dit :

Bonjour,



Salut,


Effectivement, en supprimant le disque sata et en installant le système
sur l'un des disques scsi le problème a été résolu.

Question subsidiaire : est-il possible d'installer conjointement un
disque sata et un disque scsi sans provoquer ce conflit de nom ?



Comme l'a dit Pascal, oui, il faut utiliser les UUID dans le /etc/fstab.
Pour cela, on peut utiliser la commande blkid du paquet util-linux-ng.

s.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #21641051
alain vanranst a écrit :

Effectivement, en supprimant le disque sata et en installant le système
sur l'un des disques scsi le problème a été résolu.

Question subsidiaire : est-il possible d'installer conjointement un
disque sata et un disque scsi sans provoquer ce conflit de nom ?



Je crains de m'être mal fait comprendre. Il n'y a pas de conflit mais un
changement de nom du disque probablement à cause de l'ordre
d'énumération des disques, parce que le pilote de l'adaptateur SCSI est
chargé avant celui de l'adaptateur SATA.

Exemple possible de ce qui s'est passé :

Avant : 1 disque SATA, pas de disque SCSI
L'adaptateur SCSI est identifié, son pilote chargé et ses disques
énumérés : pas de disque
L'adaptateur SATA est identifié, son pilote chargé et ses disques
énumérés : sda

Après : 1 disque SATA + 6 disques SCSI
L'adaptateur SCSI est identifié, son pilote chargé et ses disques
énumérés : sda sdb sdc sdd sde sdf
L'adaptateur SATA est identifié, son pilote chargé et ses disques
énumérés : sdg

Résultat : sda est maintenant un disque SCSI et le disque SATA
anciennement sda est devenu sdg. La partition racine anciennement sda1
est devenue sdg1.

Il n'était pas du tout nécessaire de retirer le disque SATA ni de
réinstaller le système sur un disque SCSI, d'autant plus si les disques
SCSI doivent servir à du RAID 0. Il aurait suffi de renommer la
partition racine dans le chargeur de démarrage (root=, faisable à chaud
ce qui permet au moins de démarrer en mode "single") puis les autres
partitions du disque SATA dans /etc/fstab.

Comme déjà dit, une alternative est d'identifier les partitions par leur
UUID ou leur label (qui est fixe) au lieu de leur nom (qui dépend de
l'ordre d'énumération), ce qui présente l'avantage de mettre à l'abri de
semblables déboires lors d'un prochain ajout ou retrait de disque, mais
l'éventuel inconvénient de nécessiter un initramfs car le noyau seul ne
sait pas gérer les UUID ou les labels.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme