[Seamonkey][Ubuntu] Impossible de lancer le composant de securite du navigateur

Le
Olivier Miakinen
[ diapublication, suivi sur fr.comp.infosystemes.www.navigateurs ]

Bonjour,

J'utilise Seamonkey sur Ubuntu. De temps en temps, j'obtiens le message
« Impossible de lancer le composant de sécurité du navigateur », et peu
de temps après Seamonkey se ferme. Cela arrive parfois quand je clique
sur un lien, mais à l'instant je viens de l'avoir en publiant un article
sur usenet. En revanche ce n'est pas systématique.

Une recherche sur le web me donne plein de réponses à propos de ce
message, mais la plupart du temps le problème se résoud en retirant
l'extension AllPeers de Firefox : seulement moi je n'utilise ni Firefox
ni AllPeers, alors je dois chercher ailleurs.

Je précise que sous ~/.mozilla tous les fichiers m'appartiennent, et ils
ont tous les droits de lecture et d'écriture pour le propriétaire.

Quelqu'un aurait une idée pour résoudre ce problème ?

--
Olivier Miakinen
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jacques.montier
Le #19509431
Olivier Miakinen a gentiment tapote:
[ diapublication, suivi sur fr.comp.infosystemes.www.navigateurs ]

Bonjour,

J'utilise Seamonkey sur Ubuntu. De temps en temps, j'obtiens le message
« Impossible de lancer le composant de sécurité du navigateur », et peu
de temps après Seamonkey se ferme. Cela arrive parfois quand je clique
sur un lien, mais à l'instant je viens de l'avoir en publiant un article
sur usenet. En revanche ce n'est pas systématique.

Une recherche sur le web me donne plein de réponses à propos de ce
message, mais la plupart du temps le problème se résoud en retirant
l'extension AllPeers de Firefox : seulement moi je n'utilise ni Firefox
ni AllPeers, alors je dois chercher ailleurs.

Je précise que sous ~/.mozilla tous les fichiers m'appartiennent, et ils
ont tous les droits de lecture et d'écriture pour le propriétaire.

Quelqu'un aurait une idée pour résoudre ce problème ?




Bonjour,

Et le vieux truc de virer .config (moyennant sauvegarde...) ?
Ça résout parfois bien des problèmes.

--
Jacques
docanski
Le #19510221
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Olivier Miakinen ecrit ce qui suit en ce 07/06/2009 11:19 :

Bonjour,



Bonjour Olivier,

J'utilise Seamonkey sur Ubuntu. De temps en temps, j'obtiens le message
« Impossible de lancer le composant de sécurité du navigateur », et peu
de temps après Seamonkey se ferme.



Je n'ai jamais eu ce genre de problème avec Firefox sous Ubuntu et
pourtant, c'est le même moteur. Je ne suis donc pas sûr que le
navigateur est en cause mais peut-être une de ses extensions. Essaye
avec Firefox sur les mêmes pages, sans extensions,ne fut-ce qu'à titre
de contrôle.

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Olivier Miakinen
Le #19512401
Le 07/06/2009 17:45, jacques.montier m'a répondu :

Et le vieux truc de virer .config (moyennant sauvegarde...) ?
Ça résout parfois bien des problèmes.



Je ne connaissais pas ce truc -- ni même d'ailleurs ce répertoire --
mais je suis tout nouveau sur Linux (à peine un mois).

J'y vois en effet au moins un fichier qui a un rapport avec Seamonkey :
swfdec-mozilla.conf. J'essaierai si je ne trouve pas d'autre moyen.

Cordialement,
--
Olivier Miakinen
Olivier Miakinen
Le #19512481
Le 07/06/2009 18:36, docanski a écrit :

J'utilise Seamonkey sur Ubuntu. De temps en temps, j'obtiens le message
« Impossible de lancer le composant de sécurité du navigateur », et peu
de temps après Seamonkey se ferme.



Je n'ai jamais eu ce genre de problème avec Firefox sous Ubuntu et
pourtant, c'est le même moteur. Je ne suis donc pas sûr que le
navigateur est en cause mais peut-être une de ses extensions. Essaye
avec Firefox sur les mêmes pages, sans extensions,ne fut-ce qu'à titre
de contrôle.



Tout d'abord, le phénomène est aléatoire, un essai avec Firefox ne me
donnera donc pas plus de renseignements qu'un autre essai avec Seamonkey
puisque la plupart du temps ça marche. Par ailleurs, je n'ai aucune
extension sur mon Seamonkey, je ne peux donc pas en enlever.

Cela dit, tu m'as quand même donné une idée : il se trouve qu'une partie
de ma config de Seamonkey sur Linux a été importée à partir de mon
ancienne config qui était sur Windows, et qui elle comportait deux
extensions. Peut-être alors que quelque chose s'est mal passé lors de
l'import. Du coup, je vais essayer en repartant d'un profil vierge, et
et recopiant manuellement les trucs dont j'ai besoins (marque-pages
en particulier).

Merci !

--
Olivier Miakinen
yamo'
Le #19518921
Salut,
Olivier Miakinen a tapoté, le 08/06/2009 00:53:
il se trouve qu'une partie
de ma config de Seamonkey sur Linux a été importée à partir de mon
ancienne config qui était sur Windows



As tu vérifié qu'il n'y a pas de c:/ dans ton fichier prefs.js?

J'avais eu le coup à l'époque de ma migration xp->dapper drake!

--
Stéphane
http://pasdenom.info/fortune/
Olivier Miakinen
Le #19520971
Le 08/06/2009 19:31, yamo' a écrit :

il se trouve qu'une partie
de ma config de Seamonkey sur Linux a été importée à partir de mon
ancienne config qui était sur Windows



As tu vérifié qu'il n'y a pas de c:/ dans ton fichier prefs.js?



Merci pour cette idée, qui était en effet excellente, mais non, aucun
chemin de type Windows dans le prefs.js. En revanche, j'ai trouvé un
WIN/prefs.js qui semble être la copie du prefs.js d'origine (avec des
chemins D:\), mais il n'y a aucun lien vers le répertoire WIN dans
aucun des fichiers du profil. Je vais quand même le renommer pour être sûr.


--
Olivier Miakinen
geo cherchetout
Le #20056641
Le 03.09.2009 18:51, *le-rafal* a écrit fort à propos :
Olivier Miakinen a écrit le 07/06/2009 à 11h19 :
[ diapublication, suivi sur fr.comp.infosystemes.www.navigateurs ]

Bonjour,

J'utilise Seamonkey sur Ubuntu. De temps en temps, j'obtiens le message
« Impossible de lancer le composant de sécurité du
navigateur », et peu
de temps après Seamonkey se ferme. Cela arrive parfois quand je clique
sur un lien, mais à l'instant je viens de l'avoir en publiant un
article
sur usenet. En revanche ce n'est pas systématique.

Une recherche sur le web me donne plein de réponses à propos de
ce
message, mais la plupart du temps le problème se résoud en
retirant
l'extension AllPeers de Firefox : seulement moi je n'utilise ni Firefox
ni AllPeers, alors je dois chercher ailleurs.

Je précise que sous ~/.mozilla tous les fichiers m'appartiennent, et
ils
ont tous les droits de lecture et d'écriture pour le
propriétaire.

Quelqu'un aurait une idée pour résoudre ce problème ?

--
Olivier Miakinen


bonjour Olivier,
Depuis longtemps, j'ai le même problème avec le protocole SSL sous ubuntu 9.04
et seamonkey 1.1.17. Je ne sais pas encore trouver les cheminements comme je le
faisais dans l'explorateur windows. Donc grosse galère à chaque fois que ça se
présente je dois me résoudre à redémarrer sous windows... Humiliant!
Si tu as trouvé la solution, aurais-tu la gentillesse de me la communiquer
STP?
merci
cordialement
Benoit



Bonjour,

Si ça peut faire avancer le schmilblick, j'ai eu pour la première fois le
même message d'erreur en plus verbeux (pas noté le texte exact) aujourd'hui
au moment d'envoyer un message avec seamonkey-mail 1.1.16, alors que le
navigateur seamonkey n'était pas en cours d'exécution. Or j'ai eu hier des
mises à jour de ma Mandriva 2008.1 :

$ rpm -qa -last | head
libnss-devel-3.12.3.1-0.1mdv2008.1 mer 02 sep 2009 10:12:24 CEST
libnss3-3.12.3.1-0.1mdv2008.1 mer 02 sep 2009 10:12:23 CEST
nss-3.12.3.1-0.1mdv2008.1 mer 02 sep 2009 10:12:19 CEST
libnspr-devel-4.7.5-0.1mdv2008.1 mer 02 sep 2009 10:12:17 CEST
libnspr4-4.7.5-0.1mdv2008.1 mer 02 sep 2009 10:12:14 CEST
geo cherchetout
Le #20065941
Le 03.09.2009 23:32, j'ai écrit :

Si ça peut faire avancer le schmilblick, j'ai eu pour la première fois le
même message d'erreur en plus verbeux (pas noté le texte exact) aujourd'hui
au moment d'envoyer un message avec seamonkey-mail 1.1.16, alors que le
navigateur seamonkey n'était pas en cours d'exécution. Or j'ai eu hier des
mises à jour de ma Mandriva 2008.1 :

$ rpm -qa -last | head
libnss-devel-3.12.3.1-0.1mdv2008.1 mer 02 sep 2009 10:12:24 CEST
libnss3-3.12.3.1-0.1mdv2008.1 mer 02 sep 2009 10:12:23 CEST
nss-3.12.3.1-0.1mdv2008.1 mer 02 sep 2009 10:12:19 CEST
libnspr-devel-4.7.5-0.1mdv2008.1 mer 02 sep 2009 10:12:17 CEST
libnspr4-4.7.5-0.1mdv2008.1 mer 02 sep 2009 10:12:14 CEST



Le problème semble avoir disparu après retour aux versions précédentes :

rpm -qa -last | head
libnss-devel-3.11.9-2mdv2008.1 ven 04 sep 2009 20:27:23 CEST
libnss3-3.11.9-2mdv2008.1 ven 04 sep 2009 20:27:08 CEST
nss-3.11.9-2mdv2008.1 ven 04 sep 2009 20:27:06 CEST
libnspr-devel-4.6.8-1mdv2008.1 ven 04 sep 2009 20:27:05 CEST
libnspr4-4.6.8-1mdv2008.1 ven 04 sep 2009 20:27:04 CEST

et il est connu chez Mandriva, ce qui permet d'espérer une solution
définitive prochainement :

https://qa.mandriva.com/show_bug.cgi?idS374
Olivier Miakinen
Le #20075091
Le 03/09/2009 18:51, le-rafal m'a répondu :

« Impossible de lancer le composant de sécurité du navigateur »



Si tu as trouvé la solution, aurais-tu la gentillesse de me la communiquer
STP?



Personnellement j'ai toujours le problème de temps à autre, mais c'est
suffisamment peu fréquent pour que je ne sente pas le besoin de revenir
à une version plus ancienne. La réponse de Géo Cherchetout me donne
l'espoir que ce sera corrigé dans pas trop longtemps, alors je vais
attendre.

--
Olivier Miakinen
Publicité
Poster une réponse
Anonyme