Sécurité SharePoint 2007

Le
Thomas
Hello,

J'essaie d'installer les webPart que je développe dans le dossier /bin du
site virtuel de SharePoint. Le souci ce que la security policy qui s'y
applique est de WSS_Minimal. J'ai essayé d'écrire mon propre fichier de
configuration de sécurité en y ajoutant ReflectionPermission,
FileIOPermission etc. etc. mais je n'arrive toujours pas à faire fonctionner
mes WebParts (ça plante sur la commande
this.Page.LoadControl(moncontrol.ascx)) alors que si je change le trustlevel
en Full ou si j'enregistre ma dll dans la GAC tout fonctionne. Quels sont les
Permissions qu'il faut configurer pour que ça fonctionne ?

Merci,

Thomas
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Renaud Comte aka TheMit [MVP]
Le #17006111
Je n'ai pas ce soucis

Essayer donc par la methode utilisé dans ce sample
http://blogs.msdn.com/sharepoint/archive/2007/08/06/anonymous-comment-feature-for-sharepoint-blog-now-available-on-codeplex.aspx

source :
http://www.codeplex.com/CKS/Release/ProjectReleases.aspx?ReleaseIdb82

utilisez donc le répertoire /_controlTemplates







Si vous avez toujours le soucis de config, jetez un oeil dans les articles
de Patrick
http://msdn2.microsoft.com/en-us/library/bb530301.aspx#WSSDevToolsTechs_P2_CodeAccessSecurityandWebPartSolutions

ou directement dans le code des SmartParts :)

--
Renaud Comte [MVP] aka TheMit
Blog Fr : http://blogs.developpeur.org/themit/
Blog Us : http://blog.spsclerics.com/

"Thomas" news:
Hello,

J'essaie d'installer les webPart que je développe dans le dossier /bin du
site virtuel de SharePoint. Le souci ce que la security policy qui s'y
applique est de WSS_Minimal. J'ai essayé d'écrire mon propre fichier de
configuration de sécurité en y ajoutant ReflectionPermission,
FileIOPermission etc. etc. mais je n'arrive toujours pas à faire
fonctionner
mes WebParts (ça plante sur la commande
this.Page.LoadControl(moncontrol.ascx)) alors que si je change le
trustlevel
en Full ou si j'enregistre ma dll dans la GAC tout fonctionne. Quels sont
les
Permissions qu'il faut configurer pour que ça fonctionne ?

Merci,

Thomas


Publicité
Poster une réponse
Anonyme