Serveur application et hyperile sous linux .... votre expérience ?

Le
Vincent
Bonjour,

J'essaie depuis presque 15 jours de faire marcher webdev sous Linux (
serveur d'application et serveur hyper file)

Hélas, si les serveurs semblent fonctionner, malgrès la doc et l'aide peu
efficace de pc soft, je n'ai pas réussi à déployer
de site, j'ai toujours une erreur ftp ( malgès tous les droits ouvert ..
malgrès avoir bien suivi la doc et faits quelques truc
trouvè dans le forum).
Je n'arrive pas à me connecter au serveur hyper file, quand je tappe le
serveur,le login + mot de passe et que je valide un
message répond : Invalid or incomplete multibyte or wide character

je suis sur ubuntu 7.x chez mon hébergeur (mais j'ai le même problème avec
centOS en local sur virtuel)

Je me dit que bosser sous unix avec webdev est une vraie galère, le système
semble bien rodé sous windows pourtant.

Comment faites vous ? avez vous rèussi facilement ? une idée ? Y a t'il de
vrais spécialistes ? :)

Merci beaucoup

Vincent
ps :
ca fait trop de trucs qui marchent pas :)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Roumegou Eric
Le #16513151
Vincent a utilisé son clavier pour écrire :
Bonjour,

J'essaie depuis presque 15 jours de faire marcher webdev sous Linux ( serveur
d'application et serveur hyper file)

Hélas, si les serveurs semblent fonctionner, malgrès la doc et l'aide peu
efficace de pc soft, je n'ai pas réussi à déployer
de site, j'ai toujours une erreur ftp ( malgès tous les droits ouvert .....
malgrès avoir bien suivi la doc et faits quelques truc
trouvè dans le forum).
Je n'arrive pas à me connecter au serveur hyper file, quand je tappe le
serveur,le login + mot de passe et que je valide un
message répond : Invalid or incomplete multibyte or wide character

je suis sur ubuntu 7.x chez mon hébergeur (mais j'ai le même problème avec
centOS en local sur virtuel)

Je me dit que bosser sous unix avec webdev est une vraie galère, le système
semble bien rodé sous windows pourtant.

Comment faites vous ? avez vous rèussi facilement ? une idée ? Y a t'il de
vrais spécialistes ? :)

Merci beaucoup

Vincent
ps :
ca fait trop de trucs qui marchent pas :)



je pense personnellement que webdev sous linux a été une réponse
purement commerciale aux objections selon laquelle le moteur était
payant.

Après qu'il y ait des clients qui sont allés jusqu'au bout pour de la
prod, j'y crois moins.
Sûr que moi je n'y m'y risquerais pas alors que toute mon activité
repose sur WB. (idem php wb)

Désolé de ne pas t'apporter de réponses plus positives.

--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)
Vincent
Le #16513631
Merci pour ta réponse,

C'est une vraie déception, j'ai eue un mal fou à décider ma direction
d'acheter des produits pc-soft.
Maintenant tout les développeur trouve Windev très sympa ( et c'est vrai que
les applies avancent plus vite )

Par contre mes collègues ingénieurs système ne voulaient pas entendre parler
de webdev et windows , donc la solution
Linux , ils ne jurent que Linux et OpenOffice , notre hébergeur étant sous
unix ( avec la possibilité d'installer un serveur
d'application et serveur hyper file, version démo) cela semblait un bon
compromis, ça ne marche ni en local sous centos ni
chez l'hébergeur avec ubuntu ... j'ai droit maintenant à des : on te l'avais
dit .... et on achètera pas de serveur webdev même si le prix
est faible ( quoique , avec toutes les technologies gratuites, pourquoi
payer ?)

big big déception, l'idée de payer pc-soft pour faire l'install a failli me
couter ma réputation ( tous les produits pc-soft ont pris un coup ::).
Y pas mal de détracteur ....
Pour le moment webdev est donc abandonné, dans mon coin en dehors des heures
de boulot ... je peux espérer
faire marcher quelque chose, sur mon pc xp j'ai easyphp et bien ca ne marche
pas non plus :):) , l'install des serveurs
et trop rigide .... et j'en ai aussi marre, j'espèrai importer des
"gabarits ( html+css) même ça ca marche pas.
Pour le moment avec webdev le slogan c'est ; développer 10 fois moins vite
....

Je rage parceque c'est certainement rien du tout qui bloque ... mais bon


Vincent


"Roumegou Eric" news:
Vincent a utilisé son clavier pour écrire :
Bonjour,

J'essaie depuis presque 15 jours de faire marcher webdev sous Linux (
serveur d'application et serveur hyper file)

Hélas, si les serveurs semblent fonctionner, malgrès la doc et l'aide peu
efficace de pc soft, je n'ai pas réussi à déployer
de site, j'ai toujours une erreur ftp ( malgès tous les droits ouvert
..... malgrès avoir bien suivi la doc et faits quelques truc
trouvè dans le forum).
Je n'arrive pas à me connecter au serveur hyper file, quand je tappe le
serveur,le login + mot de passe et que je valide un
message répond : Invalid or incomplete multibyte or wide character

je suis sur ubuntu 7.x chez mon hébergeur (mais j'ai le même problème
avec centOS en local sur virtuel)

Je me dit que bosser sous unix avec webdev est une vraie galère, le
système semble bien rodé sous windows pourtant.

Comment faites vous ? avez vous rèussi facilement ? une idée ? Y a t'il
de vrais spécialistes ? :)

Merci beaucoup

Vincent
ps :
ca fait trop de trucs qui marchent pas :)



je pense personnellement que webdev sous linux a été une réponse purement
commerciale aux objections selon laquelle le moteur était payant.

Après qu'il y ait des clients qui sont allés jusqu'au bout pour de la
prod, j'y crois moins.
Sûr que moi je n'y m'y risquerais pas alors que toute mon activité repose
sur WB. (idem php wb)

Désolé de ne pas t'apporter de réponses plus positives.

--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)




Vincent
Le #16517281
DANS GOOGLE tappez : 0035, ERR_CANNOT_LAUNCH et vous aurez la liste des
dizaines de sites webdev en croix :)

c'est pas rassurant .


"Vincent" news:489ded77$0$865$
Merci pour ta réponse,

C'est une vraie déception, j'ai eue un mal fou à décider ma direction
d'acheter des produits pc-soft.
Maintenant tout les développeur trouve Windev très sympa ( et c'est vrai
que les applies avancent plus vite )

Par contre mes collègues ingénieurs système ne voulaient pas entendre
parler de webdev et windows , donc la solution
Linux , ils ne jurent que Linux et OpenOffice , notre hébergeur étant sous
unix ( avec la possibilité d'installer un serveur
d'application et serveur hyper file, version démo) cela semblait un bon
compromis, ça ne marche ni en local sous centos ni
chez l'hébergeur avec ubuntu ... j'ai droit maintenant à des : on te
l'avais dit .... et on achètera pas de serveur webdev même si le prix
est faible ( quoique , avec toutes les technologies gratuites, pourquoi
payer ?)

big big déception, l'idée de payer pc-soft pour faire l'install a failli
me couter ma réputation ( tous les produits pc-soft ont pris un coup ::).
Y pas mal de détracteur ....
Pour le moment webdev est donc abandonné, dans mon coin en dehors des
heures de boulot ... je peux espérer
faire marcher quelque chose, sur mon pc xp j'ai easyphp et bien ca ne
marche pas non plus :):) , l'install des serveurs
et trop rigide .... et j'en ai aussi marre, j'espèrai importer des
"gabarits ( html+css) même ça ca marche pas.
Pour le moment avec webdev le slogan c'est ; développer 10 fois moins vite
....

Je rage parceque c'est certainement rien du tout qui bloque ... mais bon


Vincent


"Roumegou Eric" news:
Vincent a utilisé son clavier pour écrire :
Bonjour,

J'essaie depuis presque 15 jours de faire marcher webdev sous Linux (
serveur d'application et serveur hyper file)

Hélas, si les serveurs semblent fonctionner, malgrès la doc et l'aide
peu efficace de pc soft, je n'ai pas réussi à déployer
de site, j'ai toujours une erreur ftp ( malgès tous les droits ouvert
..... malgrès avoir bien suivi la doc et faits quelques truc
trouvè dans le forum).
Je n'arrive pas à me connecter au serveur hyper file, quand je tappe le
serveur,le login + mot de passe et que je valide un
message répond : Invalid or incomplete multibyte or wide character

je suis sur ubuntu 7.x chez mon hébergeur (mais j'ai le même problème
avec centOS en local sur virtuel)

Je me dit que bosser sous unix avec webdev est une vraie galère, le
système semble bien rodé sous windows pourtant.

Comment faites vous ? avez vous rèussi facilement ? une idée ? Y a t'il
de vrais spécialistes ? :)

Merci beaucoup

Vincent
ps :
ca fait trop de trucs qui marchent pas :)



je pense personnellement que webdev sous linux a été une réponse purement
commerciale aux objections selon laquelle le moteur était payant.

Après qu'il y ait des clients qui sont allés jusqu'au bout pour de la
prod, j'y crois moins.
Sûr que moi je n'y m'y risquerais pas alors que toute mon activité repose
sur WB. (idem php wb)

Désolé de ne pas t'apporter de réponses plus positives.

--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)







Vincent
Le #16519591
Bon, cette histoire qui semble n'interesser que moi :) suit son chemin ...
J'arrive à déployer sur un serveur windows .... en installant le apache
fourni par pcsoft, car celui que j'avais avec easyphp il en voulait pas :)
Bon, j'avance ..... même si j'ai encore passé 3 heures à essayer de faire
fonctionner une verion Linux .... est-ce moi? un bug ?




"Vincent" news:489eed97$0$883$
DANS GOOGLE tappez : 0035, ERR_CANNOT_LAUNCH et vous aurez la liste des
dizaines de sites webdev en croix :)

c'est pas rassurant .


"Vincent" news:489ded77$0$865$
Merci pour ta réponse,

C'est une vraie déception, j'ai eue un mal fou à décider ma direction
d'acheter des produits pc-soft.
Maintenant tout les développeur trouve Windev très sympa ( et c'est vrai
que les applies avancent plus vite )

Par contre mes collègues ingénieurs système ne voulaient pas entendre
parler de webdev et windows , donc la solution
Linux , ils ne jurent que Linux et OpenOffice , notre hébergeur étant
sous unix ( avec la possibilité d'installer un serveur
d'application et serveur hyper file, version démo) cela semblait un bon
compromis, ça ne marche ni en local sous centos ni
chez l'hébergeur avec ubuntu ... j'ai droit maintenant à des : on te
l'avais dit .... et on achètera pas de serveur webdev même si le prix
est faible ( quoique , avec toutes les technologies gratuites, pourquoi
payer ?)

big big déception, l'idée de payer pc-soft pour faire l'install a failli
me couter ma réputation ( tous les produits pc-soft ont pris un coup ::).
Y pas mal de détracteur ....
Pour le moment webdev est donc abandonné, dans mon coin en dehors des
heures de boulot ... je peux espérer
faire marcher quelque chose, sur mon pc xp j'ai easyphp et bien ca ne
marche pas non plus :):) , l'install des serveurs
et trop rigide .... et j'en ai aussi marre, j'espèrai importer des
"gabarits ( html+css) même ça ca marche pas.
Pour le moment avec webdev le slogan c'est ; développer 10 fois moins
vite ....

Je rage parceque c'est certainement rien du tout qui bloque ... mais bon


Vincent


"Roumegou Eric" news:
Vincent a utilisé son clavier pour écrire :
Bonjour,

J'essaie depuis presque 15 jours de faire marcher webdev sous Linux (
serveur d'application et serveur hyper file)

Hélas, si les serveurs semblent fonctionner, malgrès la doc et l'aide
peu efficace de pc soft, je n'ai pas réussi à déployer
de site, j'ai toujours une erreur ftp ( malgès tous les droits ouvert
..... malgrès avoir bien suivi la doc et faits quelques truc
trouvè dans le forum).
Je n'arrive pas à me connecter au serveur hyper file, quand je tappe le
serveur,le login + mot de passe et que je valide un
message répond : Invalid or incomplete multibyte or wide character

je suis sur ubuntu 7.x chez mon hébergeur (mais j'ai le même problème
avec centOS en local sur virtuel)

Je me dit que bosser sous unix avec webdev est une vraie galère, le
système semble bien rodé sous windows pourtant.

Comment faites vous ? avez vous rèussi facilement ? une idée ? Y a t'il
de vrais spécialistes ? :)

Merci beaucoup

Vincent
ps :
ca fait trop de trucs qui marchent pas :)



je pense personnellement que webdev sous linux a été une réponse
purement commerciale aux objections selon laquelle le moteur était
payant.

Après qu'il y ait des clients qui sont allés jusqu'au bout pour de la
prod, j'y crois moins.
Sûr que moi je n'y m'y risquerais pas alors que toute mon activité
repose sur WB. (idem php wb)

Désolé de ne pas t'apporter de réponses plus positives.

--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)










Roumegou Eric
Le #16521441
Vincent a couché sur son écran :

Par contre mes collègues ingénieurs système ne voulaient pas entendre parler
de webdev et windows , donc la solution
Linux , ils ne jurent que Linux et OpenOffice , notre hébergeur étant sous
unix ( avec la possibilité d'installer un serveur
d'application et serveur hyper file, version démo) cela semblait un bon
compromis, ça ne marche ni en local sous centos ni
chez l'hébergeur avec ubuntu ... j'ai droit maintenant à des : on te l'avais
dit .... et on achètera pas de serveur webdev même si le prix
est faible ( quoique , avec toutes les technologies gratuites, pourquoi payer
?)



Voilà encore un cas où l'on marche sur la tête. C'est la "technique"
qui dicte la solution, le matos sur le fonctionnel, le barbu sur
l'utilisateur.

et oui "on te l'avait dit ..."
qu'est ce que je suis heureux maintenant que je suis débarrassé de ceux
qui ont toujours raison ^^

--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)
didier
Le #16526471
C'est vrai que quelques fois, la technique ( réseaux et systèmes ) pensent
qu'il n'y a que eux qui compte.
Fort heureusement, la gestion informatique et les logiciels sont la raison
d'être du système :)

BONNE NOUVELLE :) j'ai reussi à déployer un site sur Linux, je ne sais pas
trop comment :)
j'ai suprimmé tous les fichiers du compte ( j'ai aussi laisser tomber les
rep data et app )
Les chemins à indiquer dans le gestionnaire de compte semblent causer
problème si du genre
/home/toto/ ; /home/toto/data et /home/toto/app , /home/toto/ semble
convenir ....

Bon j'avance :) , je vais essayer d'automatiser tout ça, si après y a des
volontaires je peux les héberger
à titre de test :)

Bon reste la partie Serveur HyperFile qui fonctionne, mais je ne peux pas
m'y connecter à distance ....

Vincent



"Roumegou Eric" news:
Vincent a couché sur son écran :

Par contre mes collègues ingénieurs système ne voulaient pas entendre
parler de webdev et windows , donc la solution
Linux , ils ne jurent que Linux et OpenOffice , notre hébergeur étant
sous unix ( avec la possibilité d'installer un serveur
d'application et serveur hyper file, version démo) cela semblait un bon
compromis, ça ne marche ni en local sous centos ni
chez l'hébergeur avec ubuntu ... j'ai droit maintenant à des : on te
l'avais dit .... et on achètera pas de serveur webdev même si le prix
est faible ( quoique , avec toutes les technologies gratuites, pourquoi
payer ?)



Voilà encore un cas où l'on marche sur la tête. C'est la "technique" qui
dicte la solution, le matos sur le fonctionnel, le barbu sur
l'utilisateur.

et oui "on te l'avait dit ..."
qu'est ce que je suis heureux maintenant que je suis débarrassé de ceux
qui ont toujours raison ^^

--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)




Roumegou Eric
Le #16528831
didier a couché sur son écran :
C'est vrai que quelques fois, la technique ( réseaux et systèmes ) pensent
qu'il n'y a que eux qui compte.
Fort heureusement, la gestion informatique et les logiciels sont la raison
d'être du système :)

BONNE NOUVELLE :) j'ai reussi à déployer un site sur Linux, je ne sais pas
trop comment :)
j'ai suprimmé tous les fichiers du compte ( j'ai aussi laisser tomber les rep
data et app )
Les chemins à indiquer dans le gestionnaire de compte semblent causer
problème si du genre
/home/toto/ ; /home/toto/data et /home/toto/app , /home/toto/ semble convenir
....

Bon j'avance :) , je vais essayer d'automatiser tout ça, si après y a des
volontaires je peux les héberger
à titre de test :)

Bon reste la partie Serveur HyperFile qui fonctionne, mais je ne peux pas m'y
connecter à distance ....




les ports 4900 et 4999 sont ils ouverts sur le firewall ?




--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)
Vincent
Le #16540051
BEN c'est à nouveau en croix (:(:(:(:(:

j'ai voulu, deplacer le home du user, je l'ai remis en place et ca plait pas
;)

je vois dans les logs que le serveur webdev fait un chroot sur le home du
user concerné,
ca sert à quoi ?

si je fais chroot /home/toto en tant que root un message dit cannot run
command 'binbash'
si je fait chroot /home/toto en tant que toto un message dit chroot command
not found

comment fait le serveur webdev ?? c'est peut être là que ça coince ?

c'est galère


"Roumegou Eric" news:
didier a couché sur son écran :
C'est vrai que quelques fois, la technique ( réseaux et systèmes )
pensent qu'il n'y a que eux qui compte.
Fort heureusement, la gestion informatique et les logiciels sont la
raison d'être du système :)

BONNE NOUVELLE :) j'ai reussi à déployer un site sur Linux, je ne sais
pas trop comment :)
j'ai suprimmé tous les fichiers du compte ( j'ai aussi laisser tomber les
rep data et app )
Les chemins à indiquer dans le gestionnaire de compte semblent causer
problème si du genre
/home/toto/ ; /home/toto/data et /home/toto/app , /home/toto/ semble
convenir ....

Bon j'avance :) , je vais essayer d'automatiser tout ça, si après y a des
volontaires je peux les héberger
à titre de test :)

Bon reste la partie Serveur HyperFile qui fonctionne, mais je ne peux pas
m'y connecter à distance ....




les ports 4900 et 4999 sont ils ouverts sur le firewall ?




--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)




Vincent
Le #16541011
je continue mon histoire presque en solo, il est possible que se soit plutôt
le ftp qui fasse un chroot .... avec un outil classique de ftp
je tombe sur le home .... sans pouvoir aller ailleur.

Je cherche pourquoi je ne peux plus déployer, ça doit être un petit truc
bien vicelard, dommage que le système de déployement ne soit pas plus
détaillés dans ces logs.

"Vincent" news:48a30b1a$0$935$
BEN c'est à nouveau en croix (:(:(:(:(:

j'ai voulu, deplacer le home du user, je l'ai remis en place et ca plait
pas ;)

je vois dans les logs que le serveur webdev fait un chroot sur le home du
user concerné,
ca sert à quoi ?

si je fais chroot /home/toto en tant que root un message dit cannot run
command 'binbash'
si je fait chroot /home/toto en tant que toto un message dit chroot
command not found

comment fait le serveur webdev ?? c'est peut être là que ça coince ?

c'est galère


"Roumegou Eric" news:
didier a couché sur son écran :
C'est vrai que quelques fois, la technique ( réseaux et systèmes )
pensent qu'il n'y a que eux qui compte.
Fort heureusement, la gestion informatique et les logiciels sont la
raison d'être du système :)

BONNE NOUVELLE :) j'ai reussi à déployer un site sur Linux, je ne sais
pas trop comment :)
j'ai suprimmé tous les fichiers du compte ( j'ai aussi laisser tomber
les rep data et app )
Les chemins à indiquer dans le gestionnaire de compte semblent causer
problème si du genre
/home/toto/ ; /home/toto/data et /home/toto/app , /home/toto/ semble
convenir ....

Bon j'avance :) , je vais essayer d'automatiser tout ça, si après y a
des volontaires je peux les héberger
à titre de test :)

Bon reste la partie Serveur HyperFile qui fonctionne, mais je ne peux
pas m'y connecter à distance ....




les ports 4900 et 4999 sont ils ouverts sur le firewall ?




--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)







Publicité
Poster une réponse
Anonyme