Le serveur X perturbe les consoles textuelles

Le
Dominique MICOLLET
bonjour

Soit un acer aspire 7730GZ équipé d'une debian/lenny "genuine".
La carte graphique est une nvidia 9300M GS

Le démarrage du serveur X met la pagaille dans les consoles textuelles de
tty1 à 6.

Si je n'installe pas le driver spécifique nvidia procurant la 3D, la
perturbation consiste en un changement de la fonte utilisée qui devient la
fonte IBM du temps de MSDOS (avec les caractères permettant de tracer des
cadres).

Si j'installe le driver spécifique nvidia procurant la 3D, la perturbation
consiste en une disparition de l'affichage. Les consoles sont cependant
toujours actives car le CTRL-ALT-DEL provoque l'arrêt normal de la machine
(sans les messages d'erreur toutefois).

Est ce que cela évoque quelque chose à quelqu'un ?


--
Dominique MICOLLET
Adresse email : enlever deux francs
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
  • Le smartphone Sony Xperia X voit sa résistance aux immersions testée durant deux ...
  • Présentation du Wendelstein 7-X le réacteur à fusion nucléaire le plus grand jamais ...
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Kevin Denis
Le #19687271
Le 03-07-2009, Dominique MICOLLET a écrit :
Soit un acer aspire 7730GZ équipé d'une debian/lenny "genuine".
La carte graphique est une nvidia 9300M GS

Le démarrage du serveur X met la pagaille dans les consoles textuelles de
tty1 à 6.

Si je n'installe pas le driver spécifique nvidia procurant la 3D, la
perturbation consiste en un changement de la fonte utilisée qui devient la
fonte IBM du temps de MSDOS (avec les caractères permettant de tracer des
cadres).

Si j'installe le driver spécifique nvidia procurant la 3D, la perturbation
consiste en une disparition de l'affichage. Les consoles sont cependant
toujours actives car le CTRL-ALT-DEL provoque l'arrêt normal de la machine
(sans les messages d'erreur toutefois).

Est ce que cela évoque quelque chose à quelqu'un ?



Lorsque cela m'arrive je tape la commande
reset
en aveugle pour récupérer un affichage normal. Ceci dit, je ne sais pas
si ca correspond au pb avec la nvidia
--
Kevin
Nicolas George
Le #19687501
Dominique MICOLLET wrote in message
Le démarrage du serveur X met la pagaille dans les consoles textuelles de
tty1 à 6.



Il va falloir s'y faire : le mode texte est en voie de disparition, le
support, logiciel comme matériel, va se déliter progressivement jusqu'à
disparaître complètement. Ça arrivera plus tard pour les drivers libres,
mais quand le matériel ne pourra plus...
Mihamina Rakotomandimby
Le #19687661
07/03/2009 02:23 PM, Nicolas George::
Il va falloir s'y faire : le mode texte est en voie de disparition,



"mode texte" qui passe par la carte graphique?
Parceque je pense que la console (sur les serveurs) a encore de beaux jours devant elle.
Pascal Hambourg
Le #19687701
Salut,

Nicolas George a écrit :

Il va falloir s'y faire : le mode texte est en voie de disparition, le
support, logiciel comme matériel, va se déliter progressivement jusqu'à
disparaître complètement.



Tu parles seulement du mode caractère pur ou de tout ce qui est
affichage non X, incluant le framebuffer ? Après tout il me semble que
certaines architectures comme Mac ou Sun n'ont pas d'affichage en mode
caractère mais seulement un framebuffer. Je ne serais pas
fondamentalement opposé au remplacement définitif du mode caractère par
le framebuffer pour l'architecture PC, mais à condition que ce soit
standard sur toutes les machines de l'architecture comme peut l'être le
mode caractère 80*25.
Erwan David
Le #19687851
Nicolas George
Dominique MICOLLET wrote in message
Le démarrage du serveur X met la pagaille dans les consoles textuelles de
tty1 à 6.



Il va falloir s'y faire : le mode texte est en voie de disparition, le
support, logiciel comme matériel, va se déliter progressivement jusqu'à
disparaître complètement. Ça arrivera plus tard pour les drivers libres,
mais quand le matériel ne pourra plus...



Ce qui est une connerie sans nom, parceque franchement le serveur
graphique fout la merde quand on n'en a pas besoin.

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
JKB
Le #19687841
Le 03-07-2009, ? propos de
Re: Le serveur X perturbe les consoles textuelles,
Erwan David ?crivait dans fr.comp.os.linux.configuration :
Nicolas George
Dominique MICOLLET wrote in message
Le démarrage du serveur X met la pagaille dans les consoles textuelles de
tty1 à 6.



Il va falloir s'y faire : le mode texte est en voie de disparition, le
support, logiciel comme matériel, va se déliter progressivement jusqu'à
disparaître complètement. Ça arrivera plus tard pour les drivers libres,
mais quand le matériel ne pourra plus...



Ce qui est une connerie sans nom, parceque franchement le serveur
graphique fout la merde quand on n'en a pas besoin.



Et lorsqu'on a une superbe XVR500 qui n'est supporté par aucun
pilote (sauf le fb texte du noyau...)...

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
Dominique MICOLLET
Le #19688051
Dominique MICOLLET wrote:

Si je n'installe pas le driver spécifique nvidia procurant la 3D, la
perturbation consiste en un changement de la fonte utilisée qui devient la
fonte IBM du temps de MSDOS (avec les caractères permettant de tracer des
cadres).




J'ai un peu progressé.

En forçant la résolution dans le noyau (vga=0x365), ce problème là a
disparu.

Par contre le driver3D fait toujours disparaître l'affichage des consoles
texte.


--
Dominique MICOLLET
Adresse email : enlever deux francs
Pierre Maurette
Le #19688161
Dominique MICOLLET, le 03/07/2009 a écrit :
bonjour

Soit un acer aspire 7730GZ équipé d'une debian/lenny "genuine".
La carte graphique est une nvidia 9300M GS

Le démarrage du serveur X met la pagaille dans les consoles textuelles de
tty1 à 6.

Si je n'installe pas le driver spécifique nvidia procurant la 3D, la
perturbation consiste en un changement de la fonte utilisée qui devient la
fonte IBM du temps de MSDOS (avec les caractères permettant de tracer des
cadres).

Si j'installe le driver spécifique nvidia procurant la 3D, la perturbation
consiste en une disparition de l'affichage. Les consoles sont cependant
toujours actives car le CTRL-ALT-DEL provoque l'arrêt normal de la machine
(sans les messages d'erreur toutefois).

Est ce que cela évoque quelque chose à quelqu'un ?



Vaguement. Sur une Ubuntu bricolée pouir démarrer "normalement", c'est
à dire en mode console, runlevel 3 pour parler à la RedHat. Quand je
lançais le X par startX, ça mettait les consoles en bordel, il me
semble comme vous dans le cas avec driver nvidia. Si je lançais par
sudo /etc/init.d/gdm start, tout fonctionnait correctement. Je n'avais
pas cherché plus loin, mais il semble clair que dans les deux cas on ne
passe par par les mêmes fichiers de configuration. Peut-être ça pourra
vous aider ?

Je crois que je vais définitivement renoncer à faire de Linux mon
système de "productivité personnelle", donc certainement à son mode
graphique. D'ailleurs la machine Ubuntu dont je parlais s'est trouvée
nettoyée de ses couches graphiques et de tout ce qui allait avec, puis
privée de son clavier et de son écran. Pour aujourd'hui ne plus être
mise sous tension du tout, au profit de Debian texte standalone ou dans
des VirtualBox. Et comme mettre au point un affichage correct lance la
machine à perdre du temps - idem pour du DOS, d'ailleurs - je ne me
connecte plus qu'en SSH, dans un beau terminal, PuTTY ou une console
sous Linux. Je ne sais pas pourquoi vous avez besoin des consoles, mais
vous pourriez peut-être faire ça pour vous dépanner.

--
Pierre Maurette
Dominique MICOLLET
Le #19688281
Dominique MICOLLET wrote:

Dominique MICOLLET wrote:

Si je n'installe pas le driver spécifique nvidia procurant la 3D, la
perturbation consiste en un changement de la fonte utilisée qui devient
la fonte IBM du temps de MSDOS (avec les caractères permettant de tracer
des cadres).




J'ai un peu progressé.

En forçant la résolution dans le noyau (vga=0x365), ce problème là a
disparu.



J'ai écrit trop vite : si l'on ne lance que le serveur X tout va bien.
Si on travaille un tant soit peu dans un environnement graphique (kde ou
icewm) à la déconnexion le serveur X ne se relance plus.

Par contre avec un serveur vesa tout va bien.

Il semble donc que les serveurs nv ou nvidia soit buggés, ou que ma machine
a un matériel ésotérique.

--
Dominique MICOLLET
Adresse email : enlever deux francs
Nicolas George
Le #19688861
Erwan David wrote in message
Ce qui est une connerie sans nom, parceque franchement le serveur
graphique fout la merde quand on n'en a pas besoin.



Soit je ne comprends pas ce que tu veux dire, soit tu n'as pas compris ce
que j'ai dit.
Publicité
Poster une réponse
Anonyme