Un service, mais lequel ?

Le
Gloops
Bonjour tout le monde,

Pour installer le pilote de mon téléphone portable pour le synchronis=
er
avec MyPhoneExplorer, je n'ai trouvé comme moyen que d'installer dans u=
n
premier temps la suite Sony Ericsson, qui va bien tant qu'on est
administrateur mais ne connaît pas la notion d'utilisateur limité
Windows, contrairement à MyPhoneExplorer qui n'a aucun problème avec =
ça.

J'ai déjà fait ça plusieurs fois sans problème, mais sur ma nouve=
lle
config je me retrouve avec un problème à chaque démarrage : erreur =
de
droits d'accès sur epmworker, pendant le démarrage de la session de
l'utilisateur limité. epmworker, c'est le CAPI_Worker module, de Sony
Ericsson. Il est vrai que j'ai téléchargé ça hier, il y a peut-ê=
tre bien
une nouvelle version.

Comme Starter, de CodeStuff, ne le trouve pas au démarrage, j'ai lancé=

Process Explorer, de SysInternals.

Voilà l'arborescence :
winlogon.exe 860
services.exe 904 2.17
svchost.exe 1072
epmworker.exe 1516
CAPI_Worker Module
Sony Ericsson Mobile Communications AB
dwwin.exe 1296
Microsoft Application Error Reporting
Microsoft Corporation

Bon, alors il est lancé en service.
Très bien, mais dans les services, je double-clique sur tout ce qui est=

démarré, mais je n'en vois aucun qui déclare appartenir à Sony, o=
u qui
ait CAPI ou Sony dans son intitulé, ou encore epm. Et pourtant je prend=
s
soin de regarder ça avant d'avoir validé le message de Dr Watson.

Comment je fais-je ?
Désactiver tous les services puis les réactiver un par un jusqu'à c=
e que
ça bronche ? Ou il y a plus élégant que cela ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ascadix
Le #22166241
Gloops a exprimé avec précision :
Bonjour tout le monde,

Pour installer le pilote de mon téléphone portable pour le synchroniser avec
MyPhoneExplorer, je n'ai trouvé comme moyen que d'installer dans un premier
temps la suite Sony Ericsson, qui va bien tant qu'on est administrateur mais
ne connaît pas la notion d'utilisateur limité Windows, contrairement à
MyPhoneExplorer qui n'a aucun problème avec ça.

J'ai déjà fait ça plusieurs fois sans problème, mais sur ma nouvelle config
je me retrouve avec un problème à chaque démarrage : erreur de droits d'accès
sur epmworker, pendant le démarrage de la session de l'utilisateur limité.
epmworker, c'est le CAPI_Worker module, de Sony Ericsson. Il est vrai que
j'ai téléchargé ça hier, il y a peut-être bien une nouvelle version.

Comme Starter, de CodeStuff, ne le trouve pas au démarrage, j'ai lancé
Process Explorer, de SysInternals.

Voilà l'arborescence :
winlogon.exe 860
services.exe 904 2.17
svchost.exe 1072
epmworker.exe 1516
CAPI_Worker Module
Sony Ericsson Mobile Communications AB
dwwin.exe 1296
Microsoft Application Error Reporting
Microsoft Corporation

Bon, alors il est lancé en service.
Très bien, mais dans les services, je double-clique sur tout ce qui est
démarré, mais je n'en vois aucun qui déclare appartenir à Sony, ou qui ait
CAPI ou Sony dans son intitulé, ou encore epm. Et pourtant je prends soin de
regarder ça avant d'avoir validé le message de Dr Watson.

Comment je fais-je ?
Désactiver tous les services puis les réactiver un par un jusqu'à ce que ça
bronche ? Ou il y a plus élégant que cela ?



Toujours avec ProcessExplorer, double-clic sur le "svchost.exe" parent
( ici , le PID 1072 ) et regarde l'onglet "services"

Il y a peut-être plusieurs services dans la liste, essaye donc
arréter/redéarer ceux-là pour commencer.

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Gloops
Le #22170751
Ascadix a écrit, le 25/05/2010 18:09 :
Gloops a exprimé avec précision :



Merci ;)

Bon, alors il est lancé en service.
Très bien, mais dans les services, je double-clique sur tout ce qui
est démarré, mais je n'en vois aucun qui déclare appartenir à Sony, ou
qui ait CAPI ou Sony dans son intitulé, ou encore epm. Et pourtant j e
prends soin de regarder ça avant d'avoir validé le message de Dr W atson.

Comment je fais-je ?
Désactiver tous les services puis les réactiver un par un jusqu'à ce
que ça bronche ? Ou il y a plus élégant que cela ?



Toujours avec ProcessExplorer, double-clic sur le "svchost.exe" parent (
ici , le PID 1072 ) et regarde l'onglet "services"

Il y a peut-être plusieurs services dans la liste, essaye donc
arréter/redéarer ceux-là pour commencer.




Le fait est que voilà au moins une interface utile à connaître, mer ci du
tuyau.

Alors là il s'agissait du lanceur de processus serveurs DCOM, et de
Services Terminal Server.

Bon, seulement j'ai désactivé les deux, et ça fait pareil.
Ascadix
Le #22172251
Le 26/05/2010, Gloops a supposé :
Ascadix a écrit, le 25/05/2010 18:09 :
Gloops a exprimé avec précision :



Merci ;)

Bon, alors il est lancé en service.
Très bien, mais dans les services, je double-clique sur tout ce qui
est démarré, mais je n'en vois aucun qui déclare appartenir à Sony, ou
qui ait CAPI ou Sony dans son intitulé, ou encore epm. Et pourtant je
prends soin de regarder ça avant d'avoir validé le message de Dr Watson.

Comment je fais-je ?
Désactiver tous les services puis les réactiver un par un jusqu'àce
que ça bronche ? Ou il y a plus élégant que cela ?



Toujours avec ProcessExplorer, double-clic sur le "svchost.exe" parent (
ici , le PID 1072 ) et regarde l'onglet "services"

Il y a peut-être plusieurs services dans la liste, essaye donc
arréter/redéarer ceux-là pour commencer.




Le fait est que voilà au moins une interface utile à connaître, merci du
tuyau.

Alors là il s'agissait du lanceur de processus serveurs DCOM, et de Services
Terminal Server.



ça peut pas être le 2°, pas la peine d'y toucher.

Bon, seulement j'ai désactivé les deux, et ça fait pareil.



Reste le lanceur DCOM, mais c'est plutot chi...ant pour trouver d'où
arrivent les appels qui déclanchent le démarage d'un sous-process par
ce service-là

Le premier truc à chercher, c'est avec AUTORUNS (de
SYSINTERNALS/TECHNET , à coté de Process Explorer) si il y un autre
soft de Sony/Ericson qui démare sous le compte limité, si t'en tourve,
désative-les c'est peut-être eux qui déclanchent l'appel.

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Gloops
Le #22173211
Ascadix a écrit, le 26/05/2010 20:49 :
Le premier truc à chercher, c'est avec AUTORUNS (de SYSINTERNALS/TECH NET
, à coté de Process Explorer) si il y un autre soft de Sony/Ericson qui
démare sous le compte limité, si t'en tourve, désative-les c'est
peut-être eux qui déclanchent l'appel.




Autoruns, c'est un programme qui fait l'inventaire des programmes lancé s
au démarrage de la session, c'est bien ça ? Est-ce qu'il va en trouve r
plus que Starter ?

Bon je vais voir demain, après avoir géré quelques trucs.
La première chose que j'aie faite, sous Starter, a été de désacti ver la
Sony Ericsson PC Suite. ça, c'était avant d'ouvrir le fil, ici.

Après il reste ctfmon mais celui-là ce n'est pas un nouveau (ah
d'ailleurs je l'ai deux fois, une fois pour l'utilisateur par défaut,
une fois pour l'utilisateur courant -je ne suis pas certain que ça ne
ressemble pas à une erreur, ça, sans toutefois que ça ait un rappor t
avec le sujet du fil).

TclockEx mais je l'ai remis aujourd'hui.

Ah oui il faudra aussi que je fouille dans la partie "tous
utilisateurs". Pour l'administrateur la suite Sony Ericsson fonctionne
bien, ça ne l'empêche pas de coincer en profil limité. Alors la que stion
peut être de voir si il n'y a pas un autre programme dans le même cas ,
qui par coïncidence serait apparu pile au moment où j'ai installé S ony
Ericsson PC Suite.
En décochant tout je tâcherai de penser à faire une exception pour le
kit de sécurité :)
Ascadix
Le #22173191
Gloops a écrit :
Ascadix a écrit, le 26/05/2010 20:49 :
Le premier truc à chercher, c'est avec AUTORUNS (de SYSINTERNALS/TECHNET
, à coté de Process Explorer) si il y un autre soft de Sony/Ericson qui
démare sous le compte limité, si t'en tourve, désative-les c'est
peut-être eux qui déclanchent l'appel.




Autoruns, c'est un programme qui fait l'inventaire des programmes lancés au
démarrage de la session, c'est bien ça ? Est-ce qu'il va en trouver plus que
Starter ?



J'sais pas , j'ai pas joué avec "starter", mais en général, AUTORUNS
trouve tout ce dont j'ai besoin (et comme tous les outils du p'tit père
Russinovitch, c'est plutot baléze comme soft.)

Bon je vais voir demain, après avoir géré quelques trucs.
La première chose que j'aie faite, sous Starter, a été de désactiver la Sony
Ericsson PC Suite. ça, c'était avant d'ouvrir le fil, ici.

Après il reste ctfmon mais celui-là ce n'est pas un nouveau (ah d'ailleurs je
l'ai deux fois, une fois pour l'utilisateur par défaut, une fois pour
l'utilisateur courant -je ne suis pas certain que ça ne ressemble pas à une
erreur, ça, sans toutefois que ça ait un rapport avec le sujet du fil).

TclockEx mais je l'ai remis aujourd'hui.

Ah oui il faudra aussi que je fouille dans la partie "tous utilisateurs".
Pour l'administrateur la suite Sony Ericsson fonctionne bien, ça ne l'empêche
pas de coincer en profil limité. Alors la question peut être de voir si il
n'y a pas un autre programme dans le même cas, qui par coïncidence serait
apparu pile au moment où j'ai installé Sony Ericsson PC Suite.
En décochant tout je tâcherai de penser à faire une exception pour le kit de
sécurité :)



Mouaip, faut p'tet préciser quand même que autoruns est à utiliser avec
un poil de précautions, entre autre, je te conseille d'utiliser
l'option qui masque les éléments "Windows et Microsoft", ça réduit les
risques de clic-qui-tue.

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Gloops
Le #22173391
Ascadix a écrit, le 26/05/2010 23:37 :
J'sais pas , j'ai pas joué avec "starter", mais en général, AUTOR UNS
trouve tout ce dont j'ai besoin (et comme tous les outils du p'tit pè re
Russinovitch, c'est plutot baléze comme soft.)



Oui, j'ai remarqué, c'est une bonne adresse.
D'ailleurs, si Microsoft a racheté ce monde-là, ils avaient leurs rai sons :)
C'est depuis qu'après l'installation on doit cliquer pour dire "promis,
j'utilise, je ne pirate pas", ou un équivalent.

Mouaip, faut p'tet préciser quand même que autoruns est à utilise r avec
un poil de précautions, entre autre, je te conseille d'utiliser l'opt ion
qui masque les éléments "Windows et Microsoft", ça réduit les r isques de
clic-qui-tue.



Bon je vais regarder ça au moins par curiosité.
Gloops
Le #22178911
Ascadix a écrit, le 26/05/2010 20:49 :
Reste le lanceur DCOM, mais c'est plutot chi...ant pour trouver d'où
arrivent les appels qui déclanchent le démarage d'un sous-process p ar ce
service-là



Je confirme que c'est chiant aussi de le désactiver, puisque sa
désactivation empêche par exemple le Windows Installer de fonctionner .
Genre de truc qui peut monter en niveau 2 si on pose la question à un
support technique, c'est mieux si on s'en rend compte avant que le
niveau 2 appelle, pfiou.

Bon maintenant je vais dormir avant de m'occuper de l'Autoruns, parce
que je commence à me mélanger copieusement les pinceaux.
Gloops
Le #22181051
Il y a effectivement un certain nombre d'apports propres à Autoruns. Pa r
exemple le fait de pouvoir comparer à une sauvegarde, ça paraît tou t
bête une fois que c'est dit, mais c'est pourtant vrai que c'est une
sacrée bonne idée.

Et il semble y avoir encore largement de quoi découvrir là-dedans.
J'ajoute donc Autoruns à l'épaisse pile de ce que j'ai à potasser.

Une recherche de "Sony" dans la catégorie Everything donne ceci :


---------- AUTORUNS.TXT
X "Gestionnaire de fichiers Sony Ericsson" "Explorer browser
application fo
r mobile devices." "Popwire AB" "c:program filessony
ericssonmobile2
file managerfm.dll"
X "Gestionnaire de fichiers Sony Ericsson" "Explorer browser
application fo
r mobile devices." "Popwire AB" "c:program filessony
ericssonmobile2
file managerfm.dll"
+ "s116bus" "Sony Ericsson Device 116 Driver" "MCCI Corporation "
"c:windowssystem32driverss116bus.sys"
+ "s116mdfl" "Sony Ericsson Device 116 USB WMC Modem Filter" "MCCI
Corporatio
n" "c:windowssystem32driverss116mdfl.sys"
+ "s116mdm" "Sony Ericsson Device 116 USB WMC Modem Driver" "MCCI
Corporatio
n" "c:windowssystem32driverss116mdm.sys"
+ "s116mgmt" "Sony Ericsson Device 116 USB WMC Device Management
Drivers (WD
M)" "MCCI Corporation" "c:windowssystem32driverss116mgmt.sys "
+ "s116nd5" "Sony Ericsson Device 116 USB Ethernet Emulation (NDIS 5
Minipor
t)" "MCCI Corporation" "c:windowssystem32driverss116nd5.sys"
+ "s116obex" "Sony Ericsson Device 116 USB WMC OBEX Interface"
"MCCI Co
rporation" "c:windowssystem32driverss116obex.sys"
+ "s116unic" "Sony Ericsson Device 116 USB Ethernet Emulation"
"MCCI Co
rporation" "c:windowssystem32driverss116unic.sys"


Ce n'est pas très beau, en fait j'ai refait une recherche après expor t
alors je ne me suis pas embêté, j'ai utilisé le FIND du mode ligne de
commandes. Je pense qu'on doit quand même pouvoir trouver ses petits
même si je ne me suis pas embêté à reformater.

En tête on voit deux éléments de la catégorie "explorer", que j'a urais
donc plus ou moins tendance à classer comme extensions de l'explorateur ,
il faut voir jusqu'à quel point je me trompe là-dessus (clés de
l'arborescence HKCRCLSID), publiés par PopWire AB, et que je reconnais
par leur chemin d'accès. Je suis intrigué par les croix au début de la
ligne d'export, alors que dans l'interface j'ai décoché ces deux lign es.
Ces deux lignes permettent à l'explorateur de présenter les fichiers se
trouvant dans le téléphone.

Dans l'interface ces deux croix ne sont plus cochées, pourtant le
message d'erreur apparaît toujours au démarrage de session.

La suite est constituée de fichiers d'extension sys se trouvant dans le
répertoire C:WindowsSystem32drivers, j'aurais donc tendance à pens er
que si je veux que MyPhoneExplorer fonctionne j'ai intérêt à les la isser
actifs.

J'imagine qu'une fois que j'aurai bien potassé l'aide d'Autoruns je
pourrai trouver une solution propre. En attendant, en "trichant" un peu,
j'en ai trouvé une assez rapide : j'ai renommé le programme epmworker ,
comme ça l'application qui le lançait ne l'a pas trouvé, et plus
personne ne m'embête. Et MyPhoneExplorer fonctionne.

En espérant que Sony ne soit pas à l'affut des messages sur le sujet
pour maintenant avec la prochaine version lever une exception si on ne
trouve pas le programme.

Sinon c'est vrai qu'il y avait une autre solution c'était de plonger
dans mes sauvegardes pour retrouver la version précédente, qui ne pos ait
pas de problème. Il est vrai que si j'avais fait ça je n'aurais pas f ait
un tour sur SysInternals ce matin. Du coup je n'aurais pas non plus
découvert BgInfo, qui ne traite pas le même sujet, permet d'afficher des
infos système sur le bureau, mais enfin ça, à l'occasion, ça peut aussi
être bon à connaître.

Merci pour ce remue-méninges, comme on dit joliment au Nord de
l'Amérique, même si finalement je m'en suis tiré par une pirouette, et
je mettrai en ½uvre plus tard, plus à fond, la solution que tu propos es.
______________________________________
Ascadix a écrit, le 26/05/2010 23:37 :
Gloops a écrit :
Ascadix a écrit, le 26/05/2010 20:49 :
Le premier truc à chercher, c'est avec AUTORUNS (de SYSINTERNALS/TE CHNET
, à coté de Process Explorer) si il y un autre soft de Sony/Erics on qui
démare sous le compte limité, si t'en tourve, désative-les c'es t
peut-être eux qui déclanchent l'appel.




Autoruns, c'est un programme qui fait l'inventaire des programmes
lancés au démarrage de la session, c'est bien ça ? Est-ce qu'il va en
trouver plus que Starter ?



J'sais pas , j'ai pas joué avec "starter", mais en général, AUTOR UNS
trouve tout ce dont j'ai besoin (et comme tous les outils du p'tit pè re
Russinovitch, c'est plutot baléze comme soft.)

Bon je vais voir demain, après avoir géré quelques trucs.
La première chose que j'aie faite, sous Starter, a été de désa ctiver
la Sony Ericsson PC Suite. ça, c'était avant d'ouvrir le fil, ici.

Après il reste ctfmon mais celui-là ce n'est pas un nouveau (ah
d'ailleurs je l'ai deux fois, une fois pour l'utilisateur par défaut ,
une fois pour l'utilisateur courant -je ne suis pas certain que ça n e
ressemble pas à une erreur, ça, sans toutefois que ça ait un rap port
avec le sujet du fil).

TclockEx mais je l'ai remis aujourd'hui.

Ah oui il faudra aussi que je fouille dans la partie "tous
utilisateurs". Pour l'administrateur la suite Sony Ericsson fonctionne
bien, ça ne l'empêche pas de coincer en profil limité. Alors la
question peut être de voir si il n'y a pas un autre programme dans l e
même cas, qui par coïncidence serait apparu pile au moment où j' ai
installé Sony Ericsson PC Suite.
En décochant tout je tâcherai de penser à faire une exception po ur le
kit de sécurité :)



Mouaip, faut p'tet préciser quand même que autoruns est à utilise r avec
un poil de précautions, entre autre, je te conseille d'utiliser l'opt ion
qui masque les éléments "Windows et Microsoft", ça réduit les r isques de
clic-qui-tue.

Ascadix
Le #22186011
Il se trouve que Gloops a formulé :
Il y a effectivement un certain nombre d'apports propres à Autoruns. Par
exemple le fait de pouvoir comparer à une sauvegarde, ça paraît tout bête une
fois que c'est dit, mais c'est pourtant vrai que c'est une sacrée bonne idée.

Et il semble y avoir encore largement de quoi découvrir là-dedans. J'ajoute
donc Autoruns à l'épaisse pile de ce que j'ai à potasser.

Une recherche de "Sony" dans la catégorie Everything donne ceci :


---------- AUTORUNS.TXT
X "Gestionnaire de fichiers Sony Ericsson" "Explorer browser application
fo
r mobile devices." "Popwire AB" "c:program filessony
ericssonmobile2
file managerfm.dll"
X "Gestionnaire de fichiers Sony Ericsson" "Explorer browser application
fo
r mobile devices." "Popwire AB" "c:program filessony
ericssonmobile2
file managerfm.dll"
+ "s116bus" "Sony Ericsson Device 116 Driver" "MCCI Corporation"
"c:windowssystem32driverss116bus.sys"
+ "s116mdfl" "Sony Ericsson Device 116 USB WMC Modem Filter" "MCCI
Corporatio
n" "c:windowssystem32driverss116mdfl.sys"
+ "s116mdm" "Sony Ericsson Device 116 USB WMC Modem Driver" "MCCI
Corporatio
n" "c:windowssystem32driverss116mdm.sys"
+ "s116mgmt" "Sony Ericsson Device 116 USB WMC Device Management Drivers
(WD
M)" "MCCI Corporation" "c:windowssystem32driverss116mgmt.sys"
+ "s116nd5" "Sony Ericsson Device 116 USB Ethernet Emulation (NDIS 5
Minipor
t)" "MCCI Corporation" "c:windowssystem32driverss116nd5.sys"
+ "s116obex" "Sony Ericsson Device 116 USB WMC OBEX Interface" "MCCI Co
rporation" "c:windowssystem32driverss116obex.sys"
+ "s116unic" "Sony Ericsson Device 116 USB Ethernet Emulation" "MCCI Co
rporation" "c:windowssystem32driverss116unic.sys"


Ce n'est pas très beau, en fait j'ai refait une recherche après export alors
je ne me suis pas embêté, j'ai utilisé le FIND du mode ligne de commandes. Je
pense qu'on doit quand même pouvoir trouver ses petits même si je ne me suis
pas embêté à reformater.

En tête on voit deux éléments de la catégorie "explorer", que j'aurais donc
plus ou moins tendance à classer comme extensions de l'explorateur, il faut
voir jusqu'à quel point je me trompe là-dessus (clés de l'arborescence
HKCRCLSID), publiés par PopWire AB, et que je reconnais par leur chemin
d'accès. Je suis intrigué par les croix au début de la ligne d'export, alors
que dans l'interface j'ai décoché ces deux lignes. Ces deux lignes permettent
à l'explorateur de présenter les fichiers se trouvant dans le téléphone.

Dans l'interface ces deux croix ne sont plus cochées, pourtant le message
d'erreur apparaît toujours au démarrage de session.

La suite est constituée de fichiers d'extension sys se trouvant dans le
répertoire C:WindowsSystem32drivers, j'aurais donc tendance à penser que
si je veux que MyPhoneExplorer fonctionne j'ai intérêt à les laisser actifs.



Déduction logique :-)
p'tet que les "*modem*" ne sont pas indispensables, mias ça coute rien
de ne pas prendre de risque avec.

J'imagine qu'une fois que j'aurai bien potassé l'aide d'Autoruns je pourrai
trouver une solution propre. En attendant, en "trichant" un peu, j'en ai
trouvé une assez rapide : j'ai renommé le programme epmworker, comme ça
l'application qui le lançait ne l'a pas trouvé, et plus personne ne m'embête.
Et MyPhoneExplorer fonctionne.

En espérant que Sony ne soit pas à l'affut des messages sur le sujet pour
maintenant avec la prochaine version lever une exception si on ne trouve pas
le programme.

Sinon c'est vrai qu'il y avait une autre solution c'était de plonger dans mes
sauvegardes pour retrouver la version précédente, qui ne posait pas de
problème. Il est vrai que si j'avais fait ça je n'aurais pas fait un tour sur
SysInternals ce matin. Du coup je n'aurais pas non plus découvert BgInfo, qui
ne traite pas le même sujet, permet d'afficher des infos système sur le
bureau, mais enfin ça, à l'occasion, ça peut aussi être bon à connaître.

Merci pour ce remue-méninges, comme on dit joliment au Nord de l'Amérique,
même si finalement je m'en suis tiré par une pirouette, et je mettrai en
½uvre plus tard, plus à fond, la solution que tu proposes.



Si t'aime bien fouiller, tu peut aller voir avec ProcessMonitor ( à
récupérer dans le même coin que ProcessExplorer et Autoruns
Mais il crache des dizaines/centaines de lignes de log par secondes,
donc faut être patient et jouer avec les filtres pour décortiquer ça ..

L'intéret c'est qu'il choppe même les création /destruction de process
qui durent moins d'1/2 secondes et sont donc peu visible avec
ProcessExplorer

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Gloops
Le #22186531
Ascadix a écrit, le 29/05/2010 17:08 :
Il se trouve que Gloops a formulé :
Il y a effectivement un certain nombre d'apports propres à Autoruns.
Par exemple le fait de pouvoir comparer à une sauvegarde, ça paraî t
tout bête une fois que c'est dit, mais c'est pourtant vrai que c'est
une sacrée bonne idée.

Et il semble y avoir encore largement de quoi découvrir là-dedans.
J'ajoute donc Autoruns à l'épaisse pile de ce que j'ai à potasse r.

Une recherche de "Sony" dans la catégorie Everything donne ceci :


---------- AUTORUNS.TXT
X "Gestionnaire de fichiers Sony Ericsson" "Explorer browser
application fo
r mobile devices." "Popwire AB" "c:program filessony ericssonmobile 2
file managerfm.dll"
X "Gestionnaire de fichiers Sony Ericsson" "Explorer browser
application fo
r mobile devices." "Popwire AB" "c:program filessony ericssonmobile 2
file managerfm.dll"
+ "s116bus" "Sony Ericsson Device 116 Driver" "MCCI Corporation"
"c:windowssystem32driverss116bus.sys"
+ "s116mdfl" "Sony Ericsson Device 116 USB WMC Modem Filter" "MCCI
Corporatio
n" "c:windowssystem32driverss116mdfl.sys"
+ "s116mdm" "Sony Ericsson Device 116 USB WMC Modem Driver" "MCCI
Corporatio
n" "c:windowssystem32driverss116mdm.sys"
+ "s116mgmt" "Sony Ericsson Device 116 USB WMC Device Management
Drivers (WD
M)" "MCCI Corporation" "c:windowssystem32driverss116mgmt.sys"
+ "s116nd5" "Sony Ericsson Device 116 USB Ethernet Emulation (NDIS 5
Minipor
t)" "MCCI Corporation" "c:windowssystem32driverss116nd5.sys"
+ "s116obex" "Sony Ericsson Device 116 USB WMC OBEX Interface" "MCCI C o
rporation" "c:windowssystem32driverss116obex.sys"
+ "s116unic" "Sony Ericsson Device 116 USB Ethernet Emulation" "MCCI C o
rporation" "c:windowssystem32driverss116unic.sys"


Ce n'est pas très beau, en fait j'ai refait une recherche après ex port
alors je ne me suis pas embêté, j'ai utilisé le FIND du mode lig ne de
commandes. Je pense qu'on doit quand même pouvoir trouver ses petits
même si je ne me suis pas embêté à reformater.

En tête on voit deux éléments de la catégorie "explorer", que j'aurais
donc plus ou moins tendance à classer comme extensions de
l'explorateur, il faut voir jusqu'à quel point je me trompe là-des sus
(clés de l'arborescence HKCRCLSID), publiés par PopWire AB, et qu e je
reconnais par leur chemin d'accès. Je suis intrigué par les croix au
début de la ligne d'export, alors que dans l'interface j'ai décoch é
ces deux lignes. Ces deux lignes permettent à l'explorateur de
présenter les fichiers se trouvant dans le téléphone.

Dans l'interface ces deux croix ne sont plus cochées, pourtant le
message d'erreur apparaît toujours au démarrage de session.

La suite est constituée de fichiers d'extension sys se trouvant dans
le répertoire C:WindowsSystem32drivers, j'aurais donc tendance à
penser que si je veux que MyPhoneExplorer fonctionne j'ai intérêt à
les laisser actifs.



Déduction logique :-)
p'tet que les "*modem*" ne sont pas indispensables, mias ça coute rie n
de ne pas prendre de risque avec.

J'imagine qu'une fois que j'aurai bien potassé l'aide d'Autoruns je
pourrai trouver une solution propre. En attendant, en "trichant" un
peu, j'en ai trouvé une assez rapide : j'ai renommé le programme
epmworker, comme ça l'application qui le lançait ne l'a pas trouvé , et
plus personne ne m'embête. Et MyPhoneExplorer fonctionne.

En espérant que Sony ne soit pas à l'affut des messages sur le suj et
pour maintenant avec la prochaine version lever une exception si on ne
trouve pas le programme.

Sinon c'est vrai qu'il y avait une autre solution c'était de plonger
dans mes sauvegardes pour retrouver la version précédente, qui ne
posait pas de problème. Il est vrai que si j'avais fait ça je n'au rais
pas fait un tour sur SysInternals ce matin. Du coup je n'aurais pas
non plus découvert BgInfo, qui ne traite pas le même sujet, permet
d'afficher des infos système sur le bureau, mais enfin ça, à
l'occasion, ça peut aussi être bon à connaître.

Merci pour ce remue-méninges, comme on dit joliment au Nord de
l'Amérique, même si finalement je m'en suis tiré par une pirouet te, et
je mettrai en ½uvre plus tard, plus à fond, la solution que tu pro poses.



Si t'aime bien fouiller, tu peut aller voir avec ProcessMonitor ( à
récupérer dans le même coin que ProcessExplorer et Autoruns
Mais il crache des dizaines/centaines de lignes de log par secondes,
donc faut être patient et jouer avec les filtres pour décortiquer ç a ..

L'intéret c'est qu'il choppe même les création /destruction de pr ocess
qui durent moins d'1/2 secondes et sont donc peu visible avec
ProcessExplorer




Hum, de quoi occuper les longues soirées d'hiver :)
Publicité
Poster une réponse
Anonyme