=SI... encore

Le
Clochard
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J’aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69……. Ex : 69,169, 269=3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 et 299 et le
plus élevé entre 300 et 399
J’ai fouillé parmis mes notes mais je n’arrive pas à formuler mes besoins…

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir.
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
j
Le #4741191
pour le nb de 69 (quelle histoire !)
=SOMME(1*ESTERREUR(CHERCHE("*69*";A1:O1)))
validation en matricielle par CTRL+MAJ+Enter


"Clochard"
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J'aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69... Ex : 69,169, 269=3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 et 299 et
le

plus élevé entre 300 et 399
J'ai fouillé parmis mes notes mais je n'arrive pas à formuler mes besoins.

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir....
Merci!


j
Le #4741181
=MAX(A1:O1*($A1:$O1>100)*($A1:$O1<199))
matricielle à valider par CTRL+MAJ+ENTER



"Clochard"
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J'aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69... Ex : 69,169, 269=3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 et 299 et
le

plus élevé entre 300 et 399
J'ai fouillé parmis mes notes mais je n'arrive pas à formuler mes besoins.

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir....
Merci!


Filochard
Le #4741141
A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301
1 : combien de cellules contiennent le chiffre 69... Ex : 69,169, 269=3


En validant par ctrl+maj+entrée :

=SOMME(1*ESTNUM(TROUVE(69;A1:O1)))

lSteph
Le #4741081
Bonjour Clochard,

;-)
qui va savoir et...
... en saisie normale:

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$I$1;1)>0))*1))

--
LSteph

On 24 sep, 06:14, Clochard
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J'aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69....... Ex : 69,169, 269 =3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 et 299 et le
plus élevé entre 300 et 399
J'ai fouillé parmis mes notes mais je n'arrive pas à formuler mes bes oins...

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir....
Merci!


Clochard
Le #4740721
Merci pour vos réponses... ça fait avancer mon fichier...

Mais aussi, ce que j'aimerais savoir... c'est que j'ai un intervalle de 2
cellules entre chaque série de cellules
Donc j'ai formulé ceci à la suite de la suggèstion de "lSteph" et qui
fonctionne à merveille...

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$C$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$F$1:$H$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$K$1:$M$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$P$1:$R$1;1)>0))*1))

Mais ce n'est que pour 4 semaines... mon prob.. c'est que j'ai 30 semaines
avec seulement trois cellules par semaine sur une ligne.
Une semaine contient 5 cellules.
Dois-je inscrire une formule de 45 mètres de long ou s'il y a un moyen de
simplifier
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour Clochard,

;-)
qui va savoir et...
.... en saisie normale:

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$I$1;1)>0))*1))

--
LSteph

On 24 sep, 06:14, Clochard
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J'aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69....... Ex : 69,169, 269=3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 et 299 et le
plus élevé entre 300 et 399
J'ai fouillé parmis mes notes mais je n'arrive pas à formuler mes besoins...

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir....
Merci!







lSteph
Le #4740701
...

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$R$1;1)>0))*1))

--
LSteph
(à moins que tu n'ais choisi d'écrire 69 dans chacun de ces
intervalles)



On 24 sep, 14:44, Clochard
Merci pour vos réponses... ça fait avancer mon fichier...

Mais aussi, ce que j'aimerais savoir... c'est que j'ai un intervalle de 2
cellules entre chaque série de cellules
Donc j'ai formulé ceci à la suite de la suggèstion de "lSteph" et q ui
fonctionne à merveille...

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$C$1;1)>0))*1))+SOMMEPROD((NON (ESTERR(CHERCHE("69";$F$1:$H$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69 ";$K$1:$M$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$P$1:$R$1;1)>0))* 1))

Mais ce n'est que pour 4 semaines... mon prob.. c'est que j'ai 30 semaines
avec seulement trois cellules par semaine sur une ligne.
Une semaine contient 5 cellules.
Dois-je inscrire une formule de 45 mètres de long ou s'il y a un moyen de
simplifier
--
Clochard
Aimerais bien savoir....
Merci!


Bonjour Clochard,

;-)
qui va savoir et...
.... en saisie normale:

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$I$1;1)>0))*1))

--
LSteph

On 24 sep, 06:14, Clochard
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J'aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69....... Ex : 69,169, 269=3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 et 29 9 et le
plus élevé entre 300 et 399
J'ai fouillé parmis mes notes mais je n'arrive pas à formuler mes besoins...

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir....
Merci!






Clochard
Le #4740601
Steph...

De A1:C1 il y a des chiffres et en D1:E1 des sommes.. il arrive à l'occasion
que les sommes soient de 569 ou autres... je ne dois pas prendre en
considération les montants de ces cellules...

Donc, en A1:C1 excluant D1:E1..... F1:H1, excluant I1:J1.... K1:M1, excluant
N1:O1... ainsi de suite jusqu'à ER1:ET1... excluant EU1:EV1

Suis-je plus compréhensible...
--
Clochard
Aimerais bien savoir....
Merci!



....

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$R$1;1)>0))*1))

--
LSteph
(à moins que tu n'ais choisi d'écrire 69 dans chacun de ces
intervalles)



On 24 sep, 14:44, Clochard
Merci pour vos réponses... ça fait avancer mon fichier...

Mais aussi, ce que j'aimerais savoir... c'est que j'ai un intervalle de 2
cellules entre chaque série de cellules
Donc j'ai formulé ceci à la suite de la suggèstion de "lSteph" et qui
fonctionne à merveille...

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$C$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$F$1:$H$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$K$1:$M$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$P$1:$R$1;1)>0))*1))

Mais ce n'est que pour 4 semaines... mon prob.. c'est que j'ai 30 semaines
avec seulement trois cellules par semaine sur une ligne.
Une semaine contient 5 cellules.
Dois-je inscrire une formule de 45 mètres de long ou s'il y a un moyen de
simplifier
--
Clochard
Aimerais bien savoir....
Merci!


Bonjour Clochard,

;-)
qui va savoir et...
.... en saisie normale:

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$I$1;1)>0))*1))

--
LSteph

On 24 sep, 06:14, Clochard
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J'aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69....... Ex : 69,169, 269=3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 et 299 et le
plus élevé entre 300 et 399
J'ai fouillé parmis mes notes mais je n'arrive pas à formuler mes besoins...

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir....
Merci!











Filochard
Le #4740591
(à moins que tu n'ais choisi d'écrire 69 dans chacun de ces
intervalles)


Ou qu'il y ai quelque part une formule qui renvoie #N/A
car avec avec la solution sommeprod, ça ira pas..... !

http://cjoint.com/?jypAj5PZTB

lSteph
Le #4740571
re,

Alors nomme ta plage et ça marche !

Cordialement.

--
LSteph

On 24 sep, 15:26, Clochard
Steph...

De A1:C1 il y a des chiffres et en D1:E1 des sommes.. il arrive à l'occ asion
que les sommes soient de 569 ou autres... je ne dois pas prendre en
considération les montants de ces cellules...

Donc, en A1:C1 excluant D1:E1..... F1:H1, excluant I1:J1.... K1:M1, exclu ant
N1:O1... ainsi de suite jusqu'à ER1:ET1... excluant EU1:EV1

Suis-je plus compréhensible...
--
Clochard
Aimerais bien savoir....
Merci!


....

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$R$1;1)>0))*1))

--
LSteph
(à moins que tu n'ais choisi d'écrire 69 dans chacun de ces
intervalles)

On 24 sep, 14:44, Clochard
Merci pour vos réponses... ça fait avancer mon fichier...

Mais aussi, ce que j'aimerais savoir... c'est que j'ai un intervalle de 2
cellules entre chaque série de cellules
Donc j'ai formulé ceci à la suite de la suggèstion de "lSteph" et qui
fonctionne à merveille...

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$C$1;1)>0))*1))+SOMMEPROD( (NON(ESTERR(CHERCHE("69";$F$1:$H$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE ("69";$K$1:$M$1;1)>0))*1))+SOMMEPROD((NON(ESTERR(CHERCHE("69";$P$1:$R$1;1)> 0))*1))

Mais ce n'est que pour 4 semaines... mon prob.. c'est que j'ai 30 sem aines
avec seulement trois cellules par semaine sur une ligne.
Une semaine contient 5 cellules.
Dois-je inscrire une formule de 45 mètres de long ou s'il y a un mo yen de
simplifier
--
Clochard
Aimerais bien savoir....
Merci!




Bonjour Clochard,

;-)
qui va savoir et...
.... en saisie normale:

=SOMMEPROD((NON(ESTERR(CHERCHE("69";$A$1:$I$1;1)>0))*1))

--
LSteph

On 24 sep, 06:14, Clochard
Bonsoir,

Sur une ligne de chiffre :

A1 B1 C1 G1 H1 I1 M1 N1 O1
135 169 213 187 269 234 211 69 301

J'aimerais arriver a trouver

1 : combien de cellules contiennent le chiffre 69....... Ex : 69, 169, 269=3
2 : le plus gros chiffre en 100 et 199, le plus gros entre 200 e t 299 et le
plus élevé entre 300 et 399
J'ai fouillé parmis mes notes mais je n'arrive pas à formuler mes besoins...

Avez-vous S.V.P. une idée à me suggérer

Merci

--
Clochard
Aimerais bien savoir....
Merci!










lSteph
Le #4740561
pffff.......




On 24 sep, 15:27, "Filochard"
(à moins que tu n'ais choisi d'écrire 69 dans chacun de ces


intervalles)

Ou qu'il y ai quelque part une formule qui renvoie #N/A
car avec avec la solution sommeprod, ça ira pas..... !

http://cjoint.com/?jypAj5PZTB



Publicité
Poster une réponse
Anonyme