si en formule matricielle

Le
el_bodeguero
Bonjour à tous,
Après la réponse à mon post sur sommeprod en forule matricielle (j'en rêve
encore la nuit), je ne parviens pas à écrire une formule matricielle avec
uniquement SI
exemple:
feuille1
A B
12 toto
14 tata
256 lala

feuille 2
12 je veux qu'il y ait toto
256 je veux qu'il y ait lala
999 je veux qu'il y ait NON trouvé

forcément tres simple mais je trouve pas..
merci a tous.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4316951
Bonjour.
Si 12 est en A1 :
=SI(NB.SI(Feuil1!$A$1:$B$10;A1)=0;"non
trouvé";RECHERCHEV(A1;Feuil1!$A$1:$B$10;2;0))
à recopier vers le bas.
Cordialement.
Daniel
"el_bodeguero" message de news:
Bonjour à tous,
Après la réponse à mon post sur sommeprod en forule matricielle (j'en rêve
encore la nuit), je ne parviens pas à écrire une formule matricielle avec
uniquement SI
exemple:
feuille1
A B
12 toto
14 tata
256 lala

feuille 2
12 je veux qu'il y ait toto
256 je veux qu'il y ait lala
999 je veux qu'il y ait NON trouvé

forcément tres simple mais je trouve pas..
merci a tous.



el_bodeguero
Le #4316871
Merci daniel ca marche. Dieu que c'est bon ces formules matricielles.
Par contre j'ai encore un soucis de syntaxe.

Feuill1
Affaire code Prix complet ?
Affaire1 MAIN
Affaire1 BOUCHE
Affaire2 MAIN


Feuill2
affaire code fourniture prix
Affaire1 MAIN POUCE 425
Affaire1 MAIN INDEX 232
Affaire1 MAIN MAJEUR 0

le résultat que je cherche a abtenir est:
feuill1 pour affaire 1, pour main est "prix non complet"
affaire2/main ne doit pas etre renseigné.
Je tente :
si((feuill2!A1:A3¡)*(feuill2!B1:B3±)*(feuill2!D1:D2=0);"prix non
complet";"prix complet)
mais ca ne marche pas.
j'utilise des formules matricielles avec des sommeprod du style
=SOMMEPROD((eclaté!C$2:C$2000²)*(eclaté!A$2:A$2000¢)*(eclaté!N$2:N$2000)*(eclaté!H$2:H$2000))
si je comprends bien la syntaxe est :
A la ligne correspondate à condition1 ET condition2
je multiplie N(pour la ligne correspondante) à H(pour la ligne correspondante)
ou alors c'est que je ne dois pas comprendre....
Daniel
Le #4316801
Formule matricielle (valideer avec CTRL+MAJ+Entrée) :
=SI(SOMME((Feuill2!$A$1:$A$3¡)*(Feuill2!$B$1:$B$3±)*(Feuill2!$D$1:$D$3=0))>0;"prix
non complet";"prix complet")
Pour la seconde formule, tu peux la décomposer comme suit :
Prends en compte que la condition VRAI se traduit par 1 et la condition FAUX
par 0.
(si eclaté!C$2 = B2 1, sinon 0) multiplié par (si eclaté!A$2 = A2, 1, sinon
0) multiplié par N2. Tu obtiens donc soit 0 soit N2. Cette opération est
répétée pour les lignes 3 à 2000 et tu obtiens la somme des valeurs obtenues
pour chaque ligne.
Daniel
"el_bodeguero" message de news:
Merci daniel ca marche. Dieu que c'est bon ces formules matricielles.
Par contre j'ai encore un soucis de syntaxe.

Feuill1
Affaire code Prix complet ?
Affaire1 MAIN
Affaire1 BOUCHE
Affaire2 MAIN


Feuill2
affaire code fourniture prix
Affaire1 MAIN POUCE 425
Affaire1 MAIN INDEX 232
Affaire1 MAIN MAJEUR 0

le résultat que je cherche a abtenir est:
feuill1 pour affaire 1, pour main est "prix non complet"
affaire2/main ne doit pas etre renseigné.
Je tente :
si((feuill2!A1:A3¡)*(feuill2!B1:B3±)*(feuill2!D1:D2=0);"prix non
complet";"prix complet)
mais ca ne marche pas.
j'utilise des formules matricielles avec des sommeprod du style
=SOMMEPROD((eclaté!C$2:C$2000²)*(eclaté!A$2:A$2000¢)*(eclaté!N$2:N$2000)*(eclaté!H$2:H$2000))
si je comprends bien la syntaxe est :
A la ligne correspondate à condition1 ET condition2
je multiplie N(pour la ligne correspondante) à H(pour la ligne
correspondante)
ou alors c'est que je ne dois pas comprendre....






Publicité
Poster une réponse
Anonyme