si imbriqué et date

Le
j
Bonjour,

J'ai dans une feuille "Param" les données suivantes :

en A3 : =AUJOURDHUI()
en B3 : =A+30 et en nom : avant_90
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_30

Dans une autre feuille "DA" et sur toute la colonne H j'ai mis cette formule
pour avoir la valeur A si la date du jour est a 90 jours en rapport des
dates de la colonne G respective

exemple pour la ligne 4 (j'ai environ 300 lignes)
=SI(G4<avant_30;"C";SI(G4<avant_60;"B";SI(G4>avant_90;"A")))

Mais cela ne marche pas !!
d'ou vient mon erreur

Merci par avance de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #22190511
Ce ne serait pas plutôt ceci :

en A3 : =AUJOURDHUI()
en B3 : =A+30 et en nom : avant_30
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_90

=SI(G4<=avant_30;"C";SI(G4<=avant_60;"B";SI(G4<=avant_90;"A";"Plus de 90
jours")))




"" 4c029dd3$0$18418$
Bonjour,

J'ai dans une feuille "Param" les données suivantes :

en A3 : =AUJOURDHUI()
en B3 : =A+30 et en nom : avant_90
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_30

Dans une autre feuille "DA" et sur toute la colonne H j'ai mis cette formule
pour avoir la valeur A si la date du jour est a 90 jours en rapport des
dates de la colonne G respective

exemple pour la ligne 4 (j'ai environ 300 lignes)
=SI(G4<avant_30;"C";SI(G4<avant_60;"B";SI(G4>avant_90;"A")))

Mais cela ne marche pas !!
d'ou vient mon erreur

Merci par avance de votre aide
Michel__D
Le #22190501
Bonjour,

a écrit :
Bonjour,

J'ai dans une feuille "Param" les données suivantes :

en A3 : =AUJOURDHUI()
en B3 : =A+30 et en nom : avant_90
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_30

Dans une autre feuille "DA" et sur toute la colonne H j'ai mis cette formule
pour avoir la valeur A si la date du jour est a 90 jours en rapport des
dates de la colonne G respective

exemple pour la ligne 4 (j'ai environ 300 lignes)
=SI(G4<avant_30;"C";SI(G4<avant_60;"B";SI(G4>avant_90;"A")))

Mais cela ne marche pas !!
d'ou vient mon erreur



Tout dépends de ce que tu cherche à faire !

=SI(G4<avant_30;SI(G4<avant_60;SI(G4<avant_90;"A";"B");"C");"D")

SI G4 < avant_90 THEN "A"
SI avant_90 <= G4 < avant_60 THEN "B"
SI avant_60 <= G4 < avant_30 THEN "C"
SI avant_30 <= G4 THEN "D"
Modeste
Le #22190491
Bonsour® "" a écrit> J'ai dans une feuille "Param" les données suivantes
:
en A3 : =AUJOURDHUI()
en B3 : =A+30 et en nom : avant_90
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_30



heu ce ne serait pas plutot :
en B3 : £+30 et en nom : avant_30
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_90

Dans une autre feuille "DA" et sur toute la colonne H j'ai mis cette
formule pour avoir la valeur A si la date du jour est a 90 jours en
rapport des dates de la colonne G respective
exemple pour la ligne 4 (j'ai environ 300 lignes)
=SI(G4<avant_30;"C";SI(G4<avant_60;"B";SI(G4>avant_90;"A")))



=CHOISIR(1+(ENT(AUJOURDHUI()-G4)/30);"A";"B";"C";"D";"E";"F";"G")
ou
=CHOISIR(1+(ENT(AUJOURDHUI()-G4)/30);"-30";"-60";"-90";"-120";"-150";"-180";"-210")
Modeste
Le #22190711
Bonsour® "" 300 lignes)
=SI(G4<avant_30;"C";SI(G4<avant_60;"B";SI(G4>avant_90;"A")))



autre formulation ;o)))
=STXT("ABCDE";EQUIV(ENT(AUJOURDHUI()-G4);{0;30;60;90;120};1);1)

@+
n'oublier pas l'alternative à ce newsgroup moribond :-((
cliquer sur ce lien :
news://ponx.fr/office
identification : v
mot de passe : v

ou bien
cliquer sur ce lien :
http://social.answers.microsoft.com/Forums/fr-FR/officeexcelfr/threads
il faut utiliser un identifiant Microsoft live
j
Le #22191961
Exact j'aurai pu dire ce que je cherche !!!!!

par exemple :

En fonction d'une date en A1 si celle ci est :

a 90 jours de la date d'aujourd'hui on met met la valeur "A" en B1
a 60 jours de la date d'aujourd'hui on met met la valeur "B" en B1
a 30 jours de la date d'aujourd'hui on met met la valeur "C" en B1

J'ai voulu le faire sous forme de nom pour modifier tres facilement les
90,60,30 jours a d'autres intervalles comme 120,90,45 jours

Merci déjà pour vos réponses




"Michel__D" news:
Bonjour,

a écrit :
Bonjour,

J'ai dans une feuille "Param" les données suivantes :

en A3 : =AUJOURDHUI()
en B3 : =A+30 et en nom : avant_90
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_30

Dans une autre feuille "DA" et sur toute la colonne H j'ai mis cette
formule pour avoir la valeur A si la date du jour est a 90 jours en
rapport des dates de la colonne G respective

exemple pour la ligne 4 (j'ai environ 300 lignes)
=SI(G4<avant_30;"C";SI(G4<avant_60;"B";SI(G4>avant_90;"A")))

Mais cela ne marche pas !!
d'ou vient mon erreur



Tout dépends de ce que tu cherche à faire !

=SI(G4<avant_30;SI(G4<avant_60;SI(G4<avant_90;"A";"B");"C");"D")

SI G4 < avant_90 THEN "A"
SI avant_90 <= G4 < avant_60 THEN "B"
SI avant_60 <= G4 < avant_30 THEN "C"
SI avant_30 <= G4 THEN "D"
Daniel.C
Le #22192591
Bonjour.
=INDEX({"C";"B";"A"};EQUIV(A1-AUJOURDHUI();B1:B4;1))
La plage B1:B4 contient :30,60,90,10000. Tu peux nommer cette plage.
Daniel

Exact j'aurai pu dire ce que je cherche !!!!!

par exemple :

En fonction d'une date en A1 si celle ci est :

a 90 jours de la date d'aujourd'hui on met met la valeur "A" en B1
a 60 jours de la date d'aujourd'hui on met met la valeur "B" en B1
a 30 jours de la date d'aujourd'hui on met met la valeur "C" en B1

J'ai voulu le faire sous forme de nom pour modifier tres facilement les
90,60,30 jours a d'autres intervalles comme 120,90,45 jours

Merci déjà pour vos réponses




"Michel__D" news:
Bonjour,

a écrit :
Bonjour,

J'ai dans une feuille "Param" les données suivantes :

en A3 : =AUJOURDHUI()
en B3 : =A+30 et en nom : avant_90
en C3 : £+60 et en nom : avant_60
en D3 : £+90 et en nom : avant_30

Dans une autre feuille "DA" et sur toute la colonne H j'ai mis cette
formule pour avoir la valeur A si la date du jour est a 90 jours en
rapport des dates de la colonne G respective

exemple pour la ligne 4 (j'ai environ 300 lignes)
=SI(G4<avant_30;"C";SI(G4<avant_60;"B";SI(G4>avant_90;"A")))

Mais cela ne marche pas !!
d'ou vient mon erreur



Tout dépends de ce que tu cherche à faire !

=SI(G4<avant_30;SI(G4<avant_60;SI(G4<avant_90;"A";"B");"C");"D")

SI G4 < avant_90 THEN "A"
SI avant_90 <= G4 < avant_60 THEN "B"
SI avant_60 <= G4 < avant_30 THEN "C"
SI avant_30 <= G4 THEN "D"
Publicité
Poster une réponse
Anonyme