SI (je savais;je ferais;j'appelle à l'aide)

Le
Bastan
Bonjour,

Deux petites questions
(Ne souriez pas, ça doit être facile pour vous ..)

En fonction du contenu de la cellule A1, j'affiche un message dans ma
cellule (A2 par exemple..).
Exemple:
=SI(GAUCHE(A1;1)="L";"A1 commence par L";"A1 ne commence PAS par L")

Je souhaiterais:
1/ Conditionner également la couleur de A2
2/ Afficher le contenu de A1 en majuscules (ce sont des références, donc
chiffres et lettre mélés), même si on le tape en minuscules

Possible ?
Merci d'avance ;-)
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fredo P.
Le #5385741
Voir ici l'ex .http://cjoint.com/?mhwKupDGNc
En B1:B12>>=SI(A1<>"";SI(GAUCHE(A1;1)="L";" L";"pas L");"")
une mise en forme conditionnelle est appliquée à ces même cellules avec ces
formules:
=ET(A1<>"";GAUCHE(A1;1)<>"l") format bleu
=ET(A1<>"";GAUCHE(A1;1)="l") Format rouge

"Bastan" 4759b5ec$0$27391$
Bonjour,

Deux petites questions
(Ne souriez pas, ça doit être facile pour vous .....)

En fonction du contenu de la cellule A1, j'affiche un message dans ma
cellule (A2 par exemple..).
Exemple:
=SI(GAUCHE(A1;1)="L";"A1 commence par L";"A1 ne commence PAS par L")

Je souhaiterais:
1/ Conditionner également la couleur de A2
2/ Afficher le contenu de A1 en majuscules (ce sont des références, donc
chiffres et lettre mélés), même si on le tape en minuscules...

Possible ?
Merci d'avance ;-)



Fredo P.
Le #5385721
Je le refait
http://cjoint.com/?mhwKupDGNc

En B1:B12>>=SI(A1<>"";SI(GAUCHE(A1;1)="L";" L";"pas L");"")
une mise en forme conditionnelle est appliquée à ces même cellules avec
ces formules:
=ET(A1<>"";GAUCHE(A1;1)<>"l") format bleu
=ET(A1<>"";GAUCHE(A1;1)="l") Format rouge

"Bastan" 4759b5ec$0$27391$
Bonjour,

Deux petites questions
(Ne souriez pas, ça doit être facile pour vous .....)

En fonction du contenu de la cellule A1, j'affiche un message dans ma
cellule (A2 par exemple..).
Exemple:
=SI(GAUCHE(A1;1)="L";"A1 commence par L";"A1 ne commence PAS par L")

Je souhaiterais:
1/ Conditionner également la couleur de A2
2/ Afficher le contenu de A1 en majuscules (ce sont des références, donc
chiffres et lettre mélés), même si on le tape en minuscules...

Possible ?
Merci d'avance ;-)







Bastan
Le #5385701
Merci, rapide et précis ! ;-)
Mais, je reste avec mon pb sur la cellule A1...

Comment faire pour que si je tape par exemple "a125m12", lorsque je valide,
s'affiche "A125M12" ?

Possible ?



"Fredo P." message de news: %
Je le refait
http://cjoint.com/?mhwKupDGNc

En B1:B12>>=SI(A1<>"";SI(GAUCHE(A1;1)="L";" L";"pas L");"")
une mise en forme conditionnelle est appliquée à ces même cellules avec
ces formules:
=ET(A1<>"";GAUCHE(A1;1)<>"l") format bleu
=ET(A1<>"";GAUCHE(A1;1)="l") Format rouge

"Bastan" 4759b5ec$0$27391$
Bonjour,

Deux petites questions
(Ne souriez pas, ça doit être facile pour vous .....)

En fonction du contenu de la cellule A1, j'affiche un message dans ma
cellule (A2 par exemple..).
Exemple:
=SI(GAUCHE(A1;1)="L";"A1 commence par L";"A1 ne commence PAS par L")

Je souhaiterais:
1/ Conditionner également la couleur de A2
2/ Afficher le contenu de A1 en majuscules (ce sont des références, donc
chiffres et lettre mélés), même si on le tape en minuscules...

Possible ?
Merci d'avance ;-)












Tatanka
Le #5385691
Bonsoir,

Pour mettre en majuscules le contenu de A1, tu pourrais
utiliser une macro de feuille. Fais un clic droit sur l'onglet
de ta feuille, clique sur « Visualiser le code » et colle la
macro suivante dans la feuille vierge qui devrait apparaître.

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, [a1]) Is Nothing And Not IsEmpty(Target) Then _
[a1] = UCase([a1])
End Sub

Serge


"Bastan"
Bonjour,

Deux petites questions
(Ne souriez pas, ça doit être facile pour vous .....)

En fonction du contenu de la cellule A1, j'affiche un message dans ma cellule (A2 par exemple..).
Exemple:
=SI(GAUCHE(A1;1)="L";"A1 commence par L";"A1 ne commence PAS par L")

Je souhaiterais:
1/ Conditionner également la couleur de A2
2/ Afficher le contenu de A1 en majuscules (ce sont des références, donc chiffres et lettre mélés), même si on le tape en
minuscules...

Possible ?
Merci d'avance ;-)



Bastan
Le #5385671
Ca marche, MAIS, que pour la cellule A1...
Peut on à la place de A1, "viser" une plage de cellules, ou une colonne, ou
plusieurs colonnes, ou la feuille entière ?

J'ai essayé ... Sans succès...



"Tatanka" %
Bonsoir,

Pour mettre en majuscules le contenu de A1, tu pourrais
utiliser une macro de feuille. Fais un clic droit sur l'onglet
de ta feuille, clique sur « Visualiser le code » et colle la
macro suivante dans la feuille vierge qui devrait apparaître.

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, [a1]) Is Nothing And Not IsEmpty(Target) Then
_
[a1] = UCase([a1])
End Sub

Serge


Tatanka
Le #5385641
Bonsoir,

Un exemple :
Si tu nommes une plage « MaPlage » et si tu ne modifies qu'une
cellule à la fois dans « MaPlage », cette macro devrait convenir :

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Not Intersect(Target, [MaPlage]) Is Nothing And Not IsEmpty(Target) Then _
Target = UCase(Target)
End Sub

Serge


"Bastan"
Ca marche, MAIS, que pour la cellule A1...
Peut on à la place de A1, "viser" une plage de cellules, ou une colonne, ou plusieurs colonnes, ou la feuille entière ?

J'ai essayé ... Sans succès...



"Tatanka"
Bonsoir,

Pour mettre en majuscules le contenu de A1, tu pourrais
utiliser une macro de feuille. Fais un clic droit sur l'onglet
de ta feuille, clique sur « Visualiser le code » et colle la
macro suivante dans la feuille vierge qui devrait apparaître.

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, [a1]) Is Nothing And Not IsEmpty(Target) Then _
[a1] = UCase([a1])
End Sub

Serge






Tatanka
Le #5385611
ReBonsoir,

Tu n'es pas obligé de nommer une plage.
Tu pourrais par exemple utiliser ceci :

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Not Intersect(Target, Range("A1:N20")) Is Nothing And Not IsEmpty(Target) Then _
Target = UCase(Target)
End Sub

et pour toutes les cellules de la feuille, ceci :

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Not IsEmpty(Target) Then Target = UCase(Target)
End Sub

Serge


"Tatanka"
Bonsoir,

Un exemple :
Si tu nommes une plage « MaPlage » et si tu ne modifies qu'une
cellule à la fois dans « MaPlage », cette macro devrait convenir :

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Not Intersect(Target, [MaPlage]) Is Nothing And Not IsEmpty(Target) Then _
Target = UCase(Target)
End Sub

Serge


"Bastan"
Ca marche, MAIS, que pour la cellule A1...
Peut on à la place de A1, "viser" une plage de cellules, ou une colonne, ou plusieurs colonnes, ou la feuille entière ?

J'ai essayé ... Sans succès...



"Tatanka"
Bonsoir,

Pour mettre en majuscules le contenu de A1, tu pourrais
utiliser une macro de feuille. Fais un clic droit sur l'onglet
de ta feuille, clique sur « Visualiser le code » et colle la
macro suivante dans la feuille vierge qui devrait apparaître.

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, [a1]) Is Nothing And Not IsEmpty(Target) Then _
[a1] = UCase([a1])
End Sub

Serge










Bastan
Le #5385601
Impeccable !

Bon, effectivement, ça ne fonctionne qu'en modifiant les cellules une à une.
J'ai essayé un copier/coller des quelques cellule simultanément, là, c'est
non....

Merci beaucoup !

"Tatanka"
Bonsoir,

Un exemple :
Si tu nommes une plage « MaPlage » et si tu ne modifies qu'une
cellule à la fois dans « MaPlage », cette macro devrait convenir :

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Not Intersect(Target, [MaPlage]) Is Nothing And Not IsEmpty(Target)
Then _
Target = UCase(Target)
End Sub

Serge


Bastan
Le #5385591
Effectivement, pas besoin de plage..

"Tatanka"
ReBonsoir,

Tu n'es pas obligé de nommer une plage.
Tu pourrais par exemple utiliser ceci :

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Not Intersect(Target, Range("A1:N20")) Is Nothing And Not
IsEmpty(Target) Then _
Target = UCase(Target)
End Sub

et pour toutes les cellules de la feuille, ceci :

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Not IsEmpty(Target) Then Target = UCase(Target)
End Sub

Serge



Publicité
Poster une réponse
Anonyme