=SI(NBVAL

Le
Cloclo
Bonjour,
Est-ce possible de faire en sorte que 0 soit reconnu comme un nombre entier?

Parce que dans ma formule
=SI(NBVAL(A42:G42)<7;"";SOMME(--ESTNUM(EQUIV(STXT($T$2;{1.3.5.7.9.11.13};2);STXT(V 42;{1.3.5.7.9.11.13};2);0))))
le zéro n'est pas reconnu comme un nombre.

Merci de votre aide et bonne journée

ClaudeC55
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5170991
Bonjour.
Dans quelle cellule se trouve le 0 quui te pose problème ?
Cordialement.
Daniel
"Cloclo"

Bonjour,
Est-ce possible de faire en sorte que 0 soit reconnu comme un nombre
entier?

Parce que dans ma formule
=SI(NBVAL(A42:G42)<7;"";SOMME(--ESTNUM(EQUIV(STXT($T$2;{1.3.5.7.9.11.13};2);STXT(V
42;{1.3.5.7.9.11.13};2);0))))
le zéro n'est pas reconnu comme un nombre.

Merci de votre aide et bonne journée

ClaudeC55


Cloclo
Le #5170941
Merci de me répondre Daniel.C

J'inclus une partie de mon fichier pour que tu vois....

http://cjoint.com/?czrwsO8M1k


Bonjour.
Dans quelle cellule se trouve le 0 quui te pose problème ?
Cordialement.
Daniel
"Cloclo"

Bonjour,
Est-ce possible de faire en sorte que 0 soit reconnu comme un nombre
entier?

Parce que dans ma formule
=SI(NBVAL(A42:G42)<7;"";SOMME(--ESTNUM(EQUIV(STXT($T$2;{1.3.5.7.9.11.13};2);STXT(V
42;{1.3.5.7.9.11.13};2);0))))
le zéro n'est pas reconnu comme un nombre.

Merci de votre aide et bonne journée

ClaudeC55







Daniel.C
Le #5170831
Je vois rien ;-((
Qu'est-ce que tu cherches à calculer ?
Daniel
"Cloclo"
Merci de me répondre Daniel.C

J'inclus une partie de mon fichier pour que tu vois....

http://cjoint.com/?czrwsO8M1k


Bonjour.
Dans quelle cellule se trouve le 0 quui te pose problème ?
Cordialement.
Daniel
"Cloclo" news:


Bonjour,
Est-ce possible de faire en sorte que 0 soit reconnu comme un nombre
entier?

Parce que dans ma formule
=SI(NBVAL(A42:G42)<7;"";SOMME(--ESTNUM(EQUIV(STXT($T$2;{1.3.5.7.9.11.13};2);STXT(V
42;{1.3.5.7.9.11.13};2);0))))
le zéro n'est pas reconnu comme un nombre.

Merci de votre aide et bonne journée

ClaudeC55









Cloclo
Le #5170801
Oh Boy.....

J'sais pas si je peux t'expliquer tout ça par écrit.....

Lorsque j'ai entré 7 chiffes dans les A:G
H inscrit 0 en attendant que j'inscrive les numéro gagant dans K:Q qui se
rapporte à la colonne V en impliquant la colonne T qui va m'inscrire en
colonne I combien de numéro sont identique dans A:G

J'parie que je ne suis pas clair....


Je vois rien ;-((
Qu'est-ce que tu cherches à calculer ?
Daniel
"Cloclo"
Merci de me répondre Daniel.C

J'inclus une partie de mon fichier pour que tu vois....

http://cjoint.com/?czrwsO8M1k


Bonjour.
Dans quelle cellule se trouve le 0 quui te pose problème ?
Cordialement.
Daniel
"Cloclo" news:


Bonjour,
Est-ce possible de faire en sorte que 0 soit reconnu comme un nombre
entier?

Parce que dans ma formule
=SI(NBVAL(A42:G42)<7;"";SOMME(--ESTNUM(EQUIV(STXT($T$2;{1.3.5.7.9.11.13};2);STXT(V
42;{1.3.5.7.9.11.13};2);0))))
le zéro n'est pas reconnu comme un nombre.

Merci de votre aide et bonne journée

ClaudeC55














MichDenis
Le #5170791
| Je vois rien ;-((

Travailles-tu en braille ?
;-)
Daniel.C
Le #5170771
"MichDenis" %
| Je vois rien ;-((

Travailles-tu en braille ?


Non, mais, parfois, beaucoup au feeling...
;-)))
Daniel

Daniel.C
Le #5170761
Ce que ta formulr te donne, c'est le nombre de fois multiplié par 7 ou "00"
(7 substring de deux octets de la cellule T2) est trouvé par la fonction
EQUIV dans la cellule de la colonne V tronçonnée en 7 substrings de deux
caractères. Si tu as une valeur 0 en colonne V, tu obtiens 7 (1*7).
Tout doit s'arranger quand tu remplis la cellule T2.
Daniel
"Cloclo"
Oh Boy.....

J'sais pas si je peux t'expliquer tout ça par écrit.....

Lorsque j'ai entré 7 chiffes dans les A:G
H inscrit 0 en attendant que j'inscrive les numéro gagant dans K:Q qui se
rapporte à la colonne V en impliquant la colonne T qui va m'inscrire en
colonne I combien de numéro sont identique dans A:G

J'parie que je ne suis pas clair....


Je vois rien ;-((
Qu'est-ce que tu cherches à calculer ?
Daniel
"Cloclo" news:

Merci de me répondre Daniel.C

J'inclus une partie de mon fichier pour que tu vois....

http://cjoint.com/?czrwsO8M1k


Bonjour.
Dans quelle cellule se trouve le 0 quui te pose problème ?
Cordialement.
Daniel
"Cloclo" news:


Bonjour,
Est-ce possible de faire en sorte que 0 soit reconnu comme un nombre
entier?

Parce que dans ma formule
=SI(NBVAL(A42:G42)<7;"";SOMME(--ESTNUM(EQUIV(STXT($T$2;{1.3.5.7.9.11.13};2);STXT(V
42;{1.3.5.7.9.11.13};2);0))))
le zéro n'est pas reconnu comme un nombre.

Merci de votre aide et bonne journée

ClaudeC55
















Cloclo
Le #5170741
Où est-ce que tu ne vois rien???


| Je vois rien ;-((

Travailles-tu en braille ?
;-)





Cloclo
Le #5170721
La cellule T s'emplit d'elle même au fur et à mesure que tu inscris les
numéro dans K2:Q2
Pour comprendre... transcris les mêmes chiffres de la ligne A3:G3 dans la
ligne K2:Q2 et tu vas voir la réaction

Cloclo5


Ce que ta formulr te donne, c'est le nombre de fois multiplié par 7 ou "00"
(7 substring de deux octets de la cellule T2) est trouvé par la fonction
EQUIV dans la cellule de la colonne V tronçonnée en 7 substrings de deux
caractères. Si tu as une valeur 0 en colonne V, tu obtiens 7 (1*7).
Tout doit s'arranger quand tu remplis la cellule T2.
Daniel
"Cloclo"
Oh Boy.....

J'sais pas si je peux t'expliquer tout ça par écrit.....

Lorsque j'ai entré 7 chiffes dans les A:G
H inscrit 0 en attendant que j'inscrive les numéro gagant dans K:Q qui se
rapporte à la colonne V en impliquant la colonne T qui va m'inscrire en
colonne I combien de numéro sont identique dans A:G

J'parie que je ne suis pas clair....


Je vois rien ;-((
Qu'est-ce que tu cherches à calculer ?
Daniel
"Cloclo" news:

Merci de me répondre Daniel.C

J'inclus une partie de mon fichier pour que tu vois....

http://cjoint.com/?czrwsO8M1k


Bonjour.
Dans quelle cellule se trouve le 0 quui te pose problème ?
Cordialement.
Daniel
"Cloclo" news:


Bonjour,
Est-ce possible de faire en sorte que 0 soit reconnu comme un nombre
entier?

Parce que dans ma formule
=SI(NBVAL(A42:G42)<7;"";SOMME(--ESTNUM(EQUIV(STXT($T$2;{1.3.5.7.9.11.13};2);STXT(V
42;{1.3.5.7.9.11.13};2);0))))
le zéro n'est pas reconnu comme un nombre.

Merci de votre aide et bonne journée

ClaudeC55





















Daniel.C
Le #5170681
J'parie que je ne suis pas clair....

Là, t'as gagné. Quel résultat est-ce que je devrais avoir avec et sans 0 ?

Dans la cellule T8, tu concatènes TEXTE($Q$5;"00") et, comme Q5 est à 0, ça
fait +1 sur ton résultat quand tu as une valeur 0 dans les colonnes A:G.
Daniel

Publicité
Poster une réponse
Anonyme