Si + Si + SI

Le
Philippe
Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #5337201
Bonjour,

Peut-être...
=SI(OU(A1<1;A1>5);"";CHOISIR(A1;6;4;3;2;1))

--
Salutations
JJ


"Philippe"
Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe



cb60
Le #5337191
Bonjour
Avec une table d'équivalence et index equiv
http://cjoint.com/?bhnclJyIdj


Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe





AH60
Le #5336911
Bonjour

=CHOISIR(EQUIV($A$1;{0;1;2;3;4;5};1);"";6;4;3;2;1)

Abed_H






Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe





Philippe
Le #5126071
Merci à vous 3 pour vos réponses.
C'est exactement ce que je désirais.
Bonne journée.

"Philippe"
Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe



etienneM
Le #5120811
BonjourM. cb60,

Pouvez-vous m'expliquer dans votre exemple, l'utilisation du someprod
=SOMMEPROD(--($B$8:$B$13±7))
surtout les "--". Après la lecture de l'aide, je ne vois pas du tout comment
ça fonctionne. Mais c'est intéressant puisque ça reproduit l'instruction
NBVAL.?

A l'avance, merci.


Bonjour
Avec une table d'équivalence et index equiv
http://cjoint.com/?bhnclJyIdj


Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe







cb60
Le #5120711
Bonjour
Cela n'a rien a voir avec la question, j'avais un fichier ouvert et j'ai
essayé de repondre sur ce fichier .
Mais pour ce qui est du sommeprod.=SOMMEPROD(--($B$8:$B$13±7))
les 2 -- permettent de convertir du texte en numérique ( si j'ai bien retenu
ma leçon) et tu verras souvent si tu t'interresse à cette fonction *1 qui a
le même résultat, et cela correspond bien au nbval qui a comme critere la
cellule b17


BonjourM. cb60,

Pouvez-vous m'expliquer dans votre exemple, l'utilisation du someprod
=SOMMEPROD(--($B$8:$B$13±7))
surtout les "--". Après la lecture de l'aide, je ne vois pas du tout comment
ça fonctionne. Mais c'est intéressant puisque ça reproduit l'instruction
NBVAL.?

A l'avance, merci.


Bonjour
Avec une table d'équivalence et index equiv
http://cjoint.com/?bhnclJyIdj


Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe









etienneM
Le #5120691
Ca n'avait rien à voir, je suis d'accord. Merci beaucoup pour le "--" et pour
votre réponse.
Mais le someprod (normalement) multiplie des matrices et ici vous l'utilisez
pour compter le nombre de fois où la comparaison s'est vérifiée !!! Puis vous
convertissez en numérique ! J'ai bien compris ?


Bonjour
Cela n'a rien a voir avec la question, j'avais un fichier ouvert et j'ai
essayé de repondre sur ce fichier .
Mais pour ce qui est du sommeprod.=SOMMEPROD(--($B$8:$B$13±7))
les 2 -- permettent de convertir du texte en numérique ( si j'ai bien retenu
ma leçon) et tu verras souvent si tu t'interresse à cette fonction *1 qui a
le même résultat, et cela correspond bien au nbval qui a comme critere la
cellule b17


BonjourM. cb60,

Pouvez-vous m'expliquer dans votre exemple, l'utilisation du someprod
=SOMMEPROD(--($B$8:$B$13±7))
surtout les "--". Après la lecture de l'aide, je ne vois pas du tout comment
ça fonctionne. Mais c'est intéressant puisque ça reproduit l'instruction
NBVAL.?

A l'avance, merci.


Bonjour
Avec une table d'équivalence et index equiv
http://cjoint.com/?bhnclJyIdj


Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe











Misange
Le #5120561
Excellentes questions :-)
Je t'invite à aller lire les explications très détaillées sur les
utilisations non conventionnelles de cette fonction(c'est à dire au
départ non prévues mais qui sont devenues indispensables aux excelliens
avertis :-) )
http://xlwiki.free.fr/wiki/wakka.php?wiki=SommeProd (et les pages
suivantes).
Bienvenue à la SPA ! (sommeprod académie)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Ca n'avait rien à voir, je suis d'accord. Merci beaucoup pour le "--" et pour
votre réponse.
Mais le someprod (normalement) multiplie des matrices et ici vous l'utilisez
pour compter le nombre de fois où la comparaison s'est vérifiée !!! Puis vous
convertissez en numérique ! J'ai bien compris ?


Bonjour
Cela n'a rien a voir avec la question, j'avais un fichier ouvert et j'ai
essayé de repondre sur ce fichier .
Mais pour ce qui est du sommeprod.=SOMMEPROD(--($B$8:$B$13±7))
les 2 -- permettent de convertir du texte en numérique ( si j'ai bien retenu
ma leçon) et tu verras souvent si tu t'interresse à cette fonction *1 qui a
le même résultat, et cela correspond bien au nbval qui a comme critere la
cellule b17


BonjourM. cb60,

Pouvez-vous m'expliquer dans votre exemple, l'utilisation du someprod
=SOMMEPROD(--($B$8:$B$13±7))
surtout les "--". Après la lecture de l'aide, je ne vois pas du tout comment
ça fonctionne. Mais c'est intéressant puisque ça reproduit l'instruction
NBVAL.?

A l'avance, merci.


Bonjour
Avec une table d'équivalence et index equiv
http://cjoint.com/?bhnclJyIdj


Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe













cb60
Le #5120441
Bonsoir
Merci Misange pour le lien, car j'utilise et j'aime bien cette fonction qui
est capable de faire beaucoup de chose, mais je ne connaissais pas toutes les
finesses de celle ci.
Je suis souvent impressionné par la manipulation que Monique en fait et je
suis sur qu'en voyant le Wiki je vais l'utiliser encore plus.
Bonne soirée.


Excellentes questions :-)
Je t'invite à aller lire les explications très détaillées sur les
utilisations non conventionnelles de cette fonction(c'est à dire au
départ non prévues mais qui sont devenues indispensables aux excelliens
avertis :-) )
http://xlwiki.free.fr/wiki/wakka.php?wiki=SommeProd (et les pages
suivantes).
Bienvenue à la SPA ! (sommeprod académie)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Ca n'avait rien à voir, je suis d'accord. Merci beaucoup pour le "--" et pour
votre réponse.
Mais le someprod (normalement) multiplie des matrices et ici vous l'utilisez
pour compter le nombre de fois où la comparaison s'est vérifiée !!! Puis vous
convertissez en numérique ! J'ai bien compris ?


Bonjour
Cela n'a rien a voir avec la question, j'avais un fichier ouvert et j'ai
essayé de repondre sur ce fichier .
Mais pour ce qui est du sommeprod.=SOMMEPROD(--($B$8:$B$13±7))
les 2 -- permettent de convertir du texte en numérique ( si j'ai bien retenu
ma leçon) et tu verras souvent si tu t'interresse à cette fonction *1 qui a
le même résultat, et cela correspond bien au nbval qui a comme critere la
cellule b17


BonjourM. cb60,

Pouvez-vous m'expliquer dans votre exemple, l'utilisation du someprod
=SOMMEPROD(--($B$8:$B$13±7))
surtout les "--". Après la lecture de l'aide, je ne vois pas du tout comment
ça fonctionne. Mais c'est intéressant puisque ça reproduit l'instruction
NBVAL.?

A l'avance, merci.


Bonjour
Avec une table d'équivalence et index equiv
http://cjoint.com/?bhnclJyIdj


Bonjour à toutes et à tous.
Le nombre de SI étant limité, comment faire pour arriver à ceci :
Formule en B1
SI(A1<>;"");SI(A1=0;"")SI
(A1=1;6);SI(A1=2:4);SI'A1=3;3);SI(A1=4;2);SI(A1=5;1)
Merci de vos lumières.
Philippe
















Modeste
Le #5120381
Bonsour® etienneM avec ferveur ;o))) vous nous disiez :

Mais le someprod (normalement) multiplie des matrices
une seule est acceptée ;o)))

$B$8:$B$13±7
est bien une matrice !!!! (VRAI,FAUX,VRAI etc...)

et ici vous
l'utilisez pour compter le nombre de fois où la comparaison s'est
vérifiée !!! Puis vous convertissez en numérique ! J'ai bien compris ?


oui tout a fait
les VRAI,FAUX, etc... sont convertis en 1 , 0, 1, etc...

la conversion en numerique peut l'etre indifferement par un element neutre
*1, +0, /1

;o)))
voir là :
http://xlwiki.free.fr/wiki/wakka.php?wiki=SommeProd
et là :
http://xldynamic.com/source/xld.SUMPRODUCT.html

--
@+
;o)))

Publicité
Poster une réponse
Anonyme