[Sid] Dépendances capricieuses

Le
Jacques A
=_Part_66896_14607179.1179490155512
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Salut la liste,

Une erreur de manip a envoyé ce message avant que j'aie fini de l'écrir=
e.

Sur un portable IBM thinkpad R51 je suis passé de testing à Sid. J'ai c=
hangé
lenny en sid dans le fichier de sources, puis j'ai fait une mise à jour d=
es
sources dans synaptic (le apt-get upgrade m'a jeté, je crois que c'est pa=
rce
que je passe par un proxy un peu paranoïaque). Ensuite, j'ai fait une mis=
e à
jour depuis synaptic (bouton tout mettre à jour), pensant que le proxy
allait encore m'enquiquiner.

J'ai plusieurs soucis (sous gnome):

- lorsque l'écran se met en veille, quand je bouge la souris, la boite po=
ur
taper son mot de passe ne s'affiche pas; par contre je tape le mot de passe
et le bureau s'affiche à nouveau.

- au niveau des mises à jours quotidiennes du système, le fichier
libjack0.100.0-0 (version installée 0.101.1-2) refuse de se mettre à jo=
ur
vers la version 0.103.0-5 au motif suivant:

Dépend : libjack0 mais ne doit pas être installé

Si je demande à désinstaller libjack0, c'est toute une série de logic=
iels
qui doivent être désinstallés. Donc je tourne en rond.

- certaines libs de kde refusent également de s'installer (par exemple
kdelibs4-dev avec l'erreur " Dépend : libarts1-dev mais ne doit pas êtr=
e
installé", car il "Dépend : libjack0.100.0-dev mais ne doit pas êtr=
e
installé" qui s'il est désinstallé me dégage 50 logiciels.

- enfin uswsusp n'a pu être mis à jour parce qu'il dépend de libsplas=
hy0
indisponible. J'ai du la chercher dans un dépôt Ubuntu et l'installer =
à la
mano pour pouvoir faire l'upgrade.

Que faire?

Le comique là-dedans, c'est que sur mon portable perso de la maison, j'ai
fait le apt-get dist-upgrade et je n'ai aucun de ces problèmes. Tout marc=
he
super bien.

Merci pour toute info qui m'aiderait à comprendre, à commencer par la V=
RAIE
marche à suivre pour faire un upgrade propre de la distribution (de testi=
ng
vers sid).

Jacques

=_Part_66896_14607179.1179490155512
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Salut la liste,<br><br>Une erreur de manip a envoyé ce message avant que =
j&#39;aie fini de l&#39;écrire.<br><div id="mb_0"><br>Sur un portable I=
BM thinkpad R51
je suis passé de testing à Sid. J&#39;ai changé lenny en sid dans le
fichier de sources, puis j&#39;ai fait une mise à jour des sources dans
synaptic (le apt-get upgrade m&#39;a jeté, je crois que c&#39;est parce q=
ue je
passe par un proxy un peu paranoïaque). Ensuite, j&#39;ai fait une mise =
à
jour depuis synaptic (bouton tout mettre à jour), pensant que le proxy
allait encore m&#39;enquiquiner.
<br><br>J&#39;ai plusieurs soucis (sous gnome):<br><br>- lorsque l&#39;éc=
ran
se met en veille, quand je bouge la souris, la boite pour taper son mot
de passe ne s&#39;affiche pas; par contre je tape le mot de passe et le
bureau s&#39;affiche à nouveau.
<br><br>- au niveau des mises à jours quotidiennes du système, le
fichier libjack0.100.0-0 (version installée 0.101.1-2) refuse de se
mettre à jour vers la version 0.103.0-5 au motif suivant:<br><br>&nbsp;D=
épend&nbsp;: libjack0 mais ne doit pas être installé<br><br>Si je dem=
ande à désinstaller libjack0, c&#39;est toute une série de logiciels =
qui doivent être désinstallés. Donc je tourne en rond.
<br><br>- certaines libs de kde refusent également de s&#39;installer (pa=
r exemple kdelibs4-dev avec l&#39;erreur &quot; Dépend&nbsp;: libarts1-de=
v mais ne doit pas être installé&quot;, car&nbsp;&nbsp; il &quot;Dépe=
nd&nbsp;: libjack0.100.0-dev
mais ne doit pas être installé&quot; qui s&#39;il est désinstallé =
me dégage 50 logiciels.<br><br>- enfin uswsusp n&#39;a pu être mis à =
jour parce qu&#39;il dépend de libsplashy0 indisponible. J&#39;ai du la c=
hercher dans un dépôt Ubuntu et l&#39;installer à la mano pour pouvoi=
r faire l&#39;upgrade.
<br><br>Que faire?<br><br>Le comique là-dedans, c&#39;est que sur mon por=
table perso de la maison, j&#39;ai fait le apt-get dist-upgrade et je n&#39=
;ai aucun de ces problèmes. Tout marche super bien.<br><br>Merci pour tou=
te info qui m&#39;aiderait à comprendre, à commencer par la VRAIE march=
e à suivre pour faire un upgrade propre de la distribution (de testing ve=
rs sid).
<br><br>Jacques<br>
</div>

=_Part_66896_14607179.1179490155512--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Huhardeaux
Le #9555801
Jacques A a écrit :
Salut la liste,


Bonjour

[...]

Merci pour toute info qui m'aiderait à comprendre, à commencer par la
VRAIE marche à suivre pour faire un upgrade propre de la distribution
(de testing vers sid).


aptitude dist-upgrade après avoir mis à jour le source list.

--
Daniel Huhardeaux _____ ____ ____ _____ _____ _
enum +48 32 285 5276 (_ __) _ ) _ (_ __) _ _(_)
iaxtel 1-700-849-6983 / / / // / // / / / / /_/ / /
sip/iax:callto /_/ ( ___( ___/ /_/ (_/ (_/_/.net FWD# 422493


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jacques A
Le #9555781
------=_Part_67247_8188874.1179492430802
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 18/05/07, Daniel Huhardeaux

Jacques A a écrit :
> Salut la liste,
Bonjour
>
> [...]
>
> Merci pour toute info qui m'aiderait à comprendre, à commencer par la
> VRAIE marche à suivre pour faire un upgrade propre de la distribution
> (de testing vers sid).
aptitude dist-upgrade après avoir mis à jour le source list.





Merci, j'ai lancé, mais il est en train de désinstaller tout kde entre
autres. J'espère que le prochain aptitude dist-upgrade fera les choses
proprement, sinon je vais réinstaller. De toutes façons, j'ai besoin
d'utiliser Grub, parce que j'ai du xfs et que lilo est la seule option.

Jacques

--
Daniel Huhardeaux _____ ____ ____ _____ _____ _
enum +48 32 285 5276 (_ __) _ ) _ (_ __) _ _(_)
iaxtel 1-700-849-6983 / / / // / // / / / / /_/ / /
sip/iax:callto /_/ ( ___( ___/ /_/ (_/ (_/_/.net FWD# 422493


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact






------=_Part_67247_8188874.1179492430802
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Jacques A a écrit : enum&nbsp;&nbsp;&nbsp;&nbsp;+48 32 285 5276 (_&nbsp;&nbsp;__) _&nbsp;&nbsp; ) _&nbsp;&nbsp;(_&nbsp;&nbsp;__) _&nbsp;&nbsp;_(_) </a><br><br></blockquote></div><br>

------=_Part_67247_8188874.1179492430802--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Bernat
Le #9555741
OoO En ce début d'après-midi nuageux du vendredi 18 mai 2007, vers
14:09, "Jacques A"
- au niveau des mises à jours quotidiennes du système, le fichier
libjack0.100.0-0 (version installée 0.101.1-2) refuse de se mettre à jour vers
la version 0.103.0-5 au motif suivant:



Dépend : libjack0 mais ne doit pas être installé



C'est le lot de tout système sous Sid. Il suffit d'attendre pour que
cela se résolve.

Si je demande à désinstaller libjack0, c'est toute une série de logiciels qui
doivent être désinstallés. Donc je tourne en rond.



- certaines libs de kde refusent également de s'installer (par exemple
kdelibs4-dev avec l'erreur " Dépend : libarts1-dev mais ne doit pas être
installé", car il "Dépend : libjack0.100.0-dev mais ne doit pas être
installé" qui s'il est désinstallé me dégage 50 logiciels.



- enfin uswsusp n'a pu être mis à jour parce qu'il dépend de libsplashy0
indisponible. J'ai du la chercher dans un dépôt Ubuntu et l'installer à la mano
pour pouvoir faire l'upgrade.



A priori, je serai tenté de dire que tu ne devrais pas passer à Sid
avant de mieux comprendre comment résoudre ces problèmes. J'utilise pour
ma part aptitude en "mode graphique" pour faire les mises à jour et
régler les problèmes de dépendances.

Par exemple, si uswsusp dépend de la libsplashy et que celle-ci n'est
pas disponible, c'est peut-être parce qu'elle n'a pas encore été
uploadée dans unstable. Il ne faut surtout pas aller chercher la version
Ubuntu.
--
GOLDFISH DON'T BOUNCE
GOLDFISH DON'T BOUNCE
GOLDFISH DON'T BOUNCE
-+- Bart Simpson on chalkboard in episode 9F14


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
tux7513
Le #9555641
Vincent Bernat a écrit :

A priori, je serai tenté de dire que tu ne devrais pas passer à Sid
avant de mieux comprendre comment résoudre ces problèmes. J'utilise pour
ma part aptitude en "mode graphique" pour faire les mises à jour et
régler les problèmes de dépendances.



J'ai une bonne expérience des systèmes GNU/Linux pour avoir bossé a ssez
longtemps avec Slackware. Depuis quelques mois je suis passé sous Debia n
et je commence à la connaitre un peu. Je voudrais des versions plus
récentes de logiciels, d'où Sid. Mon seul soucis en termes de
dépendances est que je ne connais pas encore parfaitement le mode de
développement de Debian pour pouvoir recompiler des paquet et les
installer là où ils devraient sans briser l'homogénéité de ma d istribution.

Mais je te remercie de m'apprendre qu'avec Sid il faut attendre que
certains problèmes soient résolus. De toutes façons, je trouve Sid très
stable pour bosser.


Bonne journée

Jacques
Vincent Bernat
Le #9555571
OoO En cette matinée pluvieuse du samedi 19 mai 2007, vers 10:07,
tux7513
Mais je te remercie de m'apprendre qu'avec Sid il faut attendre que
certains problèmes soient résolus. De toutes façons, je trouve Sid très
stable pour bosser.



Testing est trop vieux pour toi ?
--
Use data arrays to avoid repetitive control sequences.
- The Elements of Programming Style (Kernighan & Plauger)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
tux7513
Le #9555561
Vincent Bernat a écrit :
OoO En cette matinée pluvieuse du samedi 19 mai 2007, vers 10: 07,
tux7513
Mais je te remercie de m'apprendre qu'avec Sid il faut attendre que
certains problèmes soient résolus. De toutes façons, je trouve S id très
stable pour bosser.



Testing est trop vieux pour toi ?



Non, seulement certaines versions récentes de softs sont uniquement
dispo sur Sid. Mon passage en Sid a été un test qui a bien fonctionné
sur un portable perso et complètement foiré sur le thinkpad de ma boi te,
en fait les fameux problèmes de dépendances insatisfaites, sinon la b ête
marchait toujours. C'est du costaud Debian!

Jacques
Charles Plessy
Le #9555311
Le Sat, May 19, 2007 at 10:07:14AM +0200, tux7513 a écrit :

J'ai une bonne expérience des systèmes GNU/Linux pour avoir bossé assez
longtemps avec Slackware. Depuis quelques mois je suis passé sous Debian
et je commence à la connaitre un peu. Je voudrais des versions plus
récentes de logiciels, d'où Sid. Mon seul soucis en termes de
dépendances est que je ne connais pas encore parfaitement le mode de
développement de Debian pour pouvoir recompiler des paquet et les
installer là où ils devraient sans briser l'homogénéité de ma distribution.



Bonjour,

normalement, les paquets rétroportés de Sid ou Lenny ne devraient pas
casser la distribution, pour la raison qu'au moment de la sortie de
Lenny, ils devront de toutes façons être installables sur une Etch.

D'ailleurs, certains paquets sont déjà rétroportés sur backports.org.

Pour le rétroportage a la main, c'est très simple:

- apt-get build-dep toto
- fakeroot apt-get source --build toto

Si ça ne marche pas, tant pis, mais ça vaut vraiment le coup d'essayer.

Bonne journée,

--
Charles Plessy
http://charles.plessy.org
Wako, Saitama, Japan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme