simplification de formule

Le
hack
Bonsoir à tous


Voila le probléme j'aimerais réduire cette formule car en effet J'ai essayer
en utilisant les fonctions de recherche mais impossible d'obtenir le bon
résultat

1 en AB12 se trouve une lettre quelquonque
2 on fait un test sur chaque ligne du tableau pour faire correspondre cette
lettre à un nombre d'heure


=(SI(AB12=Paramètres!$L$6;Paramètres!$V$6;0)+SI(AB12=Paramètres!$L$7;Paramètres!$V$7;0)+SI(AB12=Paramètres!$L$8;Paramètres!$V$8;0)+SI(AB12=Paramètres!$L$9;Paramètres!$V$9;0)+SI(AB12=Paramètres!$L$10;Paramètres!$V$10;0)+SI(AB12=Paramètres!$L$11;Paramètres!$V$11;0)+SI(AB12=Paramètres!$L$12;Paramètres!$V$12;0)+SI(AB12=Paramètres!$L$13;Paramètres!$V$13;0)+SI(AB12=Paramètres!$L$16;Paramètres!$V$16;0)+SI(AB12=Paramètres!$L$17;Paramètres!$V$17;0)+SI(AB12=Paramètres!$L$18;Paramètres!$V$18;0)+SI(AB12=Paramètres!$L$19;Paramètres!$V$19;0)+SI(AB12=Paramètres!$L$20;Paramètres!$V$20;0)+SI(AB12=Paramètres!$L$21;Paramètres!$V$21;0)+SI(AB12=Paramètres!$L$22;Paramètres!$V$22;0)+SI(AB12=Paramètres!$L$25;Paramètres!$T$25;0)+SI(AB12=Paramètres!$L$26;Paramètres!$T$26;0)+SI(AB12=Paramètres!$L$27;Paramètres!$T$27;0)+SI(AB12=Paramètres!$L$28;Paramètres!$T$28;0)+SI(AB12=Paramètres!$L$29;Paramètres!$T$29;0)+SI(AB12=Paramètres!$L$30;Paramètres!$T$30;0)+SI(AB12=Paramètres!$L$31;Paramètres!$T$31;0))

Merci d'avance pour les infos que vous pourrez me donner
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5045491
Bonjour.
Si j'ai bien compris :
=RECHERCHEV(AB12;Paramètres!L6:V31;11;0)
devrait le faire.
Cordialement.
Daniel
"hack"
Bonsoir à tous


Voila le probléme j'aimerais réduire cette formule car en effet J'ai
essayer
en utilisant les fonctions de recherche mais impossible d'obtenir le bon
résultat

1 en AB12 se trouve une lettre quelquonque
2 on fait un test sur chaque ligne du tableau pour faire correspondre
cette
lettre à un nombre d'heure


=(SI(AB12=Paramètres!$L$6;Paramètres!$V$6;0)+SI(AB12=Paramètres!$L$7;Paramètres!$V$7;0)+SI(AB12=Paramètres!$L$8;Paramètres!$V$8;0)+SI(AB12=Paramètres!$L$9;Paramètres!$V$9;0)+SI(AB12=Paramètres!$L$10;Paramètres!$V$10;0)+SI(AB12=Paramètres!$L$11;Paramètres!$V$11;0)+SI(AB12=Paramètres!$L$12;Paramètres!$V$12;0)+SI(AB12=Paramètres!$L$13;Paramètres!$V$13;0)+SI(AB12=Paramètres!$L$16;Paramètres!$V$16;0)+SI(AB12=Paramètres!$L$17;Paramètres!$V$17;0)+SI(AB12=Paramètres!$L$18;Paramètres!$V$18;0)+SI(AB12=Paramètres!$L$19;Paramètres!$V$19;0)+SI(AB12=Paramètres!$L$20;Paramètres!$V$20;0)+SI(AB12=Paramètres!$L$21;Paramètres!$V$21;0)+SI(AB12=Paramètres!$L$22;Paramètres!$V$22;0)+SI(AB12=Paramètres!$L$25;Paramètres!$T$25;0)+SI(AB12=Paramètres!$L$26;Paramètres!$T$26;0)+SI(AB12=Paramètres!$L$27;Paramètres!$T$27;0)+SI(AB12=Paramètres!$L$28;Paramètres!$T$28;0)+SI(AB12=Paramètres!$L$29;Paramètres!$T$29;0)+SI(AB12=Paramètres!$L$30;Paramètres!$T$30;0)+SI(AB12=Paramètres!$L$31;Paramètres!$T$31;0))

Merci d'avance pour les infos que vous pourrez me donner




hack
Le #5045391
bonjour,

En effet cela fonctionne bien.

Merci et bon dimanche


Bonjour.
Si j'ai bien compris :
=RECHERCHEV(AB12;Paramètres!L6:V31;11;0)
devrait le faire.
Cordialement.
Daniel
"hack"
Bonsoir à tous


Voila le probléme j'aimerais réduire cette formule car en effet J'ai
essayer
en utilisant les fonctions de recherche mais impossible d'obtenir le bon
résultat

1 en AB12 se trouve une lettre quelquonque
2 on fait un test sur chaque ligne du tableau pour faire correspondre
cette
lettre à un nombre d'heure


=(SI(AB12=Paramètres!$L$6;Paramètres!$V$6;0)+SI(AB12=Paramètres!$L$7;Paramètres!$V$7;0)+SI(AB12=Paramètres!$L$8;Paramètres!$V$8;0)+SI(AB12=Paramètres!$L$9;Paramètres!$V$9;0)+SI(AB12=Paramètres!$L$10;Paramètres!$V$10;0)+SI(AB12=Paramètres!$L$11;Paramètres!$V$11;0)+SI(AB12=Paramètres!$L$12;Paramètres!$V$12;0)+SI(AB12=Paramètres!$L$13;Paramètres!$V$13;0)+SI(AB12=Paramètres!$L$16;Paramètres!$V$16;0)+SI(AB12=Paramètres!$L$17;Paramètres!$V$17;0)+SI(AB12=Paramètres!$L$18;Paramètres!$V$18;0)+SI(AB12=Paramètres!$L$19;Paramètres!$V$19;0)+SI(AB12=Paramètres!$L$20;Paramètres!$V$20;0)+SI(AB12=Paramètres!$L$21;Paramètres!$V$21;0)+SI(AB12=Paramètres!$L$22;Paramètres!$V$22;0)+SI(AB12=Paramètres!$L$25;Paramètres!$T$25;0)+SI(AB12=Paramètres!$L$26;Paramètres!$T$26;0)+SI(AB12=Paramètres!$L$27;Paramètres!$T$27;0)+SI(AB12=Paramètres!$L$28;Paramètres!$T$28;0)+SI(AB12=Paramètres!$L$29;Paramètres!$T$29;0)+SI(AB12=Paramètres!$L$30;Paramètres!$T$30;0)+SI(AB12=Paramètres!$L$31;Paramètres!$T$31;0))

Merci d'avance pour les infos que vous pourrez me donner









Publicité
Poster une réponse
Anonyme