Slrn et iconv-base de FreeBSD-10

Le
David Marec
Salut à tous,

J'ai mis à jour mon `/Desktop/` vers la branche 10 et configuré un slrn
pour publier dans les jeux suivants:

charset outgoing "us-ascii,iso-8859-1,iso-8859-15,utf-8"

Mais, si je rédige en UTF-8 depuis *vim*, slrn ne publie qu'en us-ascii.

En fait, il déclare toujours le premier de la liste.

Vérification faites avec un autre utilisateur, cela fonctionne toujours
de la bonne manière sous FreeBSD 7: Essai des jeux depuis la gauche
vers la droite et validation au premier jeu qui colle.

Je soupçonne que cela soit dû à la migration du gnu-iconv vers un iconv
intégré depuis peu dans la base de FreeBSD.

Avez-vous constaté ce genre de soucis ? Une solution

<fu2:fcob>

--
David Marec
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bruno Ducrot
Le #26044012
On 2014-03-01, David Marec wrote:
Salut à tous,

J'ai mis à jour mon `/Desktop/` vers la branche 10 et configuré un slrn
pour publier dans les jeux suivants:

charset outgoing "us-ascii,iso-8859-1,iso-8859-15,utf-8"

Mais, si je rédige en UTF-8 depuis *vim*, slrn ne publie qu'en us-ascii.

En fait, il déclare toujours le premier de la liste.

Vérification faites avec un autre utilisateur, cela fonctionne toujours
de la bonne manière sous FreeBSD 7: Essai des jeux depuis la gauche
vers la droite et validation au premier jeu qui colle.

Je soupçonne que cela soit dû à la migration du gnu-iconv vers un iconv
intégré depuis peu dans la base de FreeBSD.



C'est bien ça.


Avez-vous constaté ce genre de soucis ? Une solution



Je viens de tester. En ajoutant :

Ca retombe en marche en remplaçant les lignes :

CONFIGURE_ARGS+=--enable-ipv6 --disable-inews --with-slrnpull
${ICONV_CONFIGURE_ARG}

par :
CONFIGURE_ARGS+=--enable-ipv6 --disable-inews --with-slrnpull
--with-non-gnu-iconv ${ICONV_CONFIGURE_ARG}


dans le Makefile du port.

A plus,

--
Bruno Ducrot

A quoi ca sert que Ducrot hisse des carcasses ?
David Marec
Le #26046202
Le 21-03-2014, Bruno Ducrot

Ca retombe en marche en remplaçant les lignes :

CONFIGURE_ARGS+=--enable-ipv6 --disable-inews --with-slrnpull
${ICONV_CONFIGURE_ARG}

par :
CONFIGURE_ARGS+=--enable-ipv6 --disable-inews --with-slrnpull
--with-non-gnu-iconv ${ICONV_CONFIGURE_ARG}





En effet, ça a l'air de fonctionner, là.

--
papapapappapapa meow meow
David Marec
Le #26075862
Le 21-03-2014, Bruno Ducrot

CONFIGURE_ARGS+=--enable-ipv6 --disable-inews --with-slrnpull
--with-non-gnu-iconv ${ICONV_CONFIGURE_ARG}


dans le Makefile du port.

A plus,




Pour clore l'affaire, le patch a été poussé dans la 1.0.1_1.

--
Pa-pa-pa-pa-pa-pa-pa-pa-pa-pa-pa-pa-pa-pa-ooma-mow-mow
Papa-ooma-mow-mow
Publicité
Poster une réponse
Anonyme