someprod probleme

Le
STEPH B
Bonjour,

j'ai un petit problème avec la fonction someprod

ma fonction marche sur la page mais j'aimerais l"executer en vba si possible
=SOMMEPROD(('2010'!R2:R5000="MULT")*(MOIS('2010'!C2:C5000)=4)*('2010'!U2:U5000))

voici un extrait de code avec le ATL F11 mais ca marche pas
ca me donne ca dans l'éditeur

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])=
moisfact)*('2010'!R[-27]C[15]:R[4971]C[15]))")

moisfact est une variable que je saisie dans une inputbox.

merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21758201
Bonjour.
Il faut sortir les variables des guillemets, faute de quoi moisfact est
interprété comme la chaîne "moisfact" et non comme la variable :

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])="
& moisfact & ")*('2010'!R[-27]C[15]:R[4971]C[15]))")

(non testée).
Cordialement.
Daniel



Bonjour,

j'ai un petit problème avec la fonction someprod

ma fonction marche sur la page mais j'aimerais l"executer en vba si possible
=SOMMEPROD(('2010'!R2:R5000="MULT")*(MOIS('2010'!C2:C5000)=4)*('2010'!U2:U5000))

voici un extrait de code avec le ATL F11 mais ca marche pas
ca me donne ca dans l'éditeur

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])=
moisfact)*('2010'!R[-27]C[15]:R[4971]C[15]))")

moisfact est une variable que je saisie dans une inputbox.

merci d'avance
STEPH B
Le #21760001
désolé mais j ai une incompatibilté de type 13...


"Daniel.C"
Bonjour.
Il faut sortir les variables des guillemets, faute de quoi moisfact est
interprété comme la chaîne "moisfact" et non comme la variable :

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])="
& moisfact & ")*('2010'!R[-27]C[15]:R[4971]C[15]))")

(non testée).
Cordialement.
Daniel



Bonjour,

j'ai un petit problème avec la fonction someprod

ma fonction marche sur la page mais j'aimerais l"executer en vba si
possible
=SOMMEPROD(('2010'!R2:R5000="MULT")*(MOIS('2010'!C2:C5000)=4)*('2010'!U2:U5000))

voici un extrait de code avec le ATL F11 mais ca marche pas
ca me donne ca dans l'éditeur

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])=
moisfact)*('2010'!R[-27]C[15]:R[4971]C[15]))")

moisfact est une variable que je saisie dans une inputbox.

merci d'avance




Daniel.C
Le #21761791
Pas moi ? J'ai découpé la ligne, pour plus de clarté :

Sheets("FACTURE 2").Range("f29") = _
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")" & _
"*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])=" & _
moisfact & ")*('2010'!R[-27]C[15]:R[4971]C[15]))")

Si l'erreur persiste, met un classeur sur www.cijoint.fr
Daniel

désolé mais j ai une incompatibilté de type 13...


"Daniel.C"
Bonjour.
Il faut sortir les variables des guillemets, faute de quoi moisfact est
interprété comme la chaîne "moisfact" et non comme la variable :

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])="
& moisfact & ")*('2010'!R[-27]C[15]:R[4971]C[15]))")

(non testée).
Cordialement.
Daniel



Bonjour,

j'ai un petit problème avec la fonction someprod

ma fonction marche sur la page mais j'aimerais l"executer en vba si
possible
=SOMMEPROD(('2010'!R2:R5000="MULT")*(MOIS('2010'!C2:C5000)=4)*('2010'!U2:U5000))

voici un extrait de code avec le ATL F11 mais ca marche pas
ca me donne ca dans l'éditeur

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])=
moisfact)*('2010'!R[-27]C[15]:R[4971]C[15]))")

moisfact est une variable que je saisie dans une inputbox.

merci d'avance




STEPH B
Le #21761781
ayé ca marche
merci bcp




"Daniel.C"
Pas moi ? J'ai découpé la ligne, pour plus de clarté :

Sheets("FACTURE 2").Range("f29") = _
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")" & _
"*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])=" & _
moisfact & ")*('2010'!R[-27]C[15]:R[4971]C[15]))")

Si l'erreur persiste, met un classeur sur www.cijoint.fr
Daniel

désolé mais j ai une incompatibilté de type 13...


"Daniel.C"
Bonjour.
Il faut sortir les variables des guillemets, faute de quoi moisfact est
interprété comme la chaîne "moisfact" et non comme la variable :

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])="
& moisfact & ")*('2010'!R[-27]C[15]:R[4971]C[15]))")

(non testée).
Cordialement.
Daniel



Bonjour,

j'ai un petit problème avec la fonction someprod

ma fonction marche sur la page mais j'aimerais l"executer en vba si
possible
=SOMMEPROD(('2010'!R2:R5000="MULT")*(MOIS('2010'!C2:C5000)=4)*('2010'!U2:U5000))

voici un extrait de code avec le ATL F11 mais ca marche pas
ca me donne ca dans l'éditeur

Sheets("FACTURE 2").Range("f29") =
Evaluate("=SUMPRODUCT(('2010'!R[-27]C[12]:R[4971]C[12]=""MULT"")*(MONTH('2010'!R[-27]C[-3]:R[4971]C[-3])=
moisfact)*('2010'!R[-27]C[15]:R[4971]C[15]))")

moisfact est une variable que je saisie dans une inputbox.

merci d'avance










Publicité
Poster une réponse
Anonyme