somme avec 2 conditions

Le
Lulu
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4812161
Bonjour,

ÞCALER($E2;0;(COLONNE()-27)*5)

http://cjoint.com/?ifs4sLUBsi

JB
On 5 août, 18:25, "Lulu"
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc


Lulu
Le #4812131
Merci JB de la réponse rapide

J'ai un peu de mal à piger la formule
d'autre part apparemment c'est pas le bon résultat, j'ai fait manuellement
la formule

http://www.cijoint.fr/cij1411542021657.xls

A+ Luc



"JB"
Bonjour,

ÞCALER($E2;0;(COLONNE()-27)*5)

http://cjoint.com/?ifs4sLUBsi

JB
On 5 août, 18:25, "Lulu"
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc


garnote
Le #4812121
Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y2)

Serge

"Lulu"
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc



Lulu
Le #4812011
Merci Garnote
Ok la formule est bonne ca marche
Dans mon exemple j'avais 5 références, en réalité j'en ai 48 (ok peut-être
j'aurai du faire autrement)
pour appliquer la formule, c'est un peu long, je pensais trouver une autre
solution mais celle-ci marche c'est déjà pas mal.

Merci encore a+ Luc

"garnote" %
Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y2)

Serge

"Lulu" 46b5f9fc$0$25931$
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc







garnote
Le #4811981
Salut Luc,

Je t'ai proposé cette formule en espérant que les références
ne soient pas trop nombreuses. Il faudra trouver autre chose :-(

Serge


"Lulu"
Merci Garnote
Ok la formule est bonne ca marche
Dans mon exemple j'avais 5 références, en réalité j'en ai 48 (ok peut-être j'aurai du faire autrement)
pour appliquer la formule, c'est un peu long, je pensais trouver une autre solution mais celle-ci marche c'est déjà pas mal.

Merci encore a+ Luc

"garnote"
Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y2)

Serge

"Lulu"
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc











garnote
Le #4811951
Salut Luc,

En attendant autre chose, ces deux fonctions personnalisées
me semblent compétentes :

Total pour tx*=1 :
Function pt(ici As Range)
For i = 1 To ici.Columns.Count
If ici(1, 5 * i + 1) = 1 Then s = s + ici(1, 5 * i)
Next i
pt = s
End Function

Total pour tx*=2 :
Function dt(ici As Range)
For i = 1 To ici.Columns.Count
If ici(1, 5 * i + 1) = 2 Then s = s + ici(1, 5 * i)
Next i
dt = s
End Function

1) Entre la formule suivante : =pt(A2:Z2) ( plage à adapter ) dans une cellule
et recopie vers le bas.
2) Entre la formule suivante : =dt(A2:Z2) ( plage à adapter ) dans une autre cellule
et recopie vers le bas.

Serge





"Lulu"
Merci Garnote
Ok la formule est bonne ca marche
Dans mon exemple j'avais 5 références, en réalité j'en ai 48 (ok peut-être j'aurai du faire autrement)
pour appliquer la formule, c'est un peu long, je pensais trouver une autre solution mais celle-ci marche c'est déjà pas mal.

Merci encore a+ Luc

"garnote"
Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y2)

Serge

"Lulu"
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc











JB
Le #4811921
=SOMME(SI(ESTNUM(E2:Y2);E2:Y2;0)*(MOD(COLONNE(E2:Y2)+5-COLONNE(E2);
5)=0)*(SI(F2:Z2=1;1;0)))
Valider avec maj+ctrl+entrée

http://cjoint.com/?ifxRCDx8TJ

JB


On 5 août, 21:48, "Lulu"
Merci Garnote
Ok la formule est bonne ca marche
Dans mon exemple j'avais 5 références, en réalité j'en ai 48 (ok peut-être
j'aurai du faire autrement)
pour appliquer la formule, c'est un peu long, je pensais trouver une autre
solution mais celle-ci marche c'est déjà pas mal.

Merci encore a+ Luc

"garnote" %



Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y2)

Serge

"Lulu" 46b5f9fc$0$25931$
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




JB
Le #4811901
AA2:
=SOMME(SI(ESTNUM($E2:$Y2);$E2:$Y2;0)*(MOD(COLONNE($E2:$Y2)+5-
COLONNE($E2);5)=0)*(SI($F2:$Z2=1;1;0)))
Valider avec maj+ctrl+entrée

AB2:
=SOMME(SI(ESTNUM($E2:$Y2);$E2:$Y2;0)*(MOD(COLONNE($E2:$Y2)+5-
COLONNE($E2);5)=0)*(SI($F2:$Z2=2;1;0)))
Valider avec maj+ctrl+entrée

JB


On 5 août, 23:43, JB
=SOMME(SI(ESTNUM(E2:Y2);E2:Y2;0)*(MOD(COLONNE(E2:Y2)+5-COLONNE(E2);
5)=0)*(SI(F2:Z2=1;1;0)))
Valider avec maj+ctrl+entrée

http://cjoint.com/?ifxRCDx8TJ

JB

On 5 août, 21:48, "Lulu"


Merci Garnote
Ok la formule est bonne ca marche
Dans mon exemple j'avais 5 références, en réalité j'en ai 48 (o k peut-être
j'aurai du faire autrement)
pour appliquer la formule, c'est un peu long, je pensais trouver une au tre
solution mais celle-ci marche c'est déjà pas mal.

Merci encore a+ Luc

"garnote" %

Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y2)

Serge

"Lulu" 46b5f9fc$0$25931$
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -





Lulu
Le #4811871
Serge et JB, merci des réponses,

Je dois partir, j'ai pas testé
dur dur ce sont des formules quand même compliquées !

est ce qu'on peut faire quelque chose avec BDSOMME
en faisant la somme des colonnes h* par ligne avec la condition tx*=1
puis pour la 2ème colonne de résultat tx*=2

je n'y arrive pas, il y a une erreur quelque part (les h* et tx* ne sont
peut-être pas valables)

A+ Luc

"JB"
AA2:
=SOMME(SI(ESTNUM($E2:$Y2);$E2:$Y2;0)*(MOD(COLONNE($E2:$Y2)+5-
COLONNE($E2);5)=0)*(SI($F2:$Z2=1;1;0)))
Valider avec maj+ctrl+entrée

AB2:
=SOMME(SI(ESTNUM($E2:$Y2);$E2:$Y2;0)*(MOD(COLONNE($E2:$Y2)+5-
COLONNE($E2);5)=0)*(SI($F2:$Z2=2;1;0)))
Valider avec maj+ctrl+entrée

JB


On 5 août, 23:43, JB
=SOMME(SI(ESTNUM(E2:Y2);E2:Y2;0)*(MOD(COLONNE(E2:Y2)+5-COLONNE(E2);
5)=0)*(SI(F2:Z2=1;1;0)))
Valider avec maj+ctrl+entrée

http://cjoint.com/?ifxRCDx8TJ

JB

On 5 août, 21:48, "Lulu"


Merci Garnote
Ok la formule est bonne ca marche
Dans mon exemple j'avais 5 références, en réalité j'en ai 48 (ok
peut-être
j'aurai du faire autrement)
pour appliquer la formule, c'est un peu long, je pensais trouver une
autre
solution mais celle-ci marche c'est déjà pas mal.

Merci encore a+ Luc

"garnote" news:
%

Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y2)

Serge

"Lulu" 46b5f9fc$0$25931$
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -





JB
Le #4811851
Bonjour,

-Si les données étaient organisées sous forme de BD (en colonne et non
pas en ligne), la formule serait + simple.
-On ne peut pas utiliser BdSomme() pour la même raison.
-La formule n'est pas difficile à adapter si on ajoute des colonnes
(il sufit de modifier Y2 et Z2)

JB
On 6 août, 07:28, "Lulu"
Serge et JB, merci des réponses,

Je dois partir, j'ai pas testé
dur dur ce sont des formules quand même compliquées !

est ce qu'on peut faire quelque chose avec BDSOMME
en faisant la somme des colonnes h* par ligne avec la condition tx*=1
puis pour la 2ème colonne de résultat tx*=2

je n'y arrive pas, il y a une erreur quelque part (les h* et tx* ne sont
peut-être pas valables)

A+ Luc

"JB"
AA2:
=SOMME(SI(ESTNUM($E2:$Y2);$E2:$Y2;0)*(MOD(COLONNE($E2:$Y2)+5-
COLONNE($E2);5)=0)*(SI($F2:$Z2=1;1;0)))
Valider avec maj+ctrl+entrée

AB2:
=SOMME(SI(ESTNUM($E2:$Y2);$E2:$Y2;0)*(MOD(COLONNE($E2:$Y2)+5-
COLONNE($E2);5)=0)*(SI($F2:$Z2=2;1;0)))
Valider avec maj+ctrl+entrée

JB

On 5 août, 23:43, JB


=SOMME(SI(ESTNUM(E2:Y2);E2:Y2;0)*(MOD(COLONNE(E2:Y2)+5-COLONNE(E2);
5)=0)*(SI(F2:Z2=1;1;0)))
Valider avec maj+ctrl+entrée

http://cjoint.com/?ifxRCDx8TJ

JB

On 5 août, 21:48, "Lulu"
Merci Garnote
Ok la formule est bonne ca marche
Dans mon exemple j'avais 5 références, en réalité j'en ai 48 (ok
peut-être
j'aurai du faire autrement)
pour appliquer la formule, c'est un peu long, je pensais trouver une
autre
solution mais celle-ci marche c'est déjà pas mal.

Merci encore a+ Luc

"garnote" news:
%

Bonjour Lulu,

Essaie ceci :

1) Entre la formule suivante en AA2 et recopie vers le bas :
=SOMME((F2=1)*E2;(K2=1)*J2;(P2=1)*O2;(U2=1)*T2;(Z2=1)*Y 2)

2) Entre la formule suivante en AB2 et recopie vers le bas :
=SOMME((F2=2)*E2;(K2=2)*J2;(P2=2)*O2;(U2=2)*T2;(Z2=2)*Y 2)

Serge

"Lulu" 46b5f9fc$0$25931$
Bonjour,
Ca doit pas être compliqué pour les pros
mais j'arrive pas à faire une somme avec 2 conditions :
somme si h* et tx*=1

voir l'exemple :
http://www.cijoint.fr/cij26481579521630.xls

Merci de vos lumières

Luc- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte d es
messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -






Publicité
Poster une réponse
Anonyme