Somme avec condition sur date

Le
Olivier HONDAGNEU
Bonjour,

J'ai un tableau de ce type :

A B C
1 Ligne1 Date1 Valeur1
2 Ligne2 Date2 Valeur2
3 Ligne3 Date3 Valeur3

J'aimerais récupérer la somme des valeurs (colonne C) de ce tableau
pour chaque mois civil, en se basant sur le mois de la date (colonne
B).

J'ai essayé avec la fonction SOMME.SI, mais je ne parviens pas à
écrire la condition sur la date.

Merci d'avance pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #20962391
Bonjour,

Les mois dans une colonne a partir de la ligne 2
=SOMMEPROD((MOIS($B$2:$B$20)=LIGNE()-1)*$C$2:$C$20)
Et tirer jusqu' à la ligne 13

Exemple simple ici
http://www.cijoint.fr/cjlink.php?file=cj201001/cijXTZ5l50.xls
--
Salutations
JJ


"Olivier HONDAGNEU" message de news:

Bonjour,

J'ai un tableau de ce type :

A B C
1 Ligne1 Date1 Valeur1
2 Ligne2 Date2 Valeur2
3 Ligne3 Date3 Valeur3

J'aimerais récupérer la somme des valeurs (colonne C) de ce tableau
pour chaque mois civil, en se basant sur le mois de la date (colonne
B).

J'ai essayé avec la fonction SOMME.SI, mais je ne parviens pas à
écrire la condition sur la date.

Merci d'avance pour votre aide.
FdeCourt
Le #20962381
Salut,

Avec cette formule :
=SOMMEPROD(N(MOIS(B1:B3)Ñ);C1:C3)

Cordialement,

F.
Olivier HONDAGNEU
Le #20962721
Merci beaucoup, j'ai juste rajouté l'année pour être complètement
précis.
Publicité
Poster une réponse
Anonyme