Somme des cellules commençant par

Le
Sunburn
Bonjour,
je souhaite faire, sur un onglet "ALPHA", la somme des cellules de la
feuille "BETA", selon cette condition :
mon onglet BETA :
en colonne A mes compte 601000, 602000, 603000, etc.
en colonne C mes sommes.

donc je voudrais faire la somme de mes comptes commençants par 6 dans
l'onglet
BETA, donc la somme de la colonne C.

je ne m'en sort pas avec mes somme.si.

Merci.
YANN
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #18395781
Tu remplaces "Feuil1" par le nom de l'onglet où sont tes données
ainsi que la plage appropriée de cellules

En supposant que la plage n'a pas de cellules vides

=SOMMEPROD((GAUCHE(Feuil1!C1;1)*1=6)*(Feuil1!C1:C4))

Ou Validation matricielle : Ctrl +Maj + Enter
=SOMME(SI(GAUCHE(Feuil1!C1:C4;1)*1=6;Feuil1!C1:C4))



"Sunburn" discussion :
Bonjour,
je souhaite faire, sur un onglet "ALPHA", la somme des cellules de la
feuille "BETA", selon cette condition :
mon onglet BETA :
en colonne A mes compte 601000, 602000, 603000, etc.
en colonne C mes sommes.

donc je voudrais faire la somme de mes comptes commençants par 6 dans
l'onglet
BETA, donc la somme de la colonne C.

je ne m'en sort pas avec mes somme.si.

Merci.
YANN
Sunburn
Le #18399301
Bonjour,
alors en fait, ça ne fonctionne pas comme je veux.
car je ne connais pas le nombre exact de cellules sur lequel il faudra faire
le calcul, donc je pense faire le calcul sur les 2000 ou 3000 premièress
lignes (à partir de la ligne 3).
dans ce cas là, ça ne fonctionne pas.
Donc, comment on fais si y'a des cellules vides ???
Merci.

YANN

"michdenis" a écrit :

Tu remplaces "Feuil1" par le nom de l'onglet où sont tes données
ainsi que la plage appropriée de cellules

En supposant que la plage n'a pas de cellules vides

=SOMMEPROD((GAUCHE(Feuil1!C1;1)*1=6)*(Feuil1!C1:C4))

Ou Validation matricielle : Ctrl +Maj + Enter
=SOMME(SI(GAUCHE(Feuil1!C1:C4;1)*1=6;Feuil1!C1:C4))



"Sunburn" discussion :
Bonjour,
je souhaite faire, sur un onglet "ALPHA", la somme des cellules de la
feuille "BETA", selon cette condition :
mon onglet BETA :
en colonne A mes compte 601000, 602000, 603000, etc.
en colonne C mes sommes.

donc je voudrais faire la somme de mes comptes commençants par 6 dans
l'onglet
BETA, donc la somme de la colonne C.

je ne m'en sort pas avec mes somme.si.

Merci.
YANN



Sunburn
Le #18400911
Ok, c'est bon,
j'ai trouvée cette formule, qui adaptée et ça me va ...
=SOMMEPROD(--(GAUCHE($A$2:$A$65535;NBCAR(C1))=TEXTE(C1;0));$B$2:$B$65535)

Merci encore.
YANN
"michdenis" a écrit :

Tu remplaces "Feuil1" par le nom de l'onglet où sont tes données
ainsi que la plage appropriée de cellules

En supposant que la plage n'a pas de cellules vides

=SOMMEPROD((GAUCHE(Feuil1!C1;1)*1=6)*(Feuil1!C1:C4))

Ou Validation matricielle : Ctrl +Maj + Enter
=SOMME(SI(GAUCHE(Feuil1!C1:C4;1)*1=6;Feuil1!C1:C4))



"Sunburn" discussion :
Bonjour,
je souhaite faire, sur un onglet "ALPHA", la somme des cellules de la
feuille "BETA", selon cette condition :
mon onglet BETA :
en colonne A mes compte 601000, 602000, 603000, etc.
en colonne C mes sommes.

donc je voudrais faire la somme de mes comptes commençants par 6 dans
l'onglet
BETA, donc la somme de la colonne C.

je ne m'en sort pas avec mes somme.si.

Merci.
YANN



michdenis
Le #18401371
Une autre : Les 2 permettent des cellules vides

=SOMMEPROD((A1:A5<>"")*(GAUCHE(Feuil1!A1:A5;1)="6")*(Feuil1!A1:A5))
Ou
en validation matricielle :
=SOMME(SI((A1:A5<>"");(GAUCHE(Feuil1!A1:A5;1)="6")*(Feuil1!A1:A5)))

NB- Si tu penses que le nombre limite de cellule de ta plage sera de 3000 cellules
tu vas ralentir de beaucoup ton application si tu prends comme plage
$A$2:$A$65535 ... et ça inutilement. Ce type de formule bouffe beaucoup
de ressource.



"Sunburn" discussion :
Ok, c'est bon,
j'ai trouvée cette formule, qui adaptée et ça me va ...
=SOMMEPROD(--(GAUCHE($A$2:$A$65535;NBCAR(C1))=TEXTE(C1;0));$B$2:$B$65535)

Merci encore.
YANN
"michdenis" a écrit :

Tu remplaces "Feuil1" par le nom de l'onglet où sont tes données
ainsi que la plage appropriée de cellules

En supposant que la plage n'a pas de cellules vides

=SOMMEPROD((GAUCHE(Feuil1!C1;1)*1=6)*(Feuil1!C1:C4))

Ou Validation matricielle : Ctrl +Maj + Enter
=SOMME(SI(GAUCHE(Feuil1!C1:C4;1)*1=6;Feuil1!C1:C4))



"Sunburn" discussion :
Bonjour,
je souhaite faire, sur un onglet "ALPHA", la somme des cellules de la
feuille "BETA", selon cette condition :
mon onglet BETA :
en colonne A mes compte 601000, 602000, 603000, etc.
en colonne C mes sommes.

donc je voudrais faire la somme de mes comptes commençants par 6 dans
l'onglet
BETA, donc la somme de la colonne C.

je ne m'en sort pas avec mes somme.si.

Merci.
YANN



Publicité
Poster une réponse
Anonyme