Somme colonne B en fonction de la valeur colonne A

Le
domivax
Bonjour à tous,

Après avoir fait un filtre, je me retrouve avec sous colonne A les
monnaies (EUR, USD) et en regard de la colonne B, les montants.

Comment faire pour avoir la somme des EUR dans une cellule (W1) et la
somme USD dans une autre (X1) sans pour autant additionner les données
masquées.

J'ai bien essayer la formule =SOUS.TOTAL(109;B2:B65536), mais ça
m'additionne toutes les monnaies confondues.

Merci pour votre aide.
Salutations
Xavier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4494291
bonjour Xavier

quel est la (ou les) condition du filtre ?

isabelle

Bonjour à tous,

Après avoir fait un filtre, je me retrouve avec sous colonne A les
monnaies (EUR, USD) et en regard de la colonne B, les montants.

Comment faire pour avoir la somme des EUR dans une cellule (W1) et la
somme USD dans une autre (X1) sans pour autant additionner les données
masquées.

J'ai bien essayer la formule =SOUS.TOTAL(109;B2:B65536), mais ça
m'additionne toutes les monnaies confondues.

Merci pour votre aide.
Salutations
Xavier



domivax
Le #4494281
Bonjour Isabelle,

Le filtre est fait sur la colonne C avec les mois :

Exemple de mon tableau

A B C
EUR 50 JANVIER
USD 20 JANVIER
USD 70 JANVIER
EUR 20 JANVIER
USD 50 JANVIER
EUR 10 FEVRIER
USD 20 FEVRIER
etc.....

les totaux changeraient en fonctions du filtre effectu� sur la colo nne
C.

J'ai egalement essy� : =SOMMEPROD((A2:A1000="EUR")*(B2:B1000)) mais l�
�a m'additionne tous les mois confondus sans tenir compte du filtre.

Merci.



On 8 mai, 00:18, isabelle wrote:
bonjour Xavier

quel est la (ou les) condition du filtre ?

isabelle




Bonjour à tous,

Après avoir fait un filtre, je me retrouve avec sous colonne A les
monnaies (EUR, USD) et en regard de la colonne B, les montants.

Comment faire pour avoir la somme des EUR dans une cellule (W1) et la
somme USD dans une autre (X1) sans pour autant additionner les données
masquées.

J'ai bien essayer la formule =SOUS.TOTAL(109;B2:B65536), mais ça
m'additionne toutes les monnaies confondues.

Merci pour votre aide.
Salutations
Xavier- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



MichDenis
Le #4494261
En supposant que dans la colonne A2:A10 = EUR ou USD
et qu'en colonne B tu as les montants en B2:B10

Il ne te reste plus qu'à adapter les plages de cellules.

Pour calculer la somme pour les EUR pour la plage filtrée
Validation Matricielle : Maj + Ctrl + Enter
=SOMME(SI(SOUS.TOTAL(9;DECALER(B2;LIGNE(B2:B10)-LIGNE(B2);));(A2:A10="EUR")*B2:B10))

Pour calculer la somme pour les USD pour la plage filtrée
=SOMME(SI(SOUS.TOTAL(9;DECALER(B2;LIGNE(B2:B10)-LIGNE(B2);));(A2:A10="USD")*B2:B10))



Bonjour à tous,

Après avoir fait un filtre, je me retrouve avec sous colonne A les
monnaies (EUR, USD) et en regard de la colonne B, les montants.

Comment faire pour avoir la somme des EUR dans une cellule (W1) et la
somme USD dans une autre (X1) sans pour autant additionner les données
masquées.

J'ai bien essayer la formule =SOUS.TOTAL(109;B2:B65536), mais ça
m'additionne toutes les monnaies confondues.

Merci pour votre aide.
Salutations
Xavier
isabelle
Le #4494241
bonjour Xavier,

est ce que la réponse de Denis te convient ?

isabelle

Bonjour Isabelle,

Le filtre est fait sur la colonne C avec les mois :

Exemple de mon tableau

A B C
EUR 50 JANVIER
USD 20 JANVIER
USD 70 JANVIER
EUR 20 JANVIER
USD 50 JANVIER
EUR 10 FEVRIER
USD 20 FEVRIER
etc.....

les totaux changeraient en fonctions du filtre effectu� sur la colonne
C.

J'ai egalement essy� : =SOMMEPROD((A2:A1000="EUR")*(B2:B1000)) mais l�
�a m'additionne tous les mois confondus sans tenir compte du filtre.

Merci.



On 8 mai, 00:18, isabelle wrote:

bonjour Xavier

quel est la (ou les) condition du filtre ?

isabelle





Bonjour ? tous,

Apr?s avoir fait un filtre, je me retrouve avec sous colonne A les
monnaies (EUR, USD) et en regard de la colonne B, les montants.

Comment faire pour avoir la somme des EUR dans une cellule (W1) et la
somme USD dans une autre (X1) sans pour autant additionner les donn?es
masqu?es.

J'ai bien essayer la formule =SOUS.TOTAL(109;B2:B65536), mais ?a
m'additionne toutes les monnaies confondues.

Merci pour votre aide.
Salutations
Xavier- Masquer le texte des messages pr?c?dents -


- Afficher le texte des messages pr?c?dents -








JB
Le #4494221
Bonjour,

=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("b"&LIGNE(B2:B1000)))*(A2:A1000="Eur" )))

http://boisgontierjacques.free.fr/fichiers/Filtre/FiltreSommeZoneFiltree.xls

Cordialement JB

On 8 mai, 00:13, wrote:
Bonjour à tous,

Après avoir fait un filtre, je me retrouve avec sous colonne A les
monnaies (EUR, USD) et en regard de la colonne B, les montants.

Comment faire pour avoir la somme des EUR dans une cellule (W1) et la
somme USD dans une autre (X1) sans pour autant additionner les données
masquées.

J'ai bien essayer la formule =SOUS.TOTAL(109;B2:B65536), mais ça
m'additionne toutes les monnaies confondues.

Merci pour votre aide.
Salutations
Xavier


Jean-Paul V
Le #4494161
Bonjour

Pour moi la solution de Jacques est la meilleure, je me la mets de côté, je
vais essayer de la modifier en créant des noms de champ devises, pays,
montant , ce qui devrait simplifier la lecture de la fonction.Je vais
également la placer plus bas,car lorsque l'on fait des filtres on ne voit
plus le résultat

Merci à tous


Bonjour,

=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("b"&LIGNE(B2:B1000)))*(A2:A1000="Eur")))

http://boisgontierjacques.free.fr/fichiers/Filtre/FiltreSommeZoneFiltree.xls

Cordialement JB

On 8 mai, 00:13, wrote:
Bonjour à tous,

Après avoir fait un filtre, je me retrouve avec sous colonne A les
monnaies (EUR, USD) et en regard de la colonne B, les montants.

Comment faire pour avoir la somme des EUR dans une cellule (W1) et la
somme USD dans une autre (X1) sans pour autant additionner les données
masquées.

J'ai bien essayer la formule =SOUS.TOTAL(109;B2:B65536), mais ça
m'additionne toutes les monnaies confondues.

Merci pour votre aide.
Salutations
Xavier







domivax
Le #4508711
Bonjour ? tous,

Apr?s avoir fait mes test avec les deux solutions (puisque les deux
marchent parfaitement), j'ai enfin opt? pour la solution de MichDenis
car avec cette solution mes Userform s'ouvre plus rapidement qu'avec
la solution de JB.

Bonne fin de semaine ? tous.
Xavier
Publicité
Poster une réponse
Anonyme