Somme conditionnelle

Le
Jérôme
Bonjour

Je n'arrive pas à obtenir ce que je veux avec excell. (mes cours sont
bien loin)

Voilà, j'ai une colonne avec une date et une avec un montant.

Je souhaiterais faire la somme des montant dont la date est dans une
certaine plage de valeur.

Est-ce possible ? si oui (ce dont je ne doute pas), comment procéder ?

Merci
@+
Jérôme
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #18994951
Bonjour.
Avec les dates en colonne A, les montants en colonne B et les bornes en
C1 et D1 :
=SOMMEPROD((A1:A100>Á)*(A1:A100<Ñ)*B1:B100)
Cordialement.
Daniel

Bonjour

Je n'arrive pas à obtenir ce que je veux avec excell. (mes cours sont bien
loin)

Voilà, j'ai une colonne avec une date et une avec un montant.

Je souhaiterais faire la somme des montant dont la date est dans une certaine
plage de valeur.

Est-ce possible ? si oui (ce dont je ne doute pas), comment procéder ?

Merci
@+
Jérôme


ChristianM
Le #18994941
Bonjour;
si dates dans plage a2:a100
si valeurs dans plage b2:b100
première date en C1
deuxième date en D1

=SOMMEPROD(($A$2:$A$100>Á)*($A$2:$A$100<Ñ)*($B$2:$B$100))

--
ChristianM


"Jérôme" 49cce48d$0$7886$
Bonjour

Je n'arrive pas à obtenir ce que je veux avec excell. (mes cours sont bien
loin)

Voilà, j'ai une colonne avec une date et une avec un montant.

Je souhaiterais faire la somme des montant dont la date est dans une
certaine plage de valeur.

Est-ce possible ? si oui (ce dont je ne doute pas), comment procéder ?

Merci
@+
Jérôme


ChristianM
Le #18994931
en nommant les plages
A2:A100 date
B3:B100 valeur
=sommeprod((date>Á)*(date<Ñ)*valeur)


--
ChristianM


"Jérôme" 49cce48d$0$7886$
Bonjour

Je n'arrive pas à obtenir ce que je veux avec excell. (mes cours sont bien
loin)

Voilà, j'ai une colonne avec une date et une avec un montant.

Je souhaiterais faire la somme des montant dont la date est dans une
certaine plage de valeur.

Est-ce possible ? si oui (ce dont je ne doute pas), comment procéder ?

Merci
@+
Jérôme


Jacky
Le #18994921
Bonjour,

=SOMMEPROD((PlageDate>=Ladatedebut)*(PlageDate<=LaDateFin)*plageDesmontants)
ou
s'il y a du texte dans la plage des montants
=SOMMEPROD((PlageDate>=Ladatedebut)*(PlageDate<=LaDateFin)*1;(plageDesmontants))


--
Salutations
JJ


"Jérôme" 49cce48d$0$7886$
Bonjour

Je n'arrive pas à obtenir ce que je veux avec excell. (mes cours sont bien
loin)

Voilà, j'ai une colonne avec une date et une avec un montant.

Je souhaiterais faire la somme des montant dont la date est dans une
certaine plage de valeur.

Est-ce possible ? si oui (ce dont je ne doute pas), comment procéder ?

Merci
@+
Jérôme


garnote
Le #18995081
Ou bien (exemple) :

Tes dates en A1:A16
Tes montants en B1:B16
Date début en C1, C2, C3 ...
Date fin en D1, D2, D3 ...
Mettre cette formule en E1
=SOMME(($A$1:$A$16<Ñ)*($A$1:$A$16>Á)*($B$1:$B$16))
et valider par Ctrl+Maj+Entrée.
Recopier vers le bas.

Serge


"Jérôme"
Bonjour

Je n'arrive pas à obtenir ce que je veux avec excell. (mes cours sont bien loin)

Voilà, j'ai une colonne avec une date et une avec un montant.

Je souhaiterais faire la somme des montant dont la date est dans une certaine plage de valeur.

Est-ce possible ? si oui (ce dont je ne doute pas), comment procéder ?

Merci
@+
Jérôme


Jérôme
Le #18995061
ChristianM a écrit :
Bonjour;
si dates dans plage a2:a100
si valeurs dans plage b2:b100
première date en C1
deuxième date en D1

=SOMMEPROD(($A$2:$A$100>Á)*($A$2:$A$100<Ñ)*($B$2:$B$100))



Merci de ta réponse rapide

ton code me donne N/A
J'ai testé
date de C2 à C100
Val de E2 à E100
date 1 en H7
date 2 en I7
=SOMMEPROD(C2:C100>=H7;C2:C100<=I7;E2:E100)
qui donne 0 ce qui est faux :-S

Par ailleurs j'avais cherché du coté de SOMME.SI mais sans succès !

@+
jérôme
Jérôme
Le #18995161
garnote a écrit :
Ou bien (exemple) :

Tes dates en A1:A16
Tes montants en B1:B16
Date début en C1, C2, C3 ...
Date fin en D1, D2, D3 ...
Mettre cette formule en E1
=SOMME(($A$1:$A$16<Ñ)*($A$1:$A$16>Á)*($B$1:$B$16))
et valider par Ctrl+Maj+Entrée.
Recopier vers le bas.


Ceci fonctionne
Merci bien
Par contre, quel est la fonction du signe * ici ET, quel est l'action du
shift+ctrl+entrée ???

Merci beaucoup
@+
Jérôme
ChristianM
Le #18995151
a priori ta formule est fausse : il n'y a pas de points virgules mais des
parenthèses et des * (multiplier)

=SOMMEPROD((C2:C100>=H7)*(C2:C100<=I7)*(E2:E100))

En fait chaque élément est comparé et donne vrai ou faux
ou 1 et 0 en algèbre de Boole
1*1 =1
1*0 = 0

donc si tout est vrai = 1 * 1 * valeur ==> valeur
et ceci pour chaque ligne qui est ensuité sommée.



--
ChristianM


"Jérôme" 49ccec63$0$20704$
ChristianM a écrit :
Bonjour;
si dates dans plage a2:a100
si valeurs dans plage b2:b100
première date en C1
deuxième date en D1

=SOMMEPROD(($A$2:$A$100>Á)*($A$2:$A$100<Ñ)*($B$2:$B$100))



Merci de ta réponse rapide

ton code me donne N/A
J'ai testé
date de C2 à C100
Val de E2 à E100
date 1 en H7
date 2 en I7
=SOMMEPROD(C2:C100>=H7;C2:C100<=I7;E2:E100)
qui donne 0 ce qui est faux :-S

Par ailleurs j'avais cherché du coté de SOMME.SI mais sans succès !

@+
jérôme


Jérôme
Le #18995251
ChristianM a écrit :
a priori ta formule est fausse : il n'y a pas de points virgules mais des
parenthèses et des * (multiplier)

=SOMMEPROD((C2:C100>=H7)*(C2:C100<=I7)*(E2:E100))

En fait chaque élément est comparé et donne vrai ou faux
ou 1 et 0 en algèbre de Boole
1*1 =1
1*0 = 0

donc si tout est vrai = 1 * 1 * valeur ==> valeur
et ceci pour chaque ligne qui est ensuité sommée.



Merci
cela fonctionne

Merci aussi pour l'explication
@+ Jérôme
ChristianM
Le #18995231
tu as plein d'exemples sur internet :

http://www.admexcel.com/fmath.htm#sommeprod
http://www.excelabo.net/moteurs/motsclefs.php?mot=sommeprod
http://boisgontierjacques.free.fr/
http://www.top-assistante.com/bureau/excel/cumuler_nbsi.php

etc ...


--
ChristianM


"Jérôme" 49ccec63$0$20704$
ChristianM a écrit :
Bonjour;
si dates dans plage a2:a100
si valeurs dans plage b2:b100
première date en C1
deuxième date en D1

=SOMMEPROD(($A$2:$A$100>Á)*($A$2:$A$100<Ñ)*($B$2:$B$100))



Merci de ta réponse rapide

ton code me donne N/A
J'ai testé
date de C2 à C100
Val de E2 à E100
date 1 en H7
date 2 en I7
=SOMMEPROD(C2:C100>=H7;C2:C100<=I7;E2:E100)
qui donne 0 ce qui est faux :-S

Par ailleurs j'avais cherché du coté de SOMME.SI mais sans succès !

@+
jérôme


Publicité
Poster une réponse
Anonyme