Somme conditionnelle pour des critères correspondant à des plage s

Le
MatPin
J'ai dans une première colonne des lettres de "1" à "100".
Dans les 2 colonnes d'à côté j'ai d’autres nombres.
Je veux faire la somme des nombres des 2 dernières colonnes pour certaines
plages de nombres de la première colonne
En gros (la formule est fausse mais c'est pour expliquer) :
SOMME.SI(A1:A100;">2 & <5" ou ">8 & <12";B1:C100)

A B C
1 2 6
2 3 5
3 4 1
4 8 4
5 6 7
6 6 4
7 8 1
8 1 1
9 3 1
10 8 2
11 1 1
12 6 2

Je devrais ici obtenir 64 (en considérant inférieur ou égal & supérieur ou
égal)

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
lSteph
Le #4271531
Bonjour,

=SOMMEPROD(($A$1:$A$100>2)*($A$1:$A$100<5)*($B$1:$C$100))+SOMMEPROD(($A
$1:$A$100>8)*($B$1:$C$100))

ce qui donne 41

En considérant >= et =<

=SOMMEPROD(($A$1:$A$100>=2)*($A$1:$A$100<=5)*($B$1:$C$100))
+SOMMEPROD(($A$1:$A$100>=8)*($B$1:$C$100))

ce qui donne 64



Cordialement.

lSteph

On 5 avr, 11:08, MatPin
J'ai dans une première colonne des lettres de "1" à "100".
Dans les 2 colonnes d'à côté j'ai d'autres nombres.
Je veux faire la somme des nombres des 2 dernières colonnes pour certai nes
plages de nombres de la première colonne
En gros (la formule est fausse mais c'est pour expliquer) :
SOMME.SI(A1:A100;">2 & <5" ou ">8 & <12";B1:C100)

A B C
1 2 6
2 3 5
3 4 1
4 8 4
5 6 7
6 6 4
7 8 1
8 1 1
9 3 1
10 8 2
11 1 1
12 6 2

Je devrais ici obtenir 64 (en considérant inférieur ou égal & sup érieur ou
égal)

Merci


Publicité
Poster une réponse
Anonyme