Somme

Le
Patrick
Bonjour,
Je n'arrive pas à faire la somme de différentes cellules en fonction d'autre
cellule.
J'ai le n° de semaine qui correspond au jour et je voudrais additionner pour
avoir l'horaire total de la semaine?
Exp:JAN 2008
En A n° de semaine
En B le jour
En C l'heure
En D1 la somme de la semaine 1
En D2 la somme de la semaine 2

A1 = 1 B1 = mardi 1 C1 = 0:00
A2 = 1 B2 = mercredi 2 C2 = 7:00
A3 = 1 B3 = jeudi 3 C3 = 7:30
A4 = 1 B4 = vendredi 4 C4 = 7:00
A5 = 1 B5 = samedi 5 C5 = 8:00
A6 = 1 B6 = dimanche 6 C6 = 7:00
A7 = 2 B7 = lundi 7 C7 = 7:30
A8 = 2 B8 = mardi 8 C8 = 8:00
Le contenu des cellules changent avec l'année en JAN 2009 A5 = 2 B5 = lundi
5 C5 = 8:00
Donc je pense qu'il faut sillonner les cellules des semaines récupérer les
1;2;3et en même temps additionner les horaires correspondants !
Mais voilà comment faire
Merci pour votre aides.
Bonne matinée.
Patrick.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5225321
Bonjour,

=SOMME.SI(A1:A100;1;C1:C100)

JB
On 20 mar, 09:02, "Patrick"
Bonjour,
Je n'arrive pas à faire la somme de différentes cellules en fonction d 'autre
cellule.
J'ai le n° de semaine qui correspond au jour et je voudrais additionner pour
avoir l'horaire total de la semaine?
Exp:JAN 2008
En A n° de semaine
En B le jour
En C l'heure
En D1 la somme de la semaine 1
En D2 la somme de la semaine 2...

A1 = 1  B1 = mardi 1        C1 = 0:00
A2 = 1  B2 = mercredi 2    C2 = 7:00
A3 = 1  B3 = jeudi 3          C3 = 7:30
A4 = 1  B4 = vendredi 4    C4 = 7:00
A5 = 1  B5 = samedi 5       C5 = 8:00
A6 = 1  B6 = dimanche 6    C6 = 7:00
A7 = 2  B7 = lundi 7        C7 = 7:30
A8 = 2  B8 = mardi 8        C8 = 8:00
Le contenu des cellules changent avec l'année en JAN 2009 A5 = 2  B5 = lundi
5  C5 = 8:00
Donc je pense qu'il faut sillonner les cellules des semaines récupérer les
1;2;3...et en même temps additionner les horaires correspondants !
Mais voilà comment faire...
Merci  pour votre aides.
Bonne matinée.
Patrick.


Jacky
Le #5225301
Bonjour,

Essaie:
en d1:
=SOMME.SI(($A$1:$A$1000);A1;($C$1:$C$1000))
en d2
=SI(A1¢;"";SOMME.SI(($A$1:$A$1000);A2;($C$1:$C$1000)))
et recopier vers le bas

Ou
en d1
=SOMME.SI(($A$1:$A$1000);LIGNE();($C$1:$C$1000))
et recopier vers le bas

Format [h]:mm
Adapter les plages

--
Salutations
JJ


"Patrick"
Bonjour,
Je n'arrive pas à faire la somme de différentes cellules en fonction
d'autre cellule.
J'ai le n° de semaine qui correspond au jour et je voudrais additionner
pour avoir l'horaire total de la semaine?
Exp:JAN 2008
En A n° de semaine
En B le jour
En C l'heure
En D1 la somme de la semaine 1
En D2 la somme de la semaine 2...

A1 = 1 B1 = mardi 1 C1 = 0:00
A2 = 1 B2 = mercredi 2 C2 = 7:00
A3 = 1 B3 = jeudi 3 C3 = 7:30
A4 = 1 B4 = vendredi 4 C4 = 7:00
A5 = 1 B5 = samedi 5 C5 = 8:00
A6 = 1 B6 = dimanche 6 C6 = 7:00
A7 = 2 B7 = lundi 7 C7 = 7:30
A8 = 2 B8 = mardi 8 C8 = 8:00
Le contenu des cellules changent avec l'année en JAN 2009 A5 = 2 B5 =
lundi 5 C5 = 8:00
Donc je pense qu'il faut sillonner les cellules des semaines récupérer les
1;2;3...et en même temps additionner les horaires correspondants !
Mais voilà comment faire...
Merci pour votre aides.
Bonne matinée.
Patrick.




Patrick
Le #5225091
Bonjour,
Je viens d'essayer c'est ok .
J'aimerai déterminer plus précisément la Plage
B4:P4;B12:P12;B20:P20;B28:P28;B36:P36;B44:P44;B52
et la Somme_Plage
B10;E10;H10;K10;N10;B18;E18;H18;K18;N18;B26;E26;H26;K26;N26;B34;E34;H34;K34;N34;B42;E42;H42;K42;N42;B50;E50;H50;K50;N50;B58
Pensez-vous que c'est possible ? parce que Excel ne veux pas !
Merci bonne aprés midi.
Merci à Jacky aussi.
Patrick.

"JB"
Bonjour,

=SOMME.SI(A1:A100;1;C1:C100)

JB
On 20 mar, 09:02, "Patrick"
Bonjour,
Je n'arrive pas à faire la somme de différentes cellules en fonction
d'autre
cellule.
J'ai le n° de semaine qui correspond au jour et je voudrais additionner
pour
avoir l'horaire total de la semaine?
Exp:JAN 2008
En A n° de semaine
En B le jour
En C l'heure
En D1 la somme de la semaine 1
En D2 la somme de la semaine 2...

A1 = 1 B1 = mardi 1 C1 = 0:00
A2 = 1 B2 = mercredi 2 C2 = 7:00
A3 = 1 B3 = jeudi 3 C3 = 7:30
A4 = 1 B4 = vendredi 4 C4 = 7:00
A5 = 1 B5 = samedi 5 C5 = 8:00
A6 = 1 B6 = dimanche 6 C6 = 7:00
A7 = 2 B7 = lundi 7 C7 = 7:30
A8 = 2 B8 = mardi 8 C8 = 8:00
Le contenu des cellules changent avec l'année en JAN 2009 A5 = 2 B5 =
lundi
5 C5 = 8:00
Donc je pense qu'il faut sillonner les cellules des semaines récupérer les
1;2;3...et en même temps additionner les horaires correspondants !
Mais voilà comment faire...
Merci pour votre aides.
Bonne matinée.
Patrick.


JB
Le #5225071
Fonction perso SommeSiMZ()

=SommeSiMZ((C3:C6;C9:C12);1;(A3:A6;A9:A12))

Function SommeSiMZ(champrech As Range, valCherchée, champSomme)
Application.Volatile
temp = 0
For i = 1 To champrech.Areas.Count
For j = 1 To champrech.Areas(i).Count
If valCherchée = champrech.Areas(i)(j) Then
temp = temp + champSomme.Areas(i)(j)
End If
Next j
Next i
SommeSiMZ = temp
End Function

http://cjoint.com/?duoNRfYxG5

JB
http://boisgontierjacques.free.fr

On 20 mar, 14:07, "Patrick"
Bonjour,
Je viens d'essayer c'est ok .
J'aimerai déterminer plus précisément la Plage
B4:P4;B12:P12;B20:P20;B28:P28;B36:P36;B44:P44;B52
et la Somme_Plage
B10;E10;H10;K10;N10;B18;E18;H18;K18;N18;B26;E26;H26;K26;N26;B34;E34;H34;K3 4­;N34;B42;E42;H42;K42;N42;B50;E50;H50;K50;N50;B58
Pensez-vous que c'est possible ? parce que Excel ne veux pas !
Merci bonne aprés midi.
Merci  à  Jacky aussi.
Patrick.

"JB"
Bonjour,

=SOMME.SI(A1:A100;1;C1:C100)

JB
On 20 mar, 09:02, "Patrick"


Bonjour,
Je n'arrive pas à faire la somme de différentes cellules en fonction
d'autre
cellule.
J'ai le n° de semaine qui correspond au jour et je voudrais additionne r
pour
avoir l'horaire total de la semaine?
Exp:JAN 2008
En A n° de semaine
En B le jour
En C l'heure
En D1 la somme de la semaine 1
En D2 la somme de la semaine 2...

A1 = 1 B1 = mardi 1 C1 = 0:00
A2 = 1 B2 = mercredi 2 C2 = 7:00
A3 = 1 B3 = jeudi 3 C3 = 7:30
A4 = 1 B4 = vendredi 4 C4 = 7:00
A5 = 1 B5 = samedi 5 C5 = 8:00
A6 = 1 B6 = dimanche 6 C6 = 7:00
A7 = 2 B7 = lundi 7 C7 = 7:30
A8 = 2 B8 = mardi 8 C8 = 8:00
Le contenu des cellules changent avec l'année en JAN 2009 A5 = 2 B5 =
lundi
5 C5 = 8:00
Donc je pense qu'il faut sillonner les cellules des semaines récupér er les
1;2;3...et en même temps additionner les horaires correspondants !
Mais voilà comment faire...
Merci pour votre aides.
Bonne matinée.
Patrick.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Patrick
Le #5224411
Bonsoir,
Merci de votre réponse qui fonctionne bien aussi.
Bonne soirée.
Patrick.
"Jacky"
Bonjour,

Essaie:
en d1:
=SOMME.SI(($A$1:$A$1000);A1;($C$1:$C$1000))
en d2
=SI(A1¢;"";SOMME.SI(($A$1:$A$1000);A2;($C$1:$C$1000)))
et recopier vers le bas

Ou
en d1
=SOMME.SI(($A$1:$A$1000);LIGNE();($C$1:$C$1000))
et recopier vers le bas

Format [h]:mm
Adapter les plages

--
Salutations
JJ


"Patrick"
Bonjour,
Je n'arrive pas à faire la somme de différentes cellules en fonction
d'autre cellule.
J'ai le n° de semaine qui correspond au jour et je voudrais additionner
pour avoir l'horaire total de la semaine?
Exp:JAN 2008
En A n° de semaine
En B le jour
En C l'heure
En D1 la somme de la semaine 1
En D2 la somme de la semaine 2...

A1 = 1 B1 = mardi 1 C1 = 0:00
A2 = 1 B2 = mercredi 2 C2 = 7:00
A3 = 1 B3 = jeudi 3 C3 = 7:30
A4 = 1 B4 = vendredi 4 C4 = 7:00
A5 = 1 B5 = samedi 5 C5 = 8:00
A6 = 1 B6 = dimanche 6 C6 = 7:00
A7 = 2 B7 = lundi 7 C7 = 7:30
A8 = 2 B8 = mardi 8 C8 = 8:00
Le contenu des cellules changent avec l'année en JAN 2009 A5 = 2 B5 =
lundi 5 C5 = 8:00
Donc je pense qu'il faut sillonner les cellules des semaines récupérer
les 1;2;3...et en même temps additionner les horaires correspondants !
Mais voilà comment faire...
Merci pour votre aides.
Bonne matinée.
Patrick.








Publicité
Poster une réponse
Anonyme