Somme entre deux dates

Le
Eric (C)
Bonjour à tous,

Haaa encore un problème de dates
Problème : Je voudrais faire le total de nombres (montants) encodés
par quinzaine et pour tous les mois de l'année.

J'ai deux colonnes.
La première (A) contient des dates au format jj/mm/aa
Les dates sont normalement classées par ordre croissant mais une même
date peut se répéter sur plusieurs cellules.
Je peux avoir 3x le 4/01/09 en suivant par exemple.

La seconde colonne (B) contient des nombres (montants). Il n'y a pas
des nombres dans toutes les cellules.

Dans une troisième colonne (C) j'ai 24 cellules. Cela correspond au 24
quinzaines d'une année calendrier.
La première cellule (C1) doit contenir le total des nombres de la
colonne (B) pour les 15 premiers jours de janvier indiqués en colonne
(A)
La seconde cellule (C2) doit contenir le total des nombres de (B) pour
la seconde quinzaine de janvier.
La C3 le total des nombres de la première quinzaine de février, etc

J'ai essayé avec SOMMEPROD mais sans succès.
Quelqu'un peut-il me mettre sur la voie de la solution ?
D'avance merci et bon week-end

Eric (C)
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #18550521
Exemple pour additionner les sommes en colonne B:B entre
le 1 et 14 février 2009, Les dates en colonnes A:A

=SOMMEPROD((A1:A31>="1/02/2009"*1)*(A1:A31<="14/02/2009"*1);(B1:B31))



"Eric (C)"
Bonjour à tous,

Haaa encore un problème de dates...
Problème : Je voudrais faire le total de nombres (montants) encodés
par quinzaine et pour tous les mois de l'année.

J'ai deux colonnes.
La première (A) contient des dates au format jj/mm/aa
Les dates sont normalement classées par ordre croissant mais une même
date peut se répéter sur plusieurs cellules.
Je peux avoir 3x le 4/01/09 en suivant par exemple.

La seconde colonne (B) contient des nombres (montants). Il n'y a pas
des nombres dans toutes les cellules.

Dans une troisième colonne (C) j'ai 24 cellules. Cela correspond au 24
quinzaines d'une année calendrier.
La première cellule (C1) doit contenir le total des nombres de la
colonne (B) pour les 15 premiers jours de janvier indiqués en colonne
(A)
La seconde cellule (C2) doit contenir le total des nombres de (B) pour
la seconde quinzaine de janvier.
La C3 le total des nombres de la première quinzaine de février, etc...

J'ai essayé avec SOMMEPROD mais sans succès.
Quelqu'un peut-il me mettre sur la voie de la solution ?
D'avance merci et bon week-end

Eric (C)
Merguez07
Le #18551641
si avec sommeprod on y arrive:

en C1 il faut marquer un truc du style
=SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚTE(2009;ARRONDI.SUP(LIGNE()/2;0);1))*(($A$1:$A$100)<DATE(2009;ARRONDI.SUP(LIGNE()/2;0);15)))

idem en C3 et toutes les lignes impaires
en C2
=SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚTE(2009;ARRONDI.SUP(LIGNE()/2;0);15))*(($A$1:$A$100)<DATE(2009;ARRONDI.SUP(LIGNE()/2;0)+1;1)))
idem en C4 et toutes les lignes paires


Xavier





Eric (C) a écrit :
Bonjour à tous,

Haaa encore un problème de dates...
Problème : Je voudrais faire le total de nombres (montants) encodés
par quinzaine et pour tous les mois de l'année.

J'ai deux colonnes.
La première (A) contient des dates au format jj/mm/aa
Les dates sont normalement classées par ordre croissant mais une même
date peut se répéter sur plusieurs cellules.
Je peux avoir 3x le 4/01/09 en suivant par exemple.

La seconde colonne (B) contient des nombres (montants). Il n'y a pas
des nombres dans toutes les cellules.

Dans une troisième colonne (C) j'ai 24 cellules. Cela correspond au 24
quinzaines d'une année calendrier.
La première cellule (C1) doit contenir le total des nombres de la
colonne (B) pour les 15 premiers jours de janvier indiqués en colonne
(A)
La seconde cellule (C2) doit contenir le total des nombres de (B) pour
la seconde quinzaine de janvier.
La C3 le total des nombres de la première quinzaine de février, etc...

J'ai essayé avec SOMMEPROD mais sans succès.
Quelqu'un peut-il me mettre sur la voie de la solution ?
D'avance merci et bon week-end

Eric (C)


Eric (C)
Le #18552701
Merci pour la formule.
J'ai toutefois un #REF! magnifique qui s'inscrit quand je valide.

Si j'ai bien traduit la formule, le prgm regarde d'abord en colonne A
si elle n'est pas vide et additionne chaque terme en col. B chaque
fois que A n'est pas vide si et seulement si ...et puis je ne
comprends pas le reste de la formule.

Je vois bien que tu démarres du 1er jusqu'au 15 mais comment je
détermine le mois ?


Le #REF! qui apparait : Je me demande si cela ne vient pas de ...LIGNE
()/2;0):1.... dont je ne comprends pas la signification au sein de la
formule.
Peux-tu m'éclairer ?

Merci d'avance

Eric (C)





On 1 fév, 17:24, Merguez07
si avec sommeprod on y arrive:

en C1 il faut marquer un truc du style
=SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚTE(2 009;AR­RONDI.SUP(LIGNE()/2;0);1))*(($A$1:$A$100)<DATE(2009;ARRONDI.SUP(LI GNE()/2;0­);15)))

idem en C3 et toutes les lignes impaires
en C2
=SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚTE(2 009;AR­RONDI.SUP(LIGNE()/2;0);15))*(($A$1:$A$100)<DATE(2009;ARRONDI.SUP(L IGNE()/2;­0)+1;1)))
idem en C4 et toutes les lignes paires

Xavier



Merguez07
Le #18552791
peux tu m'envoyer ton fichier en ci-joint car je vois pas ce qui colle pas

xavier



Eric (C) a écrit :
Merci pour la formule.
J'ai toutefois un #REF! magnifique qui s'inscrit quand je valide.

Si j'ai bien traduit la formule, le prgm regarde d'abord en colonne A
si elle n'est pas vide et additionne chaque terme en col. B chaque
fois que A n'est pas vide si et seulement si ...et puis je ne
comprends pas le reste de la formule.

Je vois bien que tu démarres du 1er jusqu'au 15 mais comment je
détermine le mois ?


Le #REF! qui apparait : Je me demande si cela ne vient pas de ...LIGNE
()/2;0):1.... dont je ne comprends pas la signification au sein de la
formule.
Peux-tu m'éclairer ?

Merci d'avance

Eric (C)





On 1 fév, 17:24, Merguez07
si avec sommeprod on y arrive:

en C1 il faut marquer un truc du style
=SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚTE(2009;AR­RONDI.SUP(LIGNE()/2;0);1))*(($A$1:$A$100)<DATE(2009;ARRONDI.SUP(LIGNE()/2;0­);15)))

idem en C3 et toutes les lignes impaires
en C2
=SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚTE(2009;AR­RONDI.SUP(LIGNE()/2;0);15))*(($A$1:$A$100)<DATE(2009;ARRONDI.SUP(LIGNE()/2;­0)+1;1)))
idem en C4 et toutes les lignes paires

Xavier





Eric (C)
Le #18552941
Merci cela fonctionne très bien.
Juste une précision : si dans la colonne B je n'ai pas des nombres
mais des "X", comment faire pour additionner le nombre de cellules
cochées "X" selon le même principe ?




On 1 fév, 15:22, "michdenis"
Exemple pour additionner les sommes en colonne B:B entre
le 1 et 14 février 2009, Les dates en colonnes A:A

=SOMMEPROD((A1:A31>="1/02/2009"*1)*(A1:A31<="14/02/2009"*1);(B1:B31 ))

"Eric (C)"
Bonjour à tous,

Haaa encore un problème de dates...
Problème : Je voudrais faire le total de nombres (montants) encodés
par quinzaine et pour tous les mois de l'année.

J'ai deux colonnes.
La première (A) contient des dates au format jj/mm/aa
Les dates sont normalement classées par ordre croissant mais une même
date peut se répéter sur plusieurs cellules.
Je peux avoir 3x le 4/01/09 en suivant par exemple.

La seconde colonne (B) contient des nombres (montants). Il n'y a pas
des nombres dans toutes les cellules.

Dans une troisième colonne (C) j'ai 24 cellules. Cela correspond au 24
quinzaines d'une année calendrier.
La première cellule (C1) doit contenir le total des nombres de la
colonne (B) pour les 15 premiers jours de janvier indiqués en colonne
(A)
La seconde cellule (C2) doit contenir le total des nombres de (B) pour
la seconde quinzaine de janvier.
La C3 le total des nombres de la première quinzaine de février, etc.. .

J'ai essayé avec SOMMEPROD mais sans succès.
Quelqu'un peut-il me mettre sur la voie de la solution ?
D'avance merci et bon week-end

Eric (C)


Eric (C)
Le #18552931
Xavier,

J'ai utilisé la formule de Michdenis en définitive.
Cela demande plus de chipottage (il faut ajouter les dates pour les 24
cellules concernées) mais cela me convient.

Je te remercie infiniment pour le temps que tu as passé à essayer de
résoudre mon problème. Cela m'a malgré tout beaucoup aidé.

Bonne fin de W-E


On 1 fév, 19:32, Merguez07
peux tu m'envoyer ton fichier en ci-joint car je vois pas ce qui colle pa s

xavier

Eric (C) a écrit :



> Merci pour la formule.
> J'ai toutefois un #REF! magnifique qui s'inscrit quand je valide.

> Si j'ai bien traduit la formule, le prgm regarde d'abord en colonne A
> si elle n'est pas vide et additionne chaque terme en col. B chaque
> fois que A n'est pas vide si et seulement si ...et puis je ne
> comprends pas le reste de la formule.

> Je vois bien que tu démarres du 1er jusqu'au 15 mais comment je
> détermine le mois ?

> Le #REF! qui apparait : Je me demande si cela ne vient pas de ...LIGNE
> ()/2;0):1.... dont je ne comprends pas la signification au sein de la
> formule.
> Peux-tu m'éclairer ?

> Merci d'avance

> Eric (C)

> On 1 fév, 17:24, Merguez07 >> si avec sommeprod on y arrive:

>> en C1 il faut marquer un truc du style
>> =SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚT E(2009;AR­­RONDI.SUP(LIGNE()/2;0);1))*(($A$1:$A$100)<DATE(2009;ARRONDI. SUP(LIGNE()/2;­0­);15)))

>> idem en C3 et toutes les lignes impaires
>> en C2
>> =SOMMEPROD((($A$1:$A$100)<>"")*($B$1:$B$100)*1*(($A$1:$A$100)>ÚT E(2009;AR­­RONDI.SUP(LIGNE()/2;0);15))*(($A$1:$A$100)<DATE(2009;ARRONDI .SUP(LIGNE()/2­;­0)+1;1)))
>> idem en C4 et toutes les lignes paires

>> Xavier- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


michdenis
Le #18552911
Tu veux faire un décompte du nombre de X présent
en colonne B
=SOMMEPROD((A1:A31>="1/02/2009"*1)*(A1:A31<="14/02/2009"*1)*(B1:B31="x"))


"Eric (C)"
Merci cela fonctionne très bien.
Juste une précision : si dans la colonne B je n'ai pas des nombres
mais des "X", comment faire pour additionner le nombre de cellules
cochées "X" selon le même principe ?




On 1 fév, 15:22, "michdenis"
Exemple pour additionner les sommes en colonne B:B entre
le 1 et 14 février 2009, Les dates en colonnes A:A

=SOMMEPROD((A1:A31>="1/02/2009"*1)*(A1:A31<="14/02/2009"*1);(B1:B31))

"Eric (C)"
Bonjour à tous,

Haaa encore un problème de dates...
Problème : Je voudrais faire le total de nombres (montants) encodés
par quinzaine et pour tous les mois de l'année.

J'ai deux colonnes.
La première (A) contient des dates au format jj/mm/aa
Les dates sont normalement classées par ordre croissant mais une même
date peut se répéter sur plusieurs cellules.
Je peux avoir 3x le 4/01/09 en suivant par exemple.

La seconde colonne (B) contient des nombres (montants). Il n'y a pas
des nombres dans toutes les cellules.

Dans une troisième colonne (C) j'ai 24 cellules. Cela correspond au 24
quinzaines d'une année calendrier.
La première cellule (C1) doit contenir le total des nombres de la
colonne (B) pour les 15 premiers jours de janvier indiqués en colonne
(A)
La seconde cellule (C2) doit contenir le total des nombres de (B) pour
la seconde quinzaine de janvier.
La C3 le total des nombres de la première quinzaine de février, etc...

J'ai essayé avec SOMMEPROD mais sans succès.
Quelqu'un peut-il me mettre sur la voie de la solution ?
D'avance merci et bon week-end

Eric (C)


Publicité
Poster une réponse
Anonyme