Somme - Excel 2007

Le
Dominique
Bonjour,

Pour compléter un tableau contenant des durées exprimées en minutes,
j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
type de formule utiliser ?

Je vous remercie par avance,
Dominique.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ChristianM
Le #17600421
Bonjour,
si tes données sont par exemple en A3:A9 :

=SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
--
ChristianM
"Dominique"
Bonjour,

Pour compléter un tableau contenant des durées exprimées en minutes,
j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
type de formule utiliser ?

Je vous remercie par avance,
Dominique.
Dominique
Le #17601071
Merci Christian pour ta rapidité !
En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 15
à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
Une autre idée ?

Dominique.


On 21 oct, 15:46, "ChristianM"
Bonjour,
si tes données sont par exemple en A3:A9 :
=SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
--
ChristianM
"Dominique"
Bonjour,

Pour compléter un tableau contenant des durées exprimées en minutes ,
j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
type de formule utiliser ?

Je vous remercie par avance,
Dominique.


François
Le #17601261
Bonjour,

Si tu veux en savoir plus sur la fonction SOMMEPROD, voici un site très
didactique :

http://boisgontierj.free.fr/pages_site/sommeprod.htm

François


"Dominique"
Merci Christian pour ta rapidité !
En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 15
à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
Une autre idée ?

Dominique.


On 21 oct, 15:46, "ChristianM"
Bonjour,
si tes données sont par exemple en A3:A9 :
=SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
--
ChristianM
"Dominique"
Bonjour,

Pour compléter un tableau contenant des durées exprimées en minutes,
j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
type de formule utiliser ?

Je vous remercie par avance,
Dominique.


ChristianM
Le #17601251
Ma formule additionne les valeurs comprises entre 0 et 15 dans la plage
indiquée. Il n'y a pas de produit, seulement l'utilisation de fait que si le
test est vrai alors valeur 1.
De ce fait, si par exemple en A4 on a 12, (a3:a9)< vaut 1 et (a3:a9)>0
vaut 1 donc on a 12*1*1 = 12, toutes les lignes étant sommées.
Ou alors, je n'ai pas compris la question ;-)

--
ChristianM
"Dominique"
Merci Christian pour ta rapidité !
En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 15
à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
Une autre idée ?

Dominique.


On 21 oct, 15:46, "ChristianM"
Bonjour,
si tes données sont par exemple en A3:A9 :
=SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
--
ChristianM
"Dominique"
Bonjour,

Pour compléter un tableau contenant des durées exprimées en minutes,
j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
type de formule utiliser ?

Je vous remercie par avance,
Dominique.


isabelle
Le #17601551
bonjour Dominique,

la solution de Christian fait exectement la somme des nombres ciblé :

par exemple : =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))

A3 = 2
A4 = 0
A5 = 0
A6 = 5
A7 = 0
A8 = 16
A9 = -1

le résulta est 7

isabelle

Dominique a écrit :
Merci Christian pour ta rapidité !
En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 15
à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
Une autre idée ?

Dominique.


On 21 oct, 15:46, "ChristianM"
Bonjour,
si tes données sont par exemple en A3:A9 :
=SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
--
ChristianM
"Dominique"
Bonjour,

Pour compléter un tableau contenant des durées exprimées en minutes,
j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
type de formule utiliser ?

Je vous remercie par avance,
Dominique.





Dominique
Le #17601701
Merci à tous !
Effectivement, ça marche très bien. Le résultat ne collait pas avec c e
que j'avais calculé manuellement, c'est pourquoi je pensais que la
formule ne marchait pas.
C'était mon calcul qui était faux... Trop nulle parfois !!!

Encore merci à tous et toutes,
Dominique.


On 21 oct, 17:36, isabelle wrote:
bonjour Dominique,

la solution de Christian fait exectement la somme des nombres ciblé :

par exemple : =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))

A3      =       2
A4      =       0
A5      =       0
A6      =       5
A7      =       0
A8      =       16
A9      =       -1

le résulta est 7

isabelle

Dominique a écrit :

> Merci Christian pour ta rapidité !
> En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 15
> à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
> Une autre idée ?

> Dominique.

> On 21 oct, 15:46, "ChristianM" >> Bonjour,
>> si tes données sont par exemple en A3:A9 :



>> =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
>> --
>> ChristianM
>> "Dominique" >>
>> Bonjour,

>> Pour compléter un tableau contenant des durées exprimées en minu tes,
>> j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
>> et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
>> type de formule utiliser ?

>> Je vous remercie par avance,
>> Dominique.


Dominique
Le #17605111
Re-bonjour,

Toujours sur le même tableau, un problème assez similaire : dans la
colonne A, j'ai des dates (01/01/2008...31/12/2008) et dans la colonne
H des types de réponses (Dossier, Fax, Téléphone, Courrier, etc.).
Cette fois, je voudrais compter le nombre de réponses sous forme de
dossier entre le 01/01/2008 et le 31/01/2008. Les deux colonnes sont
nommées Col_date et Col_forme_de_la_réponse. J'ai essayé d'adapter la
formule que Christian m'avait donnée précédemment, mais elle ne march e
pas puisque j'ai deux réponses 'dossier' en janvier mais la formule me
renvoie une répose de zéro... Où est l'erreur ?

=SOMMEPROD((Col_date)<="31/1")*((Col_date)>="1/1")*((Col_forme_de_la_ réponse)="Dossier")

A moins que SommeProd ne soit pas la formule qui convient ?

Merci,
Dominique.


On 21 oct, 18:00, Dominique
Merci à tous !
Effectivement, ça marche très bien. Le résultat ne collait pas avec ce
que j'avais calculé manuellement, c'est pourquoi je pensais que la
formule ne marchait pas.
C'était mon calcul qui était faux... Trop nulle parfois !!!

Encore merci à tous et toutes,
Dominique.

On 21 oct, 17:36, isabelle wrote:

> bonjour Dominique,

> la solution de Christian fait exectement la somme des nombres ciblé :

> par exemple : =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))

> A3      =       2
> A4      =       0
> A5      =       0
> A6      =       5
> A7      =       0
> A8      =       16
> A9      =       -1

> le résulta est 7

> isabelle

> Dominique a écrit :

> > Merci Christian pour ta rapidité !
> > En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 1 5
> > à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
> > Une autre idée ?

> > Dominique.

> > On 21 oct, 15:46, "ChristianM" > >> Bonjour,
> >> si tes données sont par exemple en A3:A9 :
> >> =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
> >> --
> >> ChristianM
> >> "Dominique" > >>
> >> Bonjour,

> >> Pour compléter un tableau contenant des durées exprimées en mi nutes,
> >> j'aurais besoin d'additionner l'ensemble des durées comprises entr e 0
> >> et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
> >> type de formule utiliser ?

> >> Je vous remercie par avance,
> >> Dominique.


isabelle
Le #17605791
bonjour Dominique,

il ne faut pas faire référence à des colonnes entière avec SOMMEPROD.
les références de colonne doivent pointé vers A1:A65535 et non vers A:A

isabelle

Dominique a écrit :
Re-bonjour,

Toujours sur le même tableau, un problème assez similaire : dans la
colonne A, j'ai des dates (01/01/2008...31/12/2008) et dans la colonne
H des types de réponses (Dossier, Fax, Téléphone, Courrier, etc.).
Cette fois, je voudrais compter le nombre de réponses sous forme de
dossier entre le 01/01/2008 et le 31/01/2008. Les deux colonnes sont
nommées Col_date et Col_forme_de_la_réponse. J'ai essayé d'adapter la
formule que Christian m'avait donnée précédemment, mais elle ne marche
pas puisque j'ai deux réponses 'dossier' en janvier mais la formule me
renvoie une répose de zéro... Où est l'erreur ?

=SOMMEPROD((Col_date)<="31/1")*((Col_date)>="1/1")*((Col_forme_de_la_réponse)="Dossier")

A moins que SommeProd ne soit pas la formule qui convient ?

Merci,
Dominique.


On 21 oct, 18:00, Dominique
Merci à tous !
Effectivement, ça marche très bien. Le résultat ne collait pas avec ce
que j'avais calculé manuellement, c'est pourquoi je pensais que la
formule ne marchait pas.
C'était mon calcul qui était faux... Trop nulle parfois !!!

Encore merci à tous et toutes,
Dominique.

On 21 oct, 17:36, isabelle wrote:

bonjour Dominique,
la solution de Christian fait exectement la somme des nombres ciblé :
par exemple : =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
A3 = 2
A4 = 0
A5 = 0
A6 = 5
A7 = 0
A8 = 16
A9 = -1
le résulta est 7
isabelle
Dominique a écrit :
Merci Christian pour ta rapidité !
En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 15
à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
Une autre idée ?
Dominique.
On 21 oct, 15:46, "ChristianM"
Bonjour,
si tes données sont par exemple en A3:A9 :
=SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
--
ChristianM
"Dominique"
Bonjour,
Pour compléter un tableau contenant des durées exprimées en minutes,
j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
type de formule utiliser ?
Je vous remercie par avance,
Dominique.











Christian M
Le #17605761
Bonsoir,
Peut-être comme cela car normalement cela devrait fonctionner :
1ère solution : mettre les dates dans F1 et F2

=SOMMEPROD((col_date<=$F$2)*(col_date>=$F$1)*(col_forme_de_la_réponse="Dossier"))

2ème solution : Excel interprète une date en foction de sa valeur (39478 =
31/01/2008) donc il faut convertir avec la fonction DATE()

=SOMMEPROD((col_date<ÚTE(2008;1;31))*(col_date>ÚTE(2008;1;1))*(col_forme_de_la_réponse="Dossier"))

Est-ce que cela convient ?

Christian

"Dominique"
Re-bonjour,

Toujours sur le même tableau, un problème assez similaire : dans la
colonne A, j'ai des dates (01/01/2008...31/12/2008) et dans la colonne
H des types de réponses (Dossier, Fax, Téléphone, Courrier, etc.).
Cette fois, je voudrais compter le nombre de réponses sous forme de
dossier entre le 01/01/2008 et le 31/01/2008. Les deux colonnes sont
nommées Col_date et Col_forme_de_la_réponse. J'ai essayé d'adapter la
formule que Christian m'avait donnée précédemment, mais elle ne marche
pas puisque j'ai deux réponses 'dossier' en janvier mais la formule me
renvoie une répose de zéro... Où est l'erreur ?

=SOMMEPROD((Col_date)<="31/1")*((Col_date)>="1/1")*((Col_forme_de_la_réponse)="Dossier")

A moins que SommeProd ne soit pas la formule qui convient ?

Merci,
Dominique.


On 21 oct, 18:00, Dominique
Merci à tous !
Effectivement, ça marche très bien. Le résultat ne collait pas avec ce
que j'avais calculé manuellement, c'est pourquoi je pensais que la
formule ne marchait pas.
C'était mon calcul qui était faux... Trop nulle parfois !!!

Encore merci à tous et toutes,
Dominique.

On 21 oct, 17:36, isabelle wrote:

> bonjour Dominique,

> la solution de Christian fait exectement la somme des nombres ciblé :

> par exemple : =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))

> A3 = 2
> A4 = 0
> A5 = 0
> A6 = 5
> A7 = 0
> A8 = 16
> A9 = -1

> le résulta est 7

> isabelle

> Dominique a écrit :

> > Merci Christian pour ta rapidité !
> > En fait, il n'y a pas de produit, uniquement des nombres entre 0 et 15
> > à additionner, donc la fonction "SOMMEPROD" ne peut s'appliquer.
> > Une autre idée ?

> > Dominique.

> > On 21 oct, 15:46, "ChristianM" > >> Bonjour,
> >> si tes données sont par exemple en A3:A9 :
> >> =SOMMEPROD((A3:A9)*((A3:A9)<)*((A3:A9)>0))
> >> --
> >> ChristianM
> >> "Dominique" > >>
> >> Bonjour,

> >> Pour compléter un tableau contenant des durées exprimées en minutes,
> >> j'aurais besoin d'additionner l'ensemble des durées comprises entre 0
> >> et 15 mn en ignorant toutes les autres. Pourriez-vous me dire quel
> >> type de formule utiliser ?

> >> Je vous remercie par avance,
> >> Dominique.


Dominique
Le #17607191
Je ne comprends pas pourquoi ma formule ne marche pas. En tout cas,
Christian, les deux tiennes marchent très bien.
Et effectivement, j'avais bien nommé mes colonnes sur la seule hauteur
de mon tableau (A5:A504).

Merci beaucoup à tous les deux,
Dominique.

On 21 oct, 23:26, "Christian M" wrote:
Suite à la réponse d'Isabelle, j'ajoute que je ne nomme que la zone c ontenant des données et non l'ensemble de la colonne
Christian

------------------------------------------------------------------------- -------

"Dominique" Re-bonjour,

Toujours sur le même tableau, un problème assez similaire : dans la
colonne A, j'ai des dates (01/01/2008...31/12/2008) et dans la colonne
H des types de réponses (Dossier, Fax, Téléphone, Courrier, etc.).
Cette fois, je voudrais compter le nombre de réponses sous forme de
dossier entre le 01/01/2008 et le 31/01/2008. Les deux colonnes sont
nommées Col_date et Col_forme_de_la_réponse. J'ai essayé d'adapter la
formule que Christian m'avait donnée précédemment, mais elle ne mar che
pas puisque j'ai deux réponses 'dossier' en janvier mais la formule me
renvoie une répose de zéro... Où est l'erreur ?

=SOMMEPROD((Col_date)<="31/1")*((Col_date)>="1/1")*((Col_forme_de_l a_réponse)="Dossier")

A moins que SommeProd ne soit pas la formule qui convient ?

Merci,
Dominique.



Publicité
Poster une réponse
Anonyme