Somme en fonction d'1 critère dans un tableau

Le
Yves
Bonjour à tous les contributeurs de MPFE.
Pouvez-vous m'aider pour faire une somme en fonction d'1 critère dans un
tableau?
(Sur Windows XP, Excel 2003)
Objectif: réduire la taille du fichier de x feuilles.
Soit une plage A1..AI60 divisée en 42 carrées (= des jours) identiques (de
A1..E10 à AE51..AI60)
Dans chaque carré, sur les lignes 2 à 9 de la première colonne, un choix de
tâches sur une liste déroulante et en regard, un nombre d'heures sur l'une ou
l'autre colonne (car taux différents)
Comment obtenir le total des heures pour chaque tâche dans l'ensemble de la
plageA1..AI60 plus facilement que dans l'option actuelle?
(Option actuelle: par tâche, dans une colonne à droite du tableau:
=somme((si(A2="tâche1";B2+C2+D2+E2;0));(si(F2="tâche1";G2+H2+I2+J2;0));etc
jusque siAE2…( 7ème carré en horizontal )et puis recopie de la formule sur
toutes les lignes pour avoir le total de la tâche1 en ligne61)

Merci d'avance pour votre aide.
Cordialement,
Yves. ylohest@yahoo.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4916431
Bonjour,

=SOMMEPROD((A2:A9="tache1")*B2:E9)+SOMMEPROD((F2:F9="tache1")*G2:J9)

JB

On 13 juin, 14:04, Yves
Bonjour à tous les contributeurs de MPFE.
Pouvez-vous m'aider pour faire une somme en fonction d'1 critère dans un
tableau?
(Sur Windows XP, Excel 2003)
Objectif: réduire la taille du fichier de x feuilles.
Soit une plage A1..AI60 divisée en 42 carrées (= des jours) identiq ues (de
A1..E10 à AE51..AI60)
Dans chaque carré, sur les lignes 2 à 9 de la première colonne, un choix de
tâches sur une liste déroulante et en regard, un nombre d'heures sur l'une ou
l'autre colonne (car taux différents)
Comment obtenir le total des heures pour chaque tâche dans l'ensemble d e la
plageA1..AI60 plus facilement que dans l'option actuelle?
(Option actuelle: par tâche, dans une colonne à droite du tableau:
=somme((si(A2="tâche1";B2+C2+D2+E2;0));(si(F2="tâche1";G2+H2+I2 +J2;0));...e­tc
jusque siAE2...( 7ème carré en horizontal )et puis recopie de la form ule sur
toutes les lignes pour avoir le total de la tâche1 en ligne61)

Merci d'avance pour votre aide.
Cordialement,
Yves.


Yves
Le #4916191
Merci JB, je m'essaye à cela.
A bientôt.
Yves.

"JB" wrote:

Bonjour,

=SOMMEPROD((A2:A9="tache1")*B2:E9)+SOMMEPROD((F2:F9="tache1")*G2:J9)

JB

On 13 juin, 14:04, Yves
Bonjour à tous les contributeurs de MPFE.
Pouvez-vous m'aider pour faire une somme en fonction d'1 critère dans un
tableau?
(Sur Windows XP, Excel 2003)
Objectif: réduire la taille du fichier de x feuilles.
Soit une plage A1..AI60 divisée en 42 carrées (= des jours) identiques (de
A1..E10 à AE51..AI60)
Dans chaque carré, sur les lignes 2 à 9 de la première colonne, un choix de
tâches sur une liste déroulante et en regard, un nombre d'heures sur l'une ou
l'autre colonne (car taux différents)
Comment obtenir le total des heures pour chaque tâche dans l'ensemble de la
plageA1..AI60 plus facilement que dans l'option actuelle?
(Option actuelle: par tâche, dans une colonne à droite du tableau:
=somme((si(A2="tâche1";B2+C2+D2+E2;0));(si(F2="tâche1";G2+H2+I2+J2;0));...e­tc
jusque siAE2...( 7ème carré en horizontal )et puis recopie de la formule sur
toutes les lignes pour avoir le total de la tâche1 en ligne61)

Merci d'avance pour votre aide.
Cordialement,
Yves.







Publicité
Poster une réponse
Anonyme