somme multi critère

Le
hello
Bonjour,

je suis en train de créer un tableur excel et j'ai quelques difficultés

je souhaiterai faire sur somme en fonction de plusieurs critères de mon
tableur. voici comment il se présente.

A B c D E
12 400 10/10/2006 10/10/2007
12 200 24/12/2006 24/12/2007
24 150 15/11/2004 15/11/2006
36 300 18/03/2005 18/03/2008
12 125 09/04/2006 09/04/2007
24 200 14/10/2006 14/10/2008

je voudrais faire : somme des valeurs de B selon les critères suivants (si A
= 12 on somme B pour les valeur de C correspondantes suivantes : mois de
C et année de C = 2006 sinon,(forcément F différent de 12) on fait la
somme de B mais pour les valeurs de D correspondantes suivantes : mois de D =
10 et année de D = 2006)

merci d'avance de l'attention que vous porterez à mon problème
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Corto
Le #5288501
Bonjour hello,
Je n'ai pas bien compris dans l'énoncé de ta question si tu vou lais deux
sommes différentes (A et A<> 12)
ou si tu voulais une seule somme. Dans le deuxième cas entre la form ule
suivante sinon mets les deux SOMMEPROD
dans des cellules différentes.
=SOMMEPROD((A5:A10)*(MOIS(C5:C10))*(ANNEE(C5:C10) 06)*B5: B10) +
SOMMEPROD((A5:A10<>12)*(MOIS(D5:D10))*(ANNEE(D5:D10) 06)*B5:B10)

Corto

Bonjour,

je suis en train de créer un tableur excel et j'ai quelques diffic ultés

je souhaiterai faire sur somme en fonction de plusieurs critères d e mon
tableur. voici comment il se présente.

A B c D E
12 400 10/10/2006 10/10/2007
12 200 24/12/2006 24/12/2007
24 150 15/11/2004 15/11/2006
36 300 18/03/2005 18/03/2008
12 125 09/04/2006 09/04/2007
24 200 14/10/2006 14/10/2008

je voudrais faire : somme des valeurs de B selon les critères suiv ants (si A
= 12 on somme B pour les valeur de C correspondantes suivantes : moi s de
C et année de C = 2006 sinon,(forcément F différe nt de 12) on fait la
somme de B mais pour les valeurs de D correspondantes suivantes : mois de D =
10 et année de D = 2006)

merci d'avance de l'attention que vous porterez à mon problèm e






JB
Le #5288491
Bonjour,


=SOMMEPROD((cola)*(MOIS(colc))*(ANNEE(colc) 06)*colb)
+SOMMEPROD((cola<>12)*(MOIS(cold))*(ANNEE(cold) 06)*colb)

JB

On 25 jan, 10:55, hello
Bonjour,

je suis en train de créer un tableur excel et j'ai quelques difficulté s

je souhaiterai faire sur somme en fonction de plusieurs critères de mon
tableur. voici comment il se présente.

 A        B            c                   D                    E
12     400     10/10/2006     10/10/2007  
12     200     24/12/2006     24/12/2007
24     150     15/11/2004     15/11/2006
36     300     18/03/2005     18/03/2008
12     125     09/04/2006     09/04/2007
24     200     14/10/2006     14/10/2008

je voudrais faire : somme des valeurs de B selon les critères suivants ( si A
= 12 on somme B  pour les valeur de C correspondantes suivantes : mois de
C et année de C = 2006 sinon,(forcément F différent de 12) on fait la
somme de B mais pour les valeurs de D correspondantes suivantes : mois de D =
10 et année de D = 2006)

merci d'avance de l'attention que vous porterez à mon problème


hello
Le #5288461
en fait je souhaite faire une somme '"(A + A>12)"


Bonjour hello,
Je n'ai pas bien compris dans l'énoncé de ta question si tu voulais deux
sommes différentes (A et A<> 12)
ou si tu voulais une seule somme. Dans le deuxième cas entre la formule
suivante sinon mets les deux SOMMEPROD
dans des cellules différentes.
=SOMMEPROD((A5:A10)*(MOIS(C5:C10))*(ANNEE(C5:C10) 06)*B5:B10) +
SOMMEPROD((A5:A10<>12)*(MOIS(D5:D10))*(ANNEE(D5:D10) 06)*B5:B10)

Corto

Bonjour,

je suis en train de créer un tableur excel et j'ai quelques difficultés

je souhaiterai faire sur somme en fonction de plusieurs critères de mon
tableur. voici comment il se présente.

A B c D E
12 400 10/10/2006 10/10/2007
12 200 24/12/2006 24/12/2007
24 150 15/11/2004 15/11/2006
36 300 18/03/2005 18/03/2008
12 125 09/04/2006 09/04/2007
24 200 14/10/2006 14/10/2008

je voudrais faire : somme des valeurs de B selon les critères suivants (si A
= 12 on somme B pour les valeur de C correspondantes suivantes : mois de
C et année de C = 2006 sinon,(forcément F différent de 12) on fait la
somme de B mais pour les valeurs de D correspondantes suivantes : mois de D =
10 et année de D = 2006)

merci d'avance de l'attention que vous porterez à mon problème









Corto
Le #5288441
Bonjour hello,
Alors c'est la bonne formule :-))

Corto

en fait je souhaite faire une somme '"(A + A>12)"



Bonjour hello,
Je n'ai pas bien compris dans l'énoncé de ta question si tu voulais deux
sommes différentes (A et A<> 12)
ou si tu voulais une seule somme. Dans le deuxième cas entre la f ormule
suivante sinon mets les deux SOMMEPROD
dans des cellules différentes.
=SOMMEPROD((A5:A10)*(MOIS(C5:C10))*(ANNEE(C5:C10) 06)* B5:B10) +
SOMMEPROD((A5:A10<>12)*(MOIS(D5:D10))*(ANNEE(D5:D10) 06)*B5:B 10)

Corto


Bonjour,

je suis en train de créer un tableur excel et j'ai quelques diff icultés

je souhaiterai faire sur somme en fonction de plusieurs critères de mon
tableur. voici comment il se présente.

A B c D E
12 400 10/10/2006 10/10/2007
12 200 24/12/2006 24/12/2007
24 150 15/11/2004 15/11/2006
36 300 18/03/2005 18/03/2008
12 125 09/04/2006 09/04/2007
24 200 14/10/2006 14/10/2008

je voudrais faire : somme des valeurs de B selon les critères su ivants (si A
= 12 on somme B pour les valeur de C correspondantes suivantes : m ois de
C et année de C = 2006 sinon,(forcément F diffé rent de 12) on fait la
somme de B mais pour les valeurs de D correspondantes suivantes : moi s de D =
10 et année de D = 2006)

merci d'avance de l'attention que vous porterez à mon problè me











Publicité
Poster une réponse
Anonyme