Somme par année

Le
syleg35
Bonjour à tous

Je n'arrive pas a trouvé une solution pour totaliser par année sans mod=
ifier la présentation de mon tableau

J'utilise cette formule mais le résultat est faux pour certaine année

=SOMMEPROD(((ANNEE($C$3:$C$79)=B83)*(MOIS($C$3:$C$79)=12)*$E$3:$E$79)=
)

Ci-joint exemple

http://cjoint.com/?3CAolSd7DS3


bonne journée a vous
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #26346130
Bonjour,

Le résultat de cette formule est correct
...le résultat est faux pour certaine année




Dans cette formule
=SOMMEPROD(((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79))*$E$3:$E$79))
On fait le total de l'année en B83 ET DU MOIS DE DECEMBRE

Pour ne tenir compte QUE de l'année
=SOMMEPROD(((ANNEE($C$3:$C$79)¸3)*$E$3:$E$79))


--
Salutations
JJ


Bonjour à tous

Je n'arrive pas a trouvé une solution pour totaliser par année sans modifier la présentation de mon tableau

J'utilise cette formule mais le résultat est faux pour certaine année

=SOMMEPROD(((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79))*$E$3:$E$79))

Ci-joint exemple

http://cjoint.com/?3CAolSd7DS3


bonne journée a vous
GL
Le #26346138
Le 26/03/2015 13:59, a écrit :
Bonjour à tous

Je n'arrive pas a trouvé une solution pour totaliser par année sans modifier la présentation de mon tableau

J'utilise cette formule mais le résultat est faux pour certaine année

=SOMMEPROD(((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79))*$E$3:$E$79))



Vous avez un problème de parenthèses. De plus, même si SOMMEPROD accepte
un seul argument, il est plus logique d'en donner deux, ainsi :

soit:
=SOMMEPROD((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79));$E$3:$E$79)

soit
=SOMMEPROD((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79))*($E$3:$E$79))

---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Jacky
Le #26346137
Re
On peut se passer d'une parenthèse
=SOMMEPROD((ANNEE($C$3:$C$79)¸3)*$E$3:$E$79)

--
Salutations
JJ
GL
Le #26346146
Le 26/03/2015 14:19, GL a écrit :
Le 26/03/2015 13:59, a écrit :
Bonjour à tous

Je n'arrive pas a trouvé une solution pour totaliser par année sans
modifier la présentation de mon tableau

J'utilise cette formule mais le résultat est faux pour certaine année

=SOMMEPROD(((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79))*$E$3:$E$79))



Vous avez un problème de parenthèses. De plus, même si SOMMEPROD accepte
un seul argument, il est plus logique d'en donner deux, ainsi :

soit:
=SOMMEPROD((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79));$E$3:$E$79)

soit
=SOMMEPROD((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79))*($E$3:$E$79))

---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com



C'est pénible ce bandeau Avast, désolé pour le test...

---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
GL
Le #26346145
Le 26/03/2015 14:32, GL a écrit :
---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com



C'est pénible ce bandeau Avast, désolé pour le test...

---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com




Visiblement le test n'est pas concluant, je recommence...
GL
Le #26346144
Le 26/03/2015 14:32, GL a écrit :
Le 26/03/2015 14:32, GL a écrit :
---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com



C'est pénible ce bandeau Avast, désolé pour le test...

---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com




Visiblement le test n'est pas concluant, je recommence...


C'est OK maintenant... ouf !
syleg35
Le #26346143
Merci à vous

vous m'avez apporter la solution dans vos réponse

Bonne journée à vous



Le jeudi 26 mars 2015 14:00:00 UTC+1, a écrit :
Bonjour à tous

Je n'arrive pas a trouvé une solution pour totaliser par année sans m odifier la présentation de mon tableau

J'utilise cette formule mais le résultat est faux pour certaine année

=SOMMEPROD(((ANNEE($C$3:$C$79)¸3)*(MOIS($C$3:$C$79))*$E$3:$E$7 9))

Ci-joint exemple

http://cjoint.com/?3CAolSd7DS3


bonne journée a vous
Publicité
Poster une réponse
Anonyme