somme par semaine

Le
cousinhub
bonsoir, (ça fait du bien de revenir)
Dans ma semaine de 5 jours, est-il possible d'avoir le nombre
d'interventions, quelque soit le jour choisi (de la semaine)
un petit fichier exemple :

> http://cjoint.com/?ihwVR3HQsy

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #4809281
Bonsour® cousinhub avec ferveur ;o))) vous nous disiez :

Dans ma semaine de 5 jours, est-il possible d'avoir le nombre
d'interventions, quelque soit le jour choisi (de la semaine)


1ere étape
il faut préalablement connaitre les n° de semaines ;o)))
la fonction NO.SEMAINE permet cette identification
mais il faut activer les macrocomplmentaires : utilitaires d'analyse VBA
ou bien utiliser une formule pour calculer le N° de semaine
http://excelabo.net/excel/semaines.php#numerosemaine

par exemple en colonne E2
saisir la formule : = NO.SEMAINE(A2)
recopier vers le bas autant que nécesssaire

2éme Etape :
utiliser la fonctionSOMMEPROD
= SOMMEPROD($C$2:$C$100*($E$2:$E$100=NOdelasemainechoisie)

Nb:
la fonction NO.SEMAINE est une fonction qui n'est pas à la norme ISO
les semaines 1 et 53 peuvent etre partielles
préferer la semaine à la norme ISO (voir le lien indiqué)

@+
;o)))

cousinhub
Le #4809271
Bonsoir,
et merci,
j'avais pensé à cette option, mais ne voulant pas rajouter de colonne
dans ma BD, je l'avais superbement ignorée....>:o
Pour ce qui est de la norme ISO (Ils Sont Oufs), peu importe, le but est
de rester dans la semaine...
Je commençais à réfléchir vers JOURSEM and co, mais pas évident de
trouver les jours adjacents (donc les lignes du dessus ou du dessous qui
pourraient correspondre...)
Le principe auquel je pensais, étant établi que Joursem(05/08/07), donc
un dimanche, est égal à 1, on ne peut établir une somme que dans une
fourchette, intégrant à la fois le différence entre le nombre de jours
et la différence entre "joursem"
Merci quand même, et bonne nuit

Bonsour® cousinhub avec ferveur ;o))) vous nous disiez :

Dans ma semaine de 5 jours, est-il possible d'avoir le nombre
d'interventions, quelque soit le jour choisi (de la semaine)


1ere étape
il faut préalablement connaitre les n° de semaines ;o)))
la fonction NO.SEMAINE permet cette identification
mais il faut activer les macrocomplmentaires : utilitaires d'analyse VBA
ou bien utiliser une formule pour calculer le N° de semaine
http://excelabo.net/excel/semaines.php#numerosemaine

par exemple en colonne E2
saisir la formule : = NO.SEMAINE(A2)
recopier vers le bas autant que nécesssaire

2éme Etape :
utiliser la fonctionSOMMEPROD
= SOMMEPROD($C$2:$C$100*($E$2:$E$100=NOdelasemainechoisie)

Nb:
la fonction NO.SEMAINE est une fonction qui n'est pas à la norme ISO
les semaines 1 et 53 peuvent etre partielles
préferer la semaine à la norme ISO (voir le lien indiqué)

@+
;o)))





dre
Le #4808971
Bonjour,

Avec JOURSEM et sans colonne supplémentaire
=SOMMEPROD((B$2:B$20>$F$2-JOURSEM($F$2)+1)*(B$2:B$20<$F$2-JOURSEM($F$2)+8)*C$2:C$20)

dré




Bonsoir,
et merci,
j'avais pensé à cette option, mais ne voulant pas rajouter de colonne
dans ma BD, je l'avais superbement ignorée....>:o
Pour ce qui est de la norme ISO (Ils Sont Oufs), peu importe, le but est
de rester dans la semaine...
Je commençais à réfléchir vers JOURSEM and co, mais pas évident de
trouver les jours adjacents (donc les lignes du dessus ou du dessous qui
pourraient correspondre...)
Le principe auquel je pensais, étant établi que Joursem(05/08/07), donc
un dimanche, est égal à 1, on ne peut établir une somme que dans une
fourchette, intégrant à la fois le différence entre le nombre de jours
et la différence entre "joursem"
Merci quand même, et bonne nuit

Bonsour® cousinhub avec ferveur ;o))) vous nous disiez :

Dans ma semaine de 5 jours, est-il possible d'avoir le nombre
d'interventions, quelque soit le jour choisi (de la semaine)


1ere étape
il faut préalablement connaitre les n° de semaines ;o)))
la fonction NO.SEMAINE permet cette identification
mais il faut activer les macrocomplmentaires : utilitaires d'analyse VBA
ou bien utiliser une formule pour calculer le N° de semaine
http://excelabo.net/excel/semaines.php#numerosemaine

par exemple en colonne E2
saisir la formule : = NO.SEMAINE(A2)
recopier vers le bas autant que nécesssaire

2éme Etape :
utiliser la fonctionSOMMEPROD
= SOMMEPROD($C$2:$C$100*($E$2:$E$100=NOdelasemainechoisie)

Nb:
la fonction NO.SEMAINE est une fonction qui n'est pas à la norme ISO
les semaines 1 et 53 peuvent etre partielles
préferer la semaine à la norme ISO (voir le lien indiqué)

@+
;o)))








cousinhub
Le #4654701
Merci, c'est parfait

Bonjour,

Avec JOURSEM et sans colonne supplémentaire :
=SOMMEPROD((B$2:B$20>$F$2-JOURSEM($F$2)+1)*(B$2:B$20<$F$2-JOURSEM($F$2)+8)*C$2:C$20)

dré




Bonsoir,
et merci,
j'avais pensé à cette option, mais ne voulant pas rajouter de colonne
dans ma BD, je l'avais superbement ignorée....>:o
Pour ce qui est de la norme ISO (Ils Sont Oufs), peu importe, le but est
de rester dans la semaine...
Je commençais à réfléchir vers JOURSEM and co, mais pas évident de
trouver les jours adjacents (donc les lignes du dessus ou du dessous qui
pourraient correspondre...)
Le principe auquel je pensais, étant établi que Joursem(05/08/07), donc
un dimanche, est égal à 1, on ne peut établir une somme que dans une
fourchette, intégrant à la fois le différence entre le nombre de jours
et la différence entre "joursem"
Merci quand même, et bonne nuit

Bonsour® cousinhub avec ferveur ;o))) vous nous disiez :

Dans ma semaine de 5 jours, est-il possible d'avoir le nombre
d'interventions, quelque soit le jour choisi (de la semaine)
1ere étape

il faut préalablement connaitre les n° de semaines ;o)))
la fonction NO.SEMAINE permet cette identification
mais il faut activer les macrocomplmentaires : utilitaires d'analyse VBA
ou bien utiliser une formule pour calculer le N° de semaine
http://excelabo.net/excel/semaines.php#numerosemaine

par exemple en colonne E2
saisir la formule : = NO.SEMAINE(A2)
recopier vers le bas autant que nécesssaire

2éme Etape :
utiliser la fonctionSOMMEPROD
= SOMMEPROD($C$2:$C$100*($E$2:$E$100=NOdelasemainechoisie)

Nb:
la fonction NO.SEMAINE est une fonction qui n'est pas à la norme ISO
les semaines 1 et 53 peuvent etre partielles
préferer la semaine à la norme ISO (voir le lien indiqué)

@+
;o)))









Publicité
Poster une réponse
Anonyme