Somme particulière...

Le
Bastan
Bonjour,

Je souhaiterais, dans une ligne, faire la somme de certaines cellules,
non contigües, et ne faire la somme QUE si le contenu de ces cellules
est négatif (certaines peuvent être positives ou nulles).

J'ai bien trouvé la fonction "Somme.Si" qui le fait bien, mais elle ne
s'adresse qu'à une plage de cellules et non à des cellules séparées.

J'ai bien réussi en VBA, mais je préfèrerais pour des raisons pratiques
utiliser la barre de formules.

Je suis sûr que ce n'est pas compliqué, mais bon je cale..

Merci d'avance pour votre aide ;-)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #21480831
Bonsoir,

Pour B1,D1,F1,H1
=SOMME((B1<0)*B1;(D1<0)*D1;(F1<0)*F1;(H1<0)*H1)

--
Salutations
JJ


"Bastan"
Bonjour,

Je souhaiterais, dans une ligne, faire la somme de certaines cellules, non contigües, et ne faire la somme
QUE si le contenu de ces cellules est négatif (certaines peuvent être positives ou nulles).

J'ai bien trouvé la fonction "Somme.Si" qui le fait bien, mais elle ne s'adresse qu'à une plage de cellules
et non à des cellules séparées.

J'ai bien réussi en VBA, mais je préfèrerais pour des raisons pratiques utiliser la barre de formules.

Je suis sûr que ce n'est pas compliqué, mais bon... je cale..

Merci d'avance pour votre aide ;-)


Bastan
Le #21482932
Impeccable ! Merci beaucoup !

Jacky a émis l'idée suivante :
Bonsoir,

Pour B1,D1,F1,H1
=SOMME((B1<0)*B1;(D1<0)*D1;(F1<0)*F1;(H1<0)*H1)

--
Salutations
JJ


"Bastan" 4bb5139b$0$3707$
Bonjour,

Je souhaiterais, dans une ligne, faire la somme de certaines cellules, non
contigües, et ne faire la somme QUE si le contenu de ces cellules est
négatif (certaines peuvent être positives ou nulles).

J'ai bien trouvé la fonction "Somme.Si" qui le fait bien, mais elle ne
s'adresse qu'à une plage de cellules et non à des cellules séparées.

J'ai bien réussi en VBA, mais je préfèrerais pour des raisons pratiques
utiliser la barre de formules.

Je suis sûr que ce n'est pas compliqué, mais bon... je cale..

Merci d'avance pour votre aide ;-)


Sam
Le #21485362
Bonjour, il y avait aussi
=MIN(0;B1)+MIN(0;D1)+MIN(0;F1)+MIN(0;H1)
Cordialement
Michel dit "Sam"

"Jacky"
Bonsoir,

Pour B1,D1,F1,H1
=SOMME((B1<0)*B1;(D1<0)*D1;(F1<0)*F1;(H1<0)*H1)

--
Salutations
JJ


"Bastan" 4bb5139b$0$3707$
Bonjour,

Je souhaiterais, dans une ligne, faire la somme de certaines cellules,
non contigües, et ne faire la somme QUE si le contenu de ces cellules est
négatif (certaines peuvent être positives ou nulles).

J'ai bien trouvé la fonction "Somme.Si" qui le fait bien, mais elle ne
s'adresse qu'à une plage de cellules et non à des cellules séparées.

J'ai bien réussi en VBA, mais je préfèrerais pour des raisons pratiques
utiliser la barre de formules.

Je suis sûr que ce n'est pas compliqué, mais bon... je cale..

Merci d'avance pour votre aide ;-)






Bastan
Le #21486812
Ca marche aussi. Merci !

Sam a émis l'idée suivante :
Bonjour, il y avait aussi
=MIN(0;B1)+MIN(0;D1)+MIN(0;F1)+MIN(0;H1)
Cordialement
Michel dit "Sam"

"Jacky"
Bonsoir,

Pour B1,D1,F1,H1
=SOMME((B1<0)*B1;(D1<0)*D1;(F1<0)*F1;(H1<0)*H1)

-- Salutations
JJ


"Bastan" 4bb5139b$0$3707$
Bonjour,

Je souhaiterais, dans une ligne, faire la somme de certaines cellules, non
contigües, et ne faire la somme QUE si le contenu de ces cellules est
négatif (certaines peuvent être positives ou nulles).

J'ai bien trouvé la fonction "Somme.Si" qui le fait bien, mais elle ne
s'adresse qu'à une plage de cellules et non à des cellules séparées.

J'ai bien réussi en VBA, mais je préfèrerais pour des raisons pratiques
utiliser la barre de formules.

Je suis sûr que ce n'est pas compliqué, mais bon... je cale..

Merci d'avance pour votre aide ;-)






Publicité
Poster une réponse
Anonyme