Somme de plage avec critère = mois

Le
JeanPi37
Bonjour à tous,

Je bute sur un problème sans trouver de solution.
J'ai une colonne qui contient des dates de janvier à décembre.
Je souhaiterais en bas de tableau faire un récapitulatif par mois.
Exemple :
somme de plage de valeurs si mois de plage de dates = 1 (ou janvier), puis
somme de plage de valeurs si mois de plage de dates = 2 (ou février), puis
somme de plage de valeurs si mois de plage de dates = 3 (ou mars), etc.

Mes essais avec somme.si ne sont pas concluants et je suppose qu'on peut
faire simple.

Merci d'avance.

JeanPi
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #18825971
bonjour JeanPi ,

=SOMMEPROD((MOIS($A$1:$A$10)=1)*$B$1:$B$10)
=SOMMEPROD((MOIS($A$1:$A$10)=2)*$B$1:$B$10)
=SOMMEPROD((MOIS($A$1:$A$10)=3)*$B$1:$B$10)

isabelle

JeanPi37 a écrit :
Bonjour à tous,

Je bute sur un problème sans trouver de solution.
J'ai une colonne qui contient des dates de janvier à décembre.
Je souhaiterais en bas de tableau faire un récapitulatif par mois.
Exemple :
somme de plage de valeurs si mois de plage de dates = 1 (ou janvier),
puis
somme de plage de valeurs si mois de plage de dates = 2 (ou février),
puis
somme de plage de valeurs si mois de plage de dates = 3 (ou mars), etc.

Mes essais avec somme.si ne sont pas concluants et je suppose qu'on
peut faire simple.

Merci d'avance.

JeanPi




JeanPi37
Le #18833841
Super,
Merci Isabelle
JeanPi


"isabelle" a écrit dans le message de groupe de discussion :

bonjour JeanPi ,

=SOMMEPROD((MOIS($A$1:$A$10)=1)*$B$1:$B$10)
=SOMMEPROD((MOIS($A$1:$A$10)=2)*$B$1:$B$10)
=SOMMEPROD((MOIS($A$1:$A$10)=3)*$B$1:$B$10)

isabelle

JeanPi37 a écrit :
Bonjour à tous,

Je bute sur un problème sans trouver de solution.
J'ai une colonne qui contient des dates de janvier à décembre.
Je souhaiterais en bas de tableau faire un récapitulatif par mois.
Exemple :
somme de plage de valeurs si mois de plage de dates = 1 (ou janvier),
puis
somme de plage de valeurs si mois de plage de dates = 2 (ou février),
puis
somme de plage de valeurs si mois de plage de dates = 3 (ou mars), etc.

Mes essais avec somme.si ne sont pas concluants et je suppose qu'on peut
faire simple.

Merci d'avance.

JeanPi






Publicité
Poster une réponse
Anonyme