somme sans doublon

Le
Merguez07
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #18352741
Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci


michdenis
Le #18352731
Si tu n'as pas de cellules vides dans ta colonne :

Plg est une plage nommée
=SOMMEPROD((Plg<>"")/(NB.SI(Plg;Plg)))

Avec des cellules vides dans ta colonne :
=SOMMEPROD((Plg<>"")/(NB.SI(Plg;Plg)+(Plg="")))

Avec des cellules vides dans ta colonne :
Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTVIDE(Plg);"";1/NB.SI(Plg;Plg)))



"Merguez07" 49688620$0$18738$
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci
Modeste
Le #18352811
Bonsour® Merguez07
Bonne année !!! Meilleurs voeux à tous !!!

dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3



formule matricielle :
=SOMME(1/NB.SI(plage;plage))
validation par Ctrl+Maj+Entrée

ce qui apparaitra dans la barre de formule
{={SOMME(1/NB.SI(plage;plage))}
Merguez07
Le #18353031
Merci JB, mais j'avais pris les prénoms pour simplifier l'énoncé du Pb mais
en fait c'est des phrases qu'il y a dans les cellules et parfois ça marche
pas

par exemple ma cellule A2 contient une phrase assez longue :
"RHSSQ 05 : SEC003PO : suite à graissage, stabilité thermique non acquise au
moment de l'arrêt de la pompe.La pompe a été arrêtée sur avis métier alors
que l'OP avait constaté la non stabilité.Suite à la demande de l'IS, la
pompe a été redémarrée pour contrôle des caractéristiques thermiques qui se
sont finalement avérées conformes après stabilisation."

La formule NB.SI(A2;A2) me donne 0 au lieu du 1 attendu. Mystère



"JB" discussion :

Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci





michdenis
Le #18353481
Sous une version Excel autre que Excel 2007, la longueur de la chaine
que tu peux utiliser dans la formule de la cellule A2 est 255 caractères.

Ton texte est substantiellement plus grand !


"Merguez07" 49689737$0$20356$
Merci JB, mais j'avais pris les prénoms pour simplifier l'énoncé du Pb mais
en fait c'est des phrases qu'il y a dans les cellules et parfois ça marche
pas

par exemple ma cellule A2 contient une phrase assez longue :
"RHSSQ 05 : SEC003PO : suite à graissage, stabilité thermique non acquise au
moment de l'arrêt de la pompe.La pompe a été arrêtée sur avis métier alors
que l'OP avait constaté la non stabilité.Suite à la demande de l'IS, la
pompe a été redémarrée pour contrôle des caractéristiques thermiques qui se
sont finalement avérées conformes après stabilisation."

La formule NB.SI(A2;A2) me donne 0 au lieu du 1 attendu. Mystère



"JB" discussion :

Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci





Merguez07
Le #18353671
Cela veut il dire qu'il n'y pas de solution pour éliminer un doublon sur une
cellule contenant plus de 255 caractères ?

"michdenis" discussion :
Sous une version Excel autre que Excel 2007, la longueur de la chaine
que tu peux utiliser dans la formule de la cellule A2 est 255 caractères.

Ton texte est substantiellement plus grand !


"Merguez07" 49689737$0$20356$
Merci JB, mais j'avais pris les prénoms pour simplifier l'énoncé du Pb
mais
en fait c'est des phrases qu'il y a dans les cellules et parfois ça marche
pas

par exemple ma cellule A2 contient une phrase assez longue :
"RHSSQ 05 : SEC003PO : suite à graissage, stabilité thermique non acquise
au
moment de l'arrêt de la pompe.La pompe a été arrêtée sur avis métier alors
que l'OP avait constaté la non stabilité.Suite à la demande de l'IS, la
pompe a été redémarrée pour contrôle des caractéristiques thermiques qui
se
sont finalement avérées conformes après stabilisation."

La formule NB.SI(A2;A2) me donne 0 au lieu du 1 attendu. Mystère



"JB" discussion :

Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci








Merguez07
Le #18353661
Cela veut il dire qu'il n'y a pas de solution pour éliminer un doublon d'une
cellule contenant plus de 255 caractères?

"michdenis" discussion :
Sous une version Excel autre que Excel 2007, la longueur de la chaine
que tu peux utiliser dans la formule de la cellule A2 est 255 caractères.

Ton texte est substantiellement plus grand !


"Merguez07" 49689737$0$20356$
Merci JB, mais j'avais pris les prénoms pour simplifier l'énoncé du Pb
mais
en fait c'est des phrases qu'il y a dans les cellules et parfois ça marche
pas

par exemple ma cellule A2 contient une phrase assez longue :
"RHSSQ 05 : SEC003PO : suite à graissage, stabilité thermique non acquise
au
moment de l'arrêt de la pompe.La pompe a été arrêtée sur avis métier alors
que l'OP avait constaté la non stabilité.Suite à la demande de l'IS, la
pompe a été redémarrée pour contrôle des caractéristiques thermiques qui
se
sont finalement avérées conformes après stabilisation."

La formule NB.SI(A2;A2) me donne 0 au lieu du 1 attendu. Mystère



"JB" discussion :

Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci








michdenis
Le #18353991
Une solution simple est d'utiliser le filtre élaboré
tu sélectionnes ta colonnes
Appel de la commande : Données / filtre / filtre élaboré
Tu n'as pas besoin de définir un critère
dans le bas de la fenêtre, tu coches la case "sans doublons"

Tu obtiendras seulement les lignes qui n'ont pas de doublons
dans la plage de cellule.

Sur cette plage filtrée, regarde la fonction "Sous.Total" et tu pourras
obtenir le nombre de lignes affichées dans l'étendue de la plage.




"Merguez07" 4968a6cd$0$28144$
Cela veut il dire qu'il n'y a pas de solution pour éliminer un doublon d'une
cellule contenant plus de 255 caractères?

"michdenis" discussion :
Sous une version Excel autre que Excel 2007, la longueur de la chaine
que tu peux utiliser dans la formule de la cellule A2 est 255 caractères.

Ton texte est substantiellement plus grand !


"Merguez07" 49689737$0$20356$
Merci JB, mais j'avais pris les prénoms pour simplifier l'énoncé du Pb
mais
en fait c'est des phrases qu'il y a dans les cellules et parfois ça marche
pas

par exemple ma cellule A2 contient une phrase assez longue :
"RHSSQ 05 : SEC003PO : suite à graissage, stabilité thermique non acquise
au
moment de l'arrêt de la pompe.La pompe a été arrêtée sur avis métier alors
que l'OP avait constaté la non stabilité.Suite à la demande de l'IS, la
pompe a été redémarrée pour contrôle des caractéristiques thermiques qui
se
sont finalement avérées conformes après stabilisation."

La formule NB.SI(A2;A2) me donne 0 au lieu du 1 attendu. Mystère



"JB" discussion :

Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci








CodeKiller
Le #18354111
Bonjour à tous,

Quel est le fonctionnement de la formule : SOMMEPROD ???
J'ai testé chez moi ça me met l'erreur "division par 0". Et la partie
"NB.SI" me renvoie 0.

J'ai fait le test tout bête avec les cellules contenant : 0, 1 ,1 , 2 ,0 ,3

Bonne journée.

"Merguez07" news:4968a682$0$15325$
Cela veut il dire qu'il n'y pas de solution pour éliminer un doublon sur
une cellule contenant plus de 255 caractères ?

"michdenis" discussion :
Sous une version Excel autre que Excel 2007, la longueur de la chaine
que tu peux utiliser dans la formule de la cellule A2 est 255 caractères.

Ton texte est substantiellement plus grand !


"Merguez07" 49689737$0$20356$
Merci JB, mais j'avais pris les prénoms pour simplifier l'énoncé du Pb
mais
en fait c'est des phrases qu'il y a dans les cellules et parfois ça
marche
pas

par exemple ma cellule A2 contient une phrase assez longue :
"RHSSQ 05 : SEC003PO : suite à graissage, stabilité thermique non acquise
au
moment de l'arrêt de la pompe.La pompe a été arrêtée sur avis métier
alors
que l'OP avait constaté la non stabilité.Suite à la demande de l'IS, la
pompe a été redémarrée pour contrôle des caractéristiques thermiques qui
se
sont finalement avérées conformes après stabilisation."

La formule NB.SI(A2;A2) me donne 0 au lieu du 1 attendu. Mystère



"JB" discussion :

Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci










michdenis
Le #18354101
tu as probablement utilisé cette formule avec
des cellules vides dans la plage de cellules

=SOMMEPROD(1/(NB.SI(A1:A5;A1:A5)))

Tu as d'autres alternatives que j'ai données sur un
autre message de ce fil.



"CodeKiller"
Bonjour à tous,

Quel est le fonctionnement de la formule : SOMMEPROD ???
J'ai testé chez moi ça me met l'erreur "division par 0". Et la partie
"NB.SI" me renvoie 0.

J'ai fait le test tout bête avec les cellules contenant : 0, 1 ,1 , 2 ,0 ,3

Bonne journée.

"Merguez07" news:4968a682$0$15325$
Cela veut il dire qu'il n'y pas de solution pour éliminer un doublon sur
une cellule contenant plus de 255 caractères ?

"michdenis" discussion :
Sous une version Excel autre que Excel 2007, la longueur de la chaine
que tu peux utiliser dans la formule de la cellule A2 est 255 caractères.

Ton texte est substantiellement plus grand !


"Merguez07" 49689737$0$20356$
Merci JB, mais j'avais pris les prénoms pour simplifier l'énoncé du Pb
mais
en fait c'est des phrases qu'il y a dans les cellules et parfois ça
marche
pas

par exemple ma cellule A2 contient une phrase assez longue :
"RHSSQ 05 : SEC003PO : suite à graissage, stabilité thermique non acquise
au
moment de l'arrêt de la pompe.La pompe a été arrêtée sur avis métier
alors
que l'OP avait constaté la non stabilité.Suite à la demande de l'IS, la
pompe a été redémarrée pour contrôle des caractéristiques thermiques qui
se
sont finalement avérées conformes après stabilisation."

La formule NB.SI(A2;A2) me donne 0 au lieu du 1 attendu. Mystère



"JB" discussion :

Bonjour,

=SOMMEPROD(1/NB.SI(A2:A10;A2:A10))

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB

On 10 jan, 12:27, "Merguez07"
Bonjour à tous,
dans ma colonne j'ai une liste de prénom
je veux connaitre le total des prénoms différents
Ainsi si j'ai :
Xavier
René
André
Xavier
Je dois avoir un total de 3

Comment faire ?

merci










Publicité
Poster une réponse
Anonyme