Somme selon 2 variables

Le
ceiba Hors ligne
Bonjour,

Je me permets de poser ma question après plusieurs heures de recherche sur différents forums dont celui-ci.

Mon problème est le suivant :

Je désire compter le nombre de cellules contenant le caractère "V" sur une ligne importante si et seulement si la cellule d'une autre ligne située sur la même colonne contient "dim".

J'y arrive parfaitement en utilisant la formule suivante : = SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(Annuel!$B5:$NT5="V"))
Dans laquelle "Annuel!$B2:$NT2" est la ligne contenant les jours de la semaine et "Annuel!$B5:$NT5" est la ligne contenant ou non le caractère "V".

Là je bute, c'est que dans la ligne "Annuel!$B5:$NT5", les cellules peuvent contenir indifférement "VD", "NV", "V", " V ", " V", ect. et je doit faire en sorte que ma formule compte les cellule contenant le caractère "V" qu'il soit seul ou associé à d'autres caractères ou espaces.

Merci d'avance pour votre aide

David
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23271231
Bonjour,
Regarde le post d'isabelle du 07/04/2011 19:25:23 dans le fil intitulé :
Modification formule "chaîne de caractères".
Cordialement.
Daniel


Bonjour,

Je me permets de poser ma question après plusieurs heures de recherche sur
différents forums dont celui-ci.

Mon problème est le suivant :

Je désire compter le nombre de cellules contenant le caractère "V" sur une
ligne importante si et seulement si la cellule d'une autre ligne située sur
la même colonne contient "dim".

J'y arrive parfaitement en utilisant la formule suivante : > SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(Annuel!$B5:$NT5="V"))
Dans laquelle "Annuel!$B2:$NT2" est la ligne contenant les jours de la
semaine et "Annuel!$B5:$NT5" est la ligne contenant ou non le caractère "V".

Là je bute, c'est que dans la ligne "Annuel!$B5:$NT5", les cellules peuvent
contenir indifférement "VD", "NV", "V", " V ", " V", ect. ... et je doit
faire en sorte que ma formule compte les cellule contenant le caractère "V"
qu'il soit seul ou associé à d'autres caractères ou espaces.

Merci d'avance pour votre aide

David
isabelle
Le #23271221
bonjour David,

=SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")+(NON(ESTERREUR(TROUVE("V";Annuel!$B5:$NT5)))))

isabelle
------------------------------------------------------------------

Le 2011-04-09 10:47, ceiba a écrit :
Bonjour,

Je me permets de poser ma question après plusieurs heures de recherche sur
différents forums dont celui-ci.

Mon problème est le suivant :

Je désire compter le nombre de cellules contenant le caractère "V" sur une
ligne importante si et seulement si la cellule d'une autre ligne située sur la
même colonne contient "dim".

J'y arrive parfaitement en utilisant la formule suivante : > SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(Annuel!$B5:$NT5="V"))
Dans laquelle "Annuel!$B2:$NT2" est la ligne contenant les jours de la semaine
et "Annuel!$B5:$NT5" est la ligne contenant ou non le caractère "V".

Là je bute, c'est que dans la ligne "Annuel!$B5:$NT5", les cellules peuvent
contenir indifférement "VD", "NV", "V", " V ", " V", ect. ... et je doit
faire en sorte que ma formule compte les cellule contenant le caractère "V"
qu'il soit seul ou associé à d'autres caractères ou espaces.

Merci d'avance pour votre aide

David

MichD
Le #23271261
Bonjour,

Celle ci n'est pas sensible à la casse
=SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(NON(ESTERREUR(CHERCHE("v";Annuel!$B5:$NT5="V")))))

Celle-ci est sensible à la casse :
=SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(NON(ESTERREUR(Trouve("v";Annuel!$B5:$NT5="V")))))



MichD
--------------------------------------------
"ceiba" a écrit dans le message de groupe de discussion :

Bonjour,

Je me permets de poser ma question après plusieurs heures de recherche sur
différents forums dont celui-ci.

Mon problème est le suivant :

Je désire compter le nombre de cellules contenant le caractère "V" sur une
ligne importante si et seulement si la cellule d'une autre ligne située sur la
même colonne contient "dim".

J'y arrive parfaitement en utilisant la formule suivante : SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(Annuel!$B5:$NT5="V"))
Dans laquelle "Annuel!$B2:$NT2" est la ligne contenant les jours de la semaine
et "Annuel!$B5:$NT5" est la ligne contenant ou non le caractère "V".

Là je bute, c'est que dans la ligne "Annuel!$B5:$NT5", les cellules peuvent
contenir indifférement "VD", "NV", "V", " V ", " V", ect. ... et je doit
faire en sorte que ma formule compte les cellule contenant le caractère "V"
qu'il soit seul ou associé à d'autres caractères ou espaces.

Merci d'avance pour votre aide

David
ceiba Hors ligne
Le #23271561
MichD a écrit le 09/04/2011 à 17h36 :
Bonjour,

Celle ci n'est pas sensible à la casse
=SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(NON(ESTERREUR(CHERCHE("v";Annuel!$B5:$NT5="V")))))

Celle-ci est sensible à la casse :
=SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(NON(ESTERREUR(Trouve("v";Annuel!$B5:$NT5="V")))))



MichD
--------------------------------------------
"ceiba" a écrit dans le message de groupe de discussion :


Bonjour,

Je me permets de poser ma question après plusieurs heures de recherche
sur
différents forums dont celui-ci.

Mon problème est le suivant :

Je désire compter le nombre de cellules contenant le caractère
"V" sur une
ligne importante si et seulement si la cellule d'une autre ligne située
sur la
même colonne contient "dim".

J'y arrive parfaitement en utilisant la formule suivante :
SOMMEPROD((GAUCHE(Annuel!$B2:$NT2;3)="dim")*(Annuel!$B5:$NT5="V"))
Dans laquelle "Annuel!$B2:$NT2" est la ligne contenant les jours de
la semaine
et "Annuel!$B5:$NT5" est la ligne contenant ou non le
caractère "V".

Là je bute, c'est que dans la ligne "Annuel!$B5:$NT5", les
cellules peuvent
contenir indifférement "VD", "NV", "V",
" V ", " V", ect. ... et je doit
faire en sorte que ma formule compte les cellule contenant le caractère
"V"
qu'il soit seul ou associé à d'autres caractères ou
espaces.

Merci d'avance pour votre aide

David


Bonsoir,

Merci beaucoup pour votre (très) grande réactivité; les formules fonctionnent parfaitement et m'ont en plus permis d'alléger ma feuille à d'autres endroits.

Par contre, je n'ai pas bien réussi à comprendre le cheminement logique de "NON(ESTERREUR(CHERCHE" et "NON(ESTERREUR(TROUVE"; serait-il possible de me l'expliquer ? (Pour améliorer ma compréhension d'excel et éviter de ne faire que recopier bêtement)

Merci encore

Bonne soirée
Publicité
Poster une réponse
Anonyme