Somme d'une série dans une colonne jusqu'à une cellule vide

Le
vertblancrouge
Bonjour

Dans ma colonne B, il y a différentes séries de montants séparées par des
cellules vides. Je désire calculer la somme de chacune de ces séries de
montants et les inscrires dans la colonne suivante.

Exemple pratique:
Dans ma feuille excel, j'écris en A3 le titre de ma somme.
De B4 à B9, il y a les montants.
Je désire avoir en C3, la somme de B4 à B9, soit de B4 jusqu'à la prochaine
cellule vide, car en A11, il y a un autre titre de somme (pour B12 à B20 ex.)
et ainsi de suite.

Dans une série de montant, il peut y avoir plusieurs nombres comme il peut y
en avoir un seul.

C'est pas la peine de commenter sur la structure de la feuille, je suis pris
avec ca () pour le moment et j'aimerais bien automatiser le calcul des
sommes.

Merci de m'aider.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4393751
bonjour vertblancrouge,

copie cette formule en C3
matrielle à valider avec Ctrl+Maj+Enter

=SOMME(INDIRECT("B"&LIGNE()&":B"&MIN(SI(NON(ESTVIDE(A4:A500));LIGNE(A4:A500)))-1))

tu pourras ensuite la recopier en colonne C vis à vis chaque titre de la colonne A

isabelle


Bonjour

Dans ma colonne B, il y a différentes séries de montants séparées par des
cellules vides. Je désire calculer la somme de chacune de ces séries de
montants et les inscrires dans la colonne suivante.

Exemple pratique:
Dans ma feuille excel, j'écris en A3 le titre de ma somme.
De B4 à B9, il y a les montants.
Je désire avoir en C3, la somme de B4 à B9, soit de B4 jusqu'à la prochaine
cellule vide, car en A11, il y a un autre titre de somme (pour B12 à B20 ex.)
et ainsi de suite.

Dans une série de montant, il peut y avoir plusieurs nombres comme il peut y
en avoir un seul.

C'est pas la peine de commenter sur la structure de la feuille, je suis pris
avec ca (...) pour le moment et j'aimerais bien automatiser le calcul des
sommes.

Merci de m'aider.



JB
Le #4393671
Bonjour,


En B3 :=SOMME(DECALER(B4;;;EQUIV(VRAI;ESTVIDE(B4:B100);0)-1))

Cordialement JB

On 11 avr, 15:58, vertblancrouge
Bonjour

Dans ma colonne B, il y a différentes séries de montants séparées par des
cellules vides. Je désire calculer la somme de chacune de ces séries de
montants et les inscrires dans la colonne suivante.

Exemple pratique:
Dans ma feuille excel, j'écris en A3 le titre de ma somme.
De B4 à B9, il y a les montants.
Je désire avoir en C3, la somme de B4 à B9, soit de B4 jusqu'à la p rochaine
cellule vide, car en A11, il y a un autre titre de somme (pour B12 à B2 0 ex.)
et ainsi de suite.

Dans une série de montant, il peut y avoir plusieurs nombres comme il p eut y
en avoir un seul.

C'est pas la peine de commenter sur la structure de la feuille, je suis p ris
avec ca (...) pour le moment et j'aimerais bien automatiser le calcul des
sommes.

Merci de m'aider.


vertblancrouge
Le #4393551
Re-bonjour

Et merci à vous deux.


Bonjour,


En B3 :=SOMME(DECALER(B4;;;EQUIV(VRAI;ESTVIDE(B4:B100);0)-1))

Cordialement JB

On 11 avr, 15:58, vertblancrouge
Bonjour

Dans ma colonne B, il y a différentes séries de montants séparées par des
cellules vides. Je désire calculer la somme de chacune de ces séries de
montants et les inscrires dans la colonne suivante.

Exemple pratique:
Dans ma feuille excel, j'écris en A3 le titre de ma somme.
De B4 à B9, il y a les montants.
Je désire avoir en C3, la somme de B4 à B9, soit de B4 jusqu'à la prochaine
cellule vide, car en A11, il y a un autre titre de somme (pour B12 à B20 ex.)
et ainsi de suite.

Dans une série de montant, il peut y avoir plusieurs nombres comme il peut y
en avoir un seul.

C'est pas la peine de commenter sur la structure de la feuille, je suis pris
avec ca (...) pour le moment et j'aimerais bien automatiser le calcul des
sommes.

Merci de m'aider.







Publicité
Poster une réponse
Anonyme