Somme Si 2 critères

Le
syleg35
Bonjour à tous

Que dois-je rajouté dans ma formule ci-dessous qui totalise un montant su=
r 12 colonnes quand une cellule est renseignée << Arrêter >> mais je vo=
udrais ajouter un deuxième critère pour qu'il totalise que les montants=
supérieurs à zéro


=SOMME(SI(D89="Arrêté";E88);SI(F89="Arrêté";G88);SI(H89="Ar=
rêté";I88);SI(J89="Arrêté";K88);SI(L89="Arrêté";M88);SI(N89=
="Arrêté";O88);SI(P89="Arrêté";Q88);SI(R89="Arrêté";S88);=
SI(T89="Arrêté";U88);SI(V89="Arrêté";W88);SI(X89="Arrêté"=
;Y88);SI(Z89="Arrêté";AA88))


Merci à vous et bonne journée
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #26357056
Bonjour,

Teste cette formule pour moi...

=SOMMEPROD((($D$89:$Z$89="Arrêté")+($D$89:$Z$89>0)*(MOD(COLONNE($D$89:$Z$89);2)=0)*($E$88:$AA$88)))
DanielCo
Le #26357058
Bonjour,
Sauf si j'ai mal compris, la formule renvoie la valeur d'une cellule.
Quels montants doit-elle alors totaliser ? Ou doit-elle renvoyer le
premier montant supérieur à zéro trouvé ?
Cordialement.
Daniel


Bonjour à tous

Que dois-je rajouté dans ma formule ci-dessous qui totalise un montant sur
12 colonnes quand une cellule est renseignée << Arrêter >> mais je voudrais
ajouter un deuxième critère pour qu'il totalise que les montants supérieurs
à zéro


=SOMME(SI(D89="Arrêté";E88);SI(F89="Arrêté";G88);SI(H89="Arrêté";I88);SI(J89="Arrêté";K88);SI(L89="Arrêté";M88);SI(N89="Arrêté";O88);SI(P89="Arrêté";Q88);SI(R89="Arrêté";S88);SI(T89="Arrêté";U88);SI(V89="Arrêté";W88);SI(X89="Arrêté";Y88);SI(Z89="Arrêté";AA88))


Merci à vous et bonne journée
Jacky
Le #26357071
Bonjour,

Ceci devrait être suffisant
=SOMMEPROD(($D$89:$Z$89="Arrêté")*MOD(COLONNE($E$88:$AA$88);2)*($E$88:$AA$88>0)*$E$88:$AA$88)

--
Salutations
JJ


Bonjour à tous

Que dois-je rajouté dans ma formule ci-dessous qui totalise un montant sur 12 colonnes quand une cellule est
renseignée << Arrêter >> mais je voudrais ajouter un deuxième critère pour qu'il totalise que les montants
supérieurs à zéro


=SOMME(SI(D89="Arrêté";E88);SI(F89="Arrêté";G88);SI(H89="Arrêté";I88);SI(J89="Arrêté";K88);SI(L89="Arrêté";M88);SI(N89="Arrêté";O88);SI(P89="Arrêté";Q88);SI(R89="Arrêté";S88);SI(T89="Arrêté";U88);SI(V89="Arrêté";W88);SI(X89="Arrêté";Y88);SI(Z89="Arrêté";AA88))


Merci à vous et bonne journée
syleg35
Le #26357158
Bonjour à vous

merci Jacky pour ta réponse bien adapter a mon tableau

Bonne journée à tous

Le jeudi 18 juin 2015 18:10:18 UTC+2, Jacky a écrit :
Bonjour,

Ceci devrait être suffisant
=SOMMEPROD(($D$89:$Z$89="Arrêté")*MOD(COLONNE($E$88:$AA$88);2)*($ E$88:$AA$88>0)*$E$88:$AA$88)

--
Salutations
JJ


Bonjour à tous

Que dois-je rajouté dans ma formule ci-dessous qui totalise un montant sur 12 colonnes quand une cellule est
renseignée << Arrêter >> mais je voudrais ajouter un deuxième crit ère pour qu'il totalise que les montants
supérieurs à zéro


=SOMME(SI(D89="Arrêté";E88);SI(F89="Arrêté";G88);SI(H89=" Arrêté";I88);SI(J89="Arrêté";K88);SI(L89="Arrêté";M88);SI(N 89="Arrêté";O88);SI(P89="Arrêté";Q88);SI(R89="Arrêté";S88 );SI(T89="Arrêté";U88);SI(V89="Arrêté";W88);SI(X89="Arrêt é";Y88);SI(Z89="Arrêté";AA88))


Merci à vous et bonne journée
Publicité
Poster une réponse
Anonyme