SOMME.SI avec double condition ?

Le
LANIMAL
Bonjour,
Il y a longtemps que ça me travaille

Est il possible d'utiliser DANS EXCEL la fonction SOMME.SI
avec une double condition.
Par exemple, comme ci-dessous, la condition 'ET(<>"b";<>"c")'

SOMME.SI(A:A; ET(<>"b";<>"c"); G:G)

Si c'est possible, je ne sais pas l'écrire.
sinon, existe-t-il un autre moyen ?

>> Je ne souhaite pas faire une boucle en VB,
l'exécution serait trop longue

>> Peut-être créer une fonction ?,
dans ce cas, merci de m'aider dans le détail,
je ne suis pas à l'aise dans ce domaine.

Merci à mon éventuel coach.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #21213721
Bonjour,

=SOMMEPROD((A2:A10<>"b")*(A2:A10<>"c");G2:G10)

JB

On 17 fév, 09:07, LANIMAL
Bonjour,
Il y a longtemps que ça me travaille...

Est il possible d'utiliser DANS EXCEL la fonction SOMME.SI
avec une double condition.
Par exemple, comme ci-dessous, la condition 'ET(<>"b";<>"c")'

  SOMME.SI(A:A;  ET(<>"b";<>"c");  G:G)

Si c'est possible, je ne sais pas l'écrire.
sinon, existe-t-il un autre moyen ?

 >> Je ne souhaite pas faire une boucle en VB,
        l'exécution serait trop longue

 >> Peut-être créer une fonction ?,
        dans ce cas, merci de m'aider dans le détail,
        je ne suis pas à l'aise dans ce domaine.

Merci à mon éventuel coach.


LANIMAL
Le #21213831
Merci JB,
J'ai peu l'expérience de SOMMEPROD que je digérais mal à mes débuts,
si bien que j'en avais oublié l'existence.
Bonne occasion de me re-familiariser ...
Merci

JB a écrit :
Bonjour,

=SOMMEPROD((A2:A10<>"b")*(A2:A10<>"c");G2:G10)

JB

On 17 fév, 09:07, LANIMAL
Bonjour,
Il y a longtemps que ça me travaille...

Est il possible d'utiliser DANS EXCEL la fonction SOMME.SI
avec une double condition.
Par exemple, comme ci-dessous, la condition 'ET(<>"b";<>"c")'

SOMME.SI(A:A; ET(<>"b";<>"c"); G:G)

Si c'est possible, je ne sais pas l'écrire.
sinon, existe-t-il un autre moyen ?

>> Je ne souhaite pas faire une boucle en VB,
l'exécution serait trop longue

>> Peut-être créer une fonction ?,
dans ce cas, merci de m'aider dans le détail,
je ne suis pas à l'aise dans ce domaine.

Merci à mon éventuel coach.





JB
Le #21213941
http://boisgontierjacques.free.fr/pages_site/sommeprod.htm
http://boisgontierjacques.free.fr/pages_site/sommeprod3D.htm

JB

On 17 fév, 09:36, LANIMAL
Merci JB,
J'ai peu l'expérience de SOMMEPROD que je digérais mal à mes débu ts,
si bien que j'en avais oublié l'existence.
Bonne occasion de me re-familiariser ...
Merci

JB a écrit :



> Bonjour,

> =SOMMEPROD((A2:A10<>"b")*(A2:A10<>"c");G2:G10)

> JB

> On 17 fév, 09:07, LANIMAL >> Bonjour,
>> Il y a longtemps que ça me travaille...

>> Est il possible d'utiliser DANS EXCEL la fonction SOMME.SI
>> avec une double condition.
>> Par exemple, comme ci-dessous, la condition 'ET(<>"b";<>"c")'

>>   SOMME.SI(A:A;  ET(<>"b";<>"c");  G:G)

>> Si c'est possible, je ne sais pas l'écrire.
>> sinon, existe-t-il un autre moyen ?

>>  >> Je ne souhaite pas faire une boucle en VB,
>>         l'exécution serait trop longue

>>  >> Peut-être créer une fonction ?,
>>         dans ce cas, merci de m'aider dans le détail,
>>         je ne suis pas à l'aise dans ce domaine.

>> Merci à mon éventuel coach.- Masquer le texte des messages préc édents -

- Afficher le texte des messages précédents -


Publicité
Poster une réponse
Anonyme