SOMME.SI avec plusieurs critères

Le
Emilie
Bonjour!
Je cherche à faire une SOMME.SI avec non pas 1, mais plusieurs critères.
La solution serait d'ajouter les SOMME.SI les unes au bout des autres, mais
y aurait-il un moyen de renseigner tous mes critères dans une seule et même
SOMME.SI?

=SOMME.SI(plage;critère1/critère2/critère3/;montant)

Comment écrire cette liste de critères alors?

Merci pour votre aide!
Emilie
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4226301
Bonjour,

Il faut utiliser SommeProd((champ1=val1)*(champ2=val2)*ChampValeur):

=SOMMEPROD((B2:B10="Compta")*(C2:C10="q1")*D1:D10)


http://boisgontierj.free.fr/fichiers/jb-FonctionsMatricielles.zip

JB

On 6 mar, 10:23, Emilie
Bonjour!
Je cherche à faire une SOMME.SI avec non pas 1, mais plusieurs critèr es.
La solution serait d'ajouter les SOMME.SI les unes au bout des autres, ma is
y aurait-il un moyen de renseigner tous mes critères dans une seule et même
SOMME.SI?

=SOMME.SI(plage;critère1/critère2/critère3/...;montant)

Comment écrire cette liste de critères alors?

Merci pour votre aide!
Emilie


Daniel
Le #4226291
Bonjour.
Utilise SOMMEPROD :
un exemple :
=SOMMEPROD((plage=critère1)*(plage=critère2)*(plage>critère3)*montant)
Cordialement.
Daniel
"Emilie"
Bonjour!
Je cherche à faire une SOMME.SI avec non pas 1, mais plusieurs critères.
La solution serait d'ajouter les SOMME.SI les unes au bout des autres,
mais
y aurait-il un moyen de renseigner tous mes critères dans une seule et
même
SOMME.SI?

=SOMME.SI(plage;critère1/critère2/critère3/...;montant)

Comment écrire cette liste de critères alors?

Merci pour votre aide!
Emilie


Emilie
Le #4225951
Merci! mais SOMMEPROD ne fonctionne pas avec ce que je veux faire.

En fait, j'ai une SOMME.SI avec:
- une "plage" (que je ne change pas)
- un "critère" (qui est sous format numérique, ex: numéros de comptes) et
j'ai besoin d'aller chercher plusieurs numéros de comptes parfois
- et une "somme_plage" (que je ne change pas)

Donc comment renseigner plusieurs comptes (ex: 2120, 2121, 2125) dans le
champ critère?
essai: SOMME.SI=(plage;2120 & 2121 & 2125;somme_plage) ne marche pas!
...
Et les cellules d'origine de mes critères doivent être au format TEXTE ou
NOMBRE pour que ca marche?

Merci encore!
Cette petite astuce me permettrait de gagner du temps (et de l'espace) en
faisant ma SOMME.SI


Bonjour.
Utilise SOMMEPROD :
un exemple :
=SOMMEPROD((plage=critère1)*(plage=critère2)*(plage>critère3)*montant)
Cordialement.
Daniel
"Emilie"
Bonjour!
Je cherche à faire une SOMME.SI avec non pas 1, mais plusieurs critères.
La solution serait d'ajouter les SOMME.SI les unes au bout des autres,
mais
y aurait-il un moyen de renseigner tous mes critères dans une seule et
même
SOMME.SI?

=SOMME.SI(plage;critère1/critère2/critère3/...;montant)

Comment écrire cette liste de critères alors?

Merci pour votre aide!
Emilie







Daniel
Le #4225911
Quà cela ne tienne !
=SOMMEPROD(OU(plage!20;plage!21;plage!25)*montant)
si tes cellules de plage sont numériques et :
=SOMMEPROD(OU(plage="2120";plage="2121";plage="2125")*montant)
si elles sont au format texte.
Daniel
"Emilie"
Merci! mais SOMMEPROD ne fonctionne pas avec ce que je veux faire.

En fait, j'ai une SOMME.SI avec:
- une "plage" (que je ne change pas)
- un "critère" (qui est sous format numérique, ex: numéros de comptes) et
j'ai besoin d'aller chercher plusieurs numéros de comptes parfois
- et une "somme_plage" (que je ne change pas)

Donc comment renseigner plusieurs comptes (ex: 2120, 2121, 2125) dans le
champ critère?
essai: SOMME.SI=(plage;2120 & 2121 & 2125;somme_plage) ne marche pas!
...
Et les cellules d'origine de mes critères doivent être au format TEXTE ou
NOMBRE pour que ca marche?

Merci encore!
Cette petite astuce me permettrait de gagner du temps (et de l'espace) en
faisant ma SOMME.SI


Bonjour.
Utilise SOMMEPROD :
un exemple :
=SOMMEPROD((plage=critère1)*(plage=critère2)*(plage>critère3)*montant)
Cordialement.
Daniel
"Emilie" news:

Bonjour!
Je cherche à faire une SOMME.SI avec non pas 1, mais plusieurs
critères.
La solution serait d'ajouter les SOMME.SI les unes au bout des autres,
mais
y aurait-il un moyen de renseigner tous mes critères dans une seule et
même
SOMME.SI?

=SOMME.SI(plage;critère1/critère2/critère3/...;montant)

Comment écrire cette liste de critères alors?

Merci pour votre aide!
Emilie









JB
Le #4225851
Bonjour,

=SOMMEPROD((ESTNUM(EQUIV(champ;{2120;2121;2125};0)))*montant)

ou

=SOMMEPROD((ESTNUM(EQUIV(champ;{"2120";"2121";"2125"};0)))*montant)

ou si 2121,2122,2125 dans champ 'Codes'

=SOMMEPROD((ESTNUM(EQUIV(champ;codes;0)))*montant)

http://cjoint.com/?dgo7ruS1Yk

JB


On 6 mar, 14:13, Emilie
Merci! mais SOMMEPROD ne fonctionne pas avec ce que je veux faire.

En fait, j'ai une SOMME.SI avec:
- une "plage" (que je ne change pas)
- un "critère" (qui est sous format numérique, ex: numéros de compt es) et
j'ai besoin d'aller chercher plusieurs numéros de comptes parfois
- et une "somme_plage" (que je ne change pas)

Donc comment renseigner plusieurs comptes (ex: 2120, 2121, 2125) dans le
champ critère?
essai: SOMME.SI=(plage;2120 & 2121 & 2125;somme_plage) ne marche pas!
...
Et les cellules d'origine de mes critères doivent être au format TEXT E ou
NOMBRE pour que ca marche?

Merci encore!
Cette petite astuce me permettrait de gagner du temps (et de l'espace) en
faisant ma SOMME.SI




Bonjour.
Utilise SOMMEPROD :
un exemple :
=SOMMEPROD((plage=critère1)*(plage=critère2)*(plage>critère 3)*montant)
Cordialement.
Daniel
"Emilie"
Bonjour!
Je cherche à faire une SOMME.SI avec non pas 1, mais plusieurs crit ères.
La solution serait d'ajouter les SOMME.SI les unes au bout des autres,
mais
y aurait-il un moyen de renseigner tous mes critères dans une seule et
même
SOMME.SI?

=SOMME.SI(plage;critère1/critère2/critère3/...;montant)

Comment écrire cette liste de critères alors?

Merci pour votre aide!
Emilie- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




Clochard
Le #4225821
Bon matin...

Merci JB pour ce fichier... FonctionsMatricielles.zip.... une vraie petite
mine d'or
--
Clochard
Bien content d'avoir....
Merci!



Bonjour,

Il faut utiliser SommeProd((champ1=val1)*(champ2=val2)*ChampValeur):

=SOMMEPROD((B2:B10="Compta")*(C2:C10="q1")*D1:D10)


http://boisgontierj.free.fr/fichiers/jb-FonctionsMatricielles.zip

JB

On 6 mar, 10:23, Emilie
Bonjour!
Je cherche à faire une SOMME.SI avec non pas 1, mais plusieurs critères.
La solution serait d'ajouter les SOMME.SI les unes au bout des autres, mais
y aurait-il un moyen de renseigner tous mes critères dans une seule et même
SOMME.SI?

=SOMME.SI(plage;critère1/critère2/critère3/...;montant)

Comment écrire cette liste de critères alors?

Merci pour votre aide!
Emilie







Publicité
Poster une réponse
Anonyme