SOMME.SI avec plusieurs critères

Le
MatPin
Bonjour,

J'ai dans une première colonne des lettres de "a" à "z".
Dans les 2 colonnes d'à côté j'ai des nombres.
Je veux faire la somme des nombres des 2 colonnes pour certaines lettres.
En gros (la formule est fausse mais c'est pour expliquer) :
SOMME.SI(A1:A26;"a" ou "b" ou "r";B1:C26)

A B C
1 a 2 6
2 b 3 5 Je devrais ici obtenir 28
3 k 4 1
4 r 8 4
5 q 6 7

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
RGI
Le #4251761
Bonjour

essayer ceci

=SOMMEPROD(((A1:A5="a")+(A1:A5="b")+(A1:A5="r"))*B1:C5)

salutations

RGI

Bonjour,

J'ai dans une première colonne des lettres de "a" à "z".
Dans les 2 colonnes d'à côté j'ai des nombres.
Je veux faire la somme des nombres des 2 colonnes pour certaines lettres.
En gros (la formule est fausse mais c'est pour expliquer) :
SOMME.SI(A1:A26;"a" ou "b" ou "r";B1:C26)

A B C
1 a 2 6
2 b 3 5 Je devrais ici obtenir 28
3 k 4 1
4 r 8 4
5 q 6 7

Merci



JB
Le #4251691
Bonjour,

=SOMMEPROD((ESTNUM(EQUIV(A1:A10;{"A";"B";"R"};0))*B1:C10))

JB

On 23 mar, 15:07, MatPin
Bonjour,

J'ai dans une première colonne des lettres de "a" à "z".
Dans les 2 colonnes d'à côté j'ai des nombres.
Je veux faire la somme des nombres des 2 colonnes pour certaines lettres.
En gros (la formule est fausse mais c'est pour expliquer) :
SOMME.SI(A1:A26;"a" ou "b" ou "r";B1:C26)

A B C
1 a 2 6
2 b 3 5 Je devrais ici obtenir 28
3 k 4 1
4 r 8 4
5 q 6 7

Merci


MatPin
Le #4259501
Ca marche nikel

Merci


Bonjour

essayer ceci

=SOMMEPROD(((A1:A5="a")+(A1:A5="b")+(A1:A5="r"))*B1:C5)

salutations

RGI

Bonjour,

J'ai dans une première colonne des lettres de "a" à "z".
Dans les 2 colonnes d'à côté j'ai des nombres.
Je veux faire la somme des nombres des 2 colonnes pour certaines lettres.
En gros (la formule est fausse mais c'est pour expliquer) :
SOMME.SI(A1:A26;"a" ou "b" ou "r";B1:C26)

A B C
1 a 2 6
2 b 3 5 Je devrais ici obtenir 28
3 k 4 1
4 r 8 4
5 q 6 7

Merci






MatPin
Le #4318881
Super, ça marche.

Merci


Bonjour,

=SOMMEPROD((ESTNUM(EQUIV(A1:A10;{"A";"B";"R"};0))*B1:C10))

JB

On 23 mar, 15:07, MatPin
Bonjour,

J'ai dans une première colonne des lettres de "a" à "z".
Dans les 2 colonnes d'à côté j'ai des nombres.
Je veux faire la somme des nombres des 2 colonnes pour certaines lettres.
En gros (la formule est fausse mais c'est pour expliquer) :
SOMME.SI(A1:A26;"a" ou "b" ou "r";B1:C26)

A B C
1 a 2 6
2 b 3 5 Je devrais ici obtenir 28
3 k 4 1
4 r 8 4
5 q 6 7

Merci







Publicité
Poster une réponse
Anonyme