Somme.si les cellules de la plage contiennent "xxx"

Le
pierremisfud
Bonjour,

Je souhaiterais faire un somme.si que l'on pourrait exprimer de la
manière suivante :

Fait la somme de la plage F:F pour toutes les cellules de la plage
H:H contenant le mot "xxx".

ou bien

Somme.si(H:H;contient"xxx";F:F)

La formule donc devrait réagir aux cellules de la plage H:H dont le
contenu serait p. ex. :

xxx

ou :
xxx yyy

ou :
wwwxxxppp

Quelqu'un a-t-il une idée ? Merci d'avance.

P. Misfud
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gaston
Le #4745191
Bonjour Misfud

Essais ceci: =Somme.si(H1:H1000;"xxx";F1:F1000)

Gaston

"" wrote:

Bonjour,

Je souhaiterais faire un somme.si que l'on pourrait exprimer de la
manière suivante :

Fait la somme de la plage F:F pour toutes les cellules de la plage
H:H contenant le mot "xxx".

ou bien

Somme.si(H:H;contient"xxx";F:F)

La formule donc devrait réagir aux cellules de la plage H:H dont le
contenu serait p. ex. :

xxx

ou :
xxx yyy

ou :
wwwxxxppp

Quelqu'un a-t-il une idée ? Merci d'avance.

P. Misfud




JB
Le #4745181
Bonjour,

Nombre: F1:F100
Critere:H1:H100

=SOMMEPROD((critere="xxx")+(critere="yyy"))*Nombre

ou

=SOMMEPROD((ESTNUM(EQUIV(critere;tcritere;0)))*Nombre)

tcritere:

xxx
yyy
zzz

JB

On 19 sep, 16:06, wrote:
Bonjour,

Je souhaiterais faire un somme.si que l'on pourrait exprimer de la
manière suivante :

Fait la somme de la plage F:F pour toutes les cellules de la plage
H:H contenant le mot "xxx".

ou bien

Somme.si(H:H;contient"xxx";F:F)

La formule donc devrait réagir aux cellules de la plage H:H dont le
contenu serait p. ex. :

xxx

ou :
xxx yyy

ou :
wwwxxxppp

Quelqu'un a-t-il une idée ? Merci d'avance.

P. Misfud


pierremisfud
Le #4744501
Bonjour Gaston & JB,

Désolé de vous répondre seulement aujourd'hui.

Gaston : merci pour ta réponse, mais tu me propose la formule
"traditionnelle" du somme.si. Cette manière ne réagis que dans le cas
où il y a exculsivement "xxx" dans la colonne et c'est bien la mon
problème; c'est que je ne peux pas me borner à ça.

JB : merci pour tes réponses. Mais je patauge, je n'arrive pas à les
mettre en pratique.

J'ai mis un petit lien ci-joint. Dans l'exemple il s'agit de faire la
somme du champs correspondant aux cellules contenant "machine".

http://cjoint.com/?jukCrdrUxp

Merci d'avance pour votre aide,
Misfud
Gaston
Le #4744191
Bonjour Pierre,
La solution n'est pas très scientifique, mais...
Je mettrais une autre colonne qui sortirais les "Machine" avec:
=Nb.Si("F1:F100";*Machine*)
Ensuite je ferais mon Somme.Si avec cette colonne
Bonne Chance
Gaston

"" wrote:

Bonjour Gaston & JB,

Désolé de vous répondre seulement aujourd'hui.

Gaston : merci pour ta réponse, mais tu me propose la formule
"traditionnelle" du somme.si. Cette manière ne réagis que dans le cas
où il y a exculsivement "xxx" dans la colonne et c'est bien la mon
problème; c'est que je ne peux pas me borner à ça.

JB : merci pour tes réponses. Mais je patauge, je n'arrive pas à les
mettre en pratique.

J'ai mis un petit lien ci-joint. Dans l'exemple il s'agit de faire la
somme du champs correspondant aux cellules contenant "machine".

http://cjoint.com/?jukCrdrUxp

Merci d'avance pour votre aide,
Misfud




Filochard
Le #4744171
# J'ai mis un petit lien ci-joint. Dans l'exemple il s'agit de faire la
# somme du champs correspondant aux cellules contenant "machine".
# http://cjoint.com/?jukCrdrUxp

Matricielle (validation par ctrl+maj+entrée) :
=SOMME(SI(ESTNUM(CHERCHE("machine";F2:F10));H2:H10))
lSteph
Le #4744131
Bonjour,
=SOMMEPROD((NON(ESTERR(TROUVE("achine";F2:F11;1)))*(H2:H11)))

Nota:
Il te faut alors chercher achine pour faire 39
si tu cherche Machine tu obtiendra 1 si tu cherche machine tu
obtiendra 38
(tu peux les additionner)

--
lSteph

On 20 sep, 10:40, wrote:
Bonjour Gaston & JB,

Désolé de vous répondre seulement aujourd'hui.

Gaston : merci pour ta réponse, mais tu me propose la formule
"traditionnelle" du somme.si. Cette manière ne réagis que dans le cas
où il y a exculsivement "xxx" dans la colonne et c'est bien la mon
problème; c'est que je ne peux pas me borner à ça.

JB : merci pour tes réponses. Mais je patauge, je n'arrive pas à les
mettre en pratique.

J'ai mis un petit lien ci-joint. Dans l'exemple il s'agit de faire la
somme du champs correspondant aux cellules contenant "machine".

http://cjoint.com/?jukCrdrUxp

Merci d'avance pour votre aide,
Misfud


Gaston
Le #4744111
Bonjour,
La réponse à lSteph est meilleure que la mienne, mais il faudrait changer
"Trouve" par "Cherche" et tu pourrais écrire "Machine", car "Cherche" ne
respecte pas la casse.
Bye
Gaston

"lSteph" wrote:

Bonjour,
=SOMMEPROD((NON(ESTERR(TROUVE("achine";F2:F11;1)))*(H2:H11)))

Nota:
Il te faut alors chercher achine pour faire 39
si tu cherche Machine tu obtiendra 1 si tu cherche machine tu
obtiendra 38
(tu peux les additionner)

--
lSteph

On 20 sep, 10:40, wrote:
Bonjour Gaston & JB,

Désolé de vous répondre seulement aujourd'hui.

Gaston : merci pour ta réponse, mais tu me propose la formule
"traditionnelle" du somme.si. Cette manière ne réagis que dans le cas
où il y a exculsivement "xxx" dans la colonne et c'est bien la mon
problème; c'est que je ne peux pas me borner à ça.

JB : merci pour tes réponses. Mais je patauge, je n'arrive pas à les
mettre en pratique.

J'ai mis un petit lien ci-joint. Dans l'exemple il s'agit de faire la
somme du champs correspondant aux cellules contenant "machine".

http://cjoint.com/?jukCrdrUxp

Merci d'avance pour votre aide,
Misfud









Filochard
Le #4744061
La réponse à lSteph est meilleure que la mienne, mais il faudrait changer
"Trouve" par "Cherche" et tu pourrais écrire "Machine", car "Cherche" ne
respecte pas la casse.


Il suffisait de lire les réponses précédentes ...

Gaston
Le #4744041
Bonjour Filochard,
Tu as raison, je pensais que ta réponse ne fonctionnais pas parce que je
n'avais pas valider avec ctrl+maj+entrée.
Bye
Gaston

"Filochard" wrote:

La réponse à lSteph est meilleure que la mienne, mais il faudrait changer
"Trouve" par "Cherche" et tu pourrais écrire "Machine", car "Cherche" ne
respecte pas la casse.


Il suffisait de lire les réponses précédentes ...






pierremisfud
Le #4743891
On 20 sep, 15:25, lSteph
Bonjour,
=SOMMEPROD((NON(ESTERR(TROUVE("achine";F2:F11;1)))*(H2:H11)))

Nota:
Il te faut alors chercher achine pour faire 39
si tu cherche Machine tu obtiendra 1 si tu cherche machine tu
obtiendra 38
(tu peux les additionner)

--
lSteph



Bonjour LSteph, Gaston et Filochard,

Je trouve vos réponses maintenant et je vous en remercie très
sincérerment.

LSteph est décidément égale à lui même : just excellent !

C'est effectivement exactement ce que je cherchais.

Merci encore, et à tous une très bonne soirée.

Misfud

Publicité
Poster une réponse
Anonyme