somme si une condition

Le
Anne
bonjour,

J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour mon
problème. Voici ce que je retrouve dans mes colonnes

A B C D E F
EUR 10 10 10 10 10
GBR 20 20 20 20 20
EUR GBR EUR GBR EUR

Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la donnée
s'y retrouve.

Merci de m'aider
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #20929371
Bonjour,

Dans le genre pas claire ta question... en tous cas pour moi. Si tu
mettais des valeurs différentes dans tes colonnes et que tu nous donnais
un exemple du résultat attendu on pourrait t'aider, mais là, faut être
devin !

Misange

Anne a écrit :
bonjour,

J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour mon
problème. Voici ce que je retrouve dans mes colonnes

A B C D E F
EUR 10 10 10 10 10
GBR 20 20 20 20 20
EUR GBR EUR GBR EUR

Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la donnée
s'y retrouve.

Merci de m'aider


Tatanka
Le #20929431
Bonjour Anne,

Je pourrais probablement t'aider si
je comprenais vraiment ce que tu
veux obtenir ! Pourrais-tu préciser ?

Serge


"Anne"
bonjour,

J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour mon
problème. Voici ce que je retrouve dans mes colonnes

A B C D E F
EUR 10 10 10 10 10
GBR 20 20 20 20 20
EUR GBR EUR GBR EUR

Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
donnée
s'y retrouve.

Merci de m'aider


Jacquouille
Le #20929421
Bonsoir Soeur Anne
Peux-tu refaire un nouvel exemple, avec des valeurs différentes et le
résultat que tu désires.
Il conviendrait que nous sachions où chercher.

Mieux, ton fichier (ou partie de fichier) sur CJOINT

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Anne"
bonjour,

J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour mon
problème. Voici ce que je retrouve dans mes colonnes

A B C D E F
EUR 10 10 10 10 10
GBR 20 20 20 20 20
EUR GBR EUR GBR EUR

Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
donnée
s'y retrouve.

Merci de m'aider


michdenis
Le #20929791
Bonjour,

Je prends une chance :

Validation matricielle :
En supposant que cette ligne se retrouve
sur la ligne 14 de A à F
EUR 10 10 10 10 10
et que celle-ci soit sur la ligne 14
EUR GBR EUR GBR EUR

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(B14:F14="EUR";B12:F12))




"Anne"
bonjour,

J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour mon
problème. Voici ce que je retrouve dans mes colonnes

A B C D E F
EUR 10 10 10 10 10
GBR 20 20 20 20 20
EUR GBR EUR GBR EUR

Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la donnée
s'y retrouve.

Merci de m'aider
Anne
Le #20930241
D'accord je vais recommencer

voici la feuille excel au haut c les en-tête A B C C et les colonnes 1 2 3 4 5

A B C D E
1 EUR 1 5 7 2
2 GBR 5 8 2 10
3 9 5 8 2
4 EUR GBR EUR EUR

J'aimerais obtenir la somme des colonnes où l'on retrouve EUR ou GBR

Ainsi pour EUR j'ai le total de la colonne B, D et E et pour GBR j'ai la
colonne C.

Dans la colonne A c'est en réalité, ce que je recherche. il y a une série
j'en ai mis seulement 2 pour l'exemple.

Est-ce que vous pouvez plus m'aider ?

Merci beaucoup !





"Jacquouille" a écrit :

Bonsoir Soeur Anne
Peux-tu refaire un nouvel exemple, avec des valeurs différentes et le
résultat que tu désires.
Il conviendrait que nous sachions où chercher.

Mieux, ton fichier (ou partie de fichier) sur CJOINT

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Anne"
> bonjour,
>
> J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour mon
> problème. Voici ce que je retrouve dans mes colonnes
>
> A B C D E F
> EUR 10 10 10 10 10
> GBR 20 20 20 20 20
> EUR GBR EUR GBR EUR
>
> Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
> donnée
> s'y retrouve.
>
> Merci de m'aider


.



Tatanka
Le #20930441
Bonsoir Anne,

Est-ce que ces formules te conviemnnent ?
=SOMMEPROD((B4:E4="EUR")*B1:E3)
=SOMMEPROD((B4:E4="GBR")*B1:E3)

Serge


"Anne"
D'accord je vais recommencer

voici la feuille excel au haut c les en-tête A B C C et les colonnes 1 2 3
4 5

A B C D E
1 EUR 1 5 7 2
2 GBR 5 8 2 10
3 9 5 8
2
4 EUR GBR EUR EUR

J'aimerais obtenir la somme des colonnes où l'on retrouve EUR ou GBR

Ainsi pour EUR j'ai le total de la colonne B, D et E et pour GBR j'ai la
colonne C.

Dans la colonne A c'est en réalité, ce que je recherche. il y a une série
j'en ai mis seulement 2 pour l'exemple.

Est-ce que vous pouvez plus m'aider ?

Merci beaucoup !





"Jacquouille" a écrit :

Bonsoir Soeur Anne
Peux-tu refaire un nouvel exemple, avec des valeurs différentes et le
résultat que tu désires.
Il conviendrait que nous sachions où chercher.

Mieux, ton fichier (ou partie de fichier) sur CJOINT

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Anne"
> bonjour,
>
> J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour
> mon
> problème. Voici ce que je retrouve dans mes colonnes
>
> A B C D E F
> EUR 10 10 10 10 10
> GBR 20 20 20 20 20
> EUR GBR EUR GBR EUR
>
> Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
> donnée
> s'y retrouve.
>
> Merci de m'aider


.





Jacquouille
Le #20930541
Bonsoir Anne
Bien que la température ne s'y prête, je vais me jeter à l'eau, comme l'a
fait Denis.
Tu dis:
<<J'aimerais obtenir la somme des colonnes où l'on retrouve EUR
<<Ainsi pour EUR j'ai le total de la colonne B, D et E
dans une cel = somme(b1:b3;d1:d3;e1:e3)
ou =SOMMEPROD((B4:E4="EUR")*B1:E3)
Les 2 donnent 46 qui est la somme des 3 col contenant le mot "EUR"
Si pas cela, joindre fichier avec le montant désiré et on cherchera la bonne
formule
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Anne"
D'accord je vais recommencer

voici la feuille excel au haut c les en-tête A B C C et les colonnes 1 2 3
4 5

A B C D E
1 EUR 1 5 7 2
2 GBR 5 8 2 10
3 9 5 8
2
4 EUR GBR EUR EUR

J'aimerais obtenir la somme des colonnes où l'on retrouve EUR ou GBR

Ainsi pour EUR j'ai le total de la colonne B, D et E et pour GBR j'ai la
colonne C.

Dans la colonne A c'est en réalité, ce que je recherche. il y a une série
j'en ai mis seulement 2 pour l'exemple.

Est-ce que vous pouvez plus m'aider ?

Merci beaucoup !





"Jacquouille" a écrit :

Bonsoir Soeur Anne
Peux-tu refaire un nouvel exemple, avec des valeurs différentes et le
résultat que tu désires.
Il conviendrait que nous sachions où chercher.

Mieux, ton fichier (ou partie de fichier) sur CJOINT

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Anne"
> bonjour,
>
> J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour
> mon
> problème. Voici ce que je retrouve dans mes colonnes
>
> A B C D E F
> EUR 10 10 10 10 10
> GBR 20 20 20 20 20
> EUR GBR EUR GBR EUR
>
> Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
> donnée
> s'y retrouve.
>
> Merci de m'aider


.





Tatanka
Le #20930741
Et si tu as beaucoup de catégories EUR, GBR, A, B, ...
tu pourrais procéder ainsi :
http://www.cijoint.fr/cjlink.php?file=cj201001/cijlkTTC3H.xls
en supposant que mon exemple respecte la structure de tes données.

Serge


"Tatanka"
Bonsoir Anne,

Est-ce que ces formules te conviemnnent ?
=SOMMEPROD((B4:E4="EUR")*B1:E3)
=SOMMEPROD((B4:E4="GBR")*B1:E3)

Serge


"Anne"
D'accord je vais recommencer

voici la feuille excel au haut c les en-tête A B C C et les colonnes 1 2
3 4 5

A B C D
E
1 EUR 1 5 7 2
2 GBR 5 8 2 10
3 9 5 8 2
4 EUR GBR EUR EUR

J'aimerais obtenir la somme des colonnes où l'on retrouve EUR ou GBR

Ainsi pour EUR j'ai le total de la colonne B, D et E et pour GBR j'ai la
colonne C.

Dans la colonne A c'est en réalité, ce que je recherche. il y a une série
j'en ai mis seulement 2 pour l'exemple.

Est-ce que vous pouvez plus m'aider ?

Merci beaucoup !





"Jacquouille" a écrit :

Bonsoir Soeur Anne
Peux-tu refaire un nouvel exemple, avec des valeurs différentes et le
résultat que tu désires.
Il conviendrait que nous sachions où chercher.

Mieux, ton fichier (ou partie de fichier) sur CJOINT

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Anne"
> bonjour,
>
> J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour
> mon
> problème. Voici ce que je retrouve dans mes colonnes
>
> A B C D E F
> EUR 10 10 10 10 10
> GBR 20 20 20 20 20
> EUR GBR EUR GBR EUR
>
> Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
> donnée
> s'y retrouve.
>
> Merci de m'aider


.









Tatanka
Le #20930931
Je tente ma chance à nouveau ;-)
Quelque chose du genre, peut-être ?
http://www.cijoint.fr/cjlink.php?file=cj201001/cijNDxNF5s.xls

Serge





"Tatanka"
Et si tu as beaucoup de catégories EUR, GBR, A, B, ...
tu pourrais procéder ainsi :
http://www.cijoint.fr/cjlink.php?file=cj201001/cijlkTTC3H.xls
en supposant que mon exemple respecte la structure de tes données.

Serge


"Tatanka"
Bonsoir Anne,

Est-ce que ces formules te conviemnnent ?
=SOMMEPROD((B4:E4="EUR")*B1:E3)
=SOMMEPROD((B4:E4="GBR")*B1:E3)

Serge


"Anne"
D'accord je vais recommencer

voici la feuille excel au haut c les en-tête A B C C et les colonnes 1 2
3 4 5

A B C D E
1 EUR 1 5 7 2
2 GBR 5 8 2 10
3 9 5 8 2
4 EUR GBR EUR EUR

J'aimerais obtenir la somme des colonnes où l'on retrouve EUR ou GBR

Ainsi pour EUR j'ai le total de la colonne B, D et E et pour GBR j'ai la
colonne C.

Dans la colonne A c'est en réalité, ce que je recherche. il y a une
série
j'en ai mis seulement 2 pour l'exemple.

Est-ce que vous pouvez plus m'aider ?

Merci beaucoup !





"Jacquouille" a écrit :

Bonsoir Soeur Anne
Peux-tu refaire un nouvel exemple, avec des valeurs différentes et le
résultat que tu désires.
Il conviendrait que nous sachions où chercher.

Mieux, ton fichier (ou partie de fichier) sur CJOINT

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Anne" news:

> bonjour,
>
> J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour
> mon
> problème. Voici ce que je retrouve dans mes colonnes
>
> A B C D E F
> EUR 10 10 10 10 10
> GBR 20 20 20 20 20
> EUR GBR EUR GBR EUR
>
> Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
> donnée
> s'y retrouve.
>
> Merci de m'aider


.













isabelle
Le #20931021
hug tatanka,

y'avait trop de neige sur ton tipi, c'est pour ça que tu est sorti de ta
cachette ? ;-)

isabelle

Le 2010-01-08 13:07, Tatanka a écrit :
Bonjour Anne,

Je pourrais probablement t'aider si
je comprenais vraiment ce que tu
veux obtenir ! Pourrais-tu préciser ?

Serge


"Anne"

bonjour,

J'ai fait une recherche mais il n'a pas rien que j'ai pu trouvé pour mon
problème. Voici ce que je retrouve dans mes colonnes

A B C D E F
EUR 10 10 10 10 10
GBR 20 20 20 20 20
EUR GBR EUR GBR EUR

Maintenant, pour chaque EUR j'aimerais la somme de la colonne que la
donnée
s'y retrouve.

Merci de m'aider







Publicité
Poster une réponse
Anonyme