somme.si sur des dates

Le
Rekam
Bonjour,

je cherche à faire un somme.si sur une plage de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en C1, je souhaiterais avoir le total des montants correspondant au MOIS(C1).

J'ai essayé avec le somme.si, mais je sèche. Je ne vois pas vraiment comment
manipuler des dates dans cette fonction

Quelle est la solution selon vous?

merci d'avance!
rekam
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Rekam
Le #20312381
oups, j'ai fait une p'tite faute de frappe. C'est en D1 que je souhaiterais
avoir la somme. En C1, il n'y a que la date de référence.

merci!

"Rekam" wrote:

Bonjour,

je cherche à faire un somme.si sur une plage de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en C1, je souhaiterais avoir le total des montants correspondant au MOIS(C1).

J'ai essayé avec le somme.si, mais je sèche. Je ne vois pas vraiment comment
manipuler des dates dans cette fonction...

Quelle est la solution selon vous?

merci d'avance!
rekam


Daniel.C
Le #20312641
Bonjour.
Si tu veux que la comparaison ne porte que sur les mois sans tenir
compte des années :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*B1:B100)
Cordialement.
Daniel

oups, j'ai fait une p'tite faute de frappe. C'est en D1 que je souhaiterais
avoir la somme. En C1, il n'y a que la date de référence.

merci!

"Rekam" wrote:

Bonjour,

je cherche à faire un somme.si sur une plage de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en C1, je souhaiterais avoir le total des montants correspondant au
MOIS(C1).

J'ai essayé avec le somme.si, mais je sèche. Je ne vois pas vraiment comment
manipuler des dates dans cette fonction...

Quelle est la solution selon vous?

merci d'avance!
rekam




Daniel.C
Le #20312631
Sinon, en tenant compte des années :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)
Daniel

Bonjour.
Si tu veux que la comparaison ne porte que sur les mois sans tenir compte des
années :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*B1:B100)
Cordialement.
Daniel

oups, j'ai fait une p'tite faute de frappe. C'est en D1 que je souhaiterais
avoir la somme. En C1, il n'y a que la date de référence.

merci!

"Rekam" wrote:

Bonjour,

je cherche à faire un somme.si sur une plage de date, en faisant le test
sur le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en C1, je souhaiterais avoir le total des montants correspondant au
MOIS(C1).

J'ai essayé avec le somme.si, mais je sèche. Je ne vois pas vraiment
comment manipuler des dates dans cette fonction...

Quelle est la solution selon vous?

merci d'avance!
rekam






Rekam
Le #20313101
Impeccable, merci! c'est exactement ça.

Bonne journée!


"Daniel.C" wrote:

Sinon, en tenant compte des années :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)
Daniel

> Bonjour.
> Si tu veux que la comparaison ne porte que sur les mois sans tenir compte des
> années :
> =SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*B1:B100)
> Cordialement.
> Daniel
>
>> oups, j'ai fait une p'tite faute de frappe. C'est en D1 que je souhaiterais
>> avoir la somme. En C1, il n'y a que la date de référence.
>>
>> merci!
>>
>> "Rekam" wrote:
>>
>>> Bonjour,
>>>
>>> je cherche à faire un somme.si sur une plage de date, en faisant le test
>>> sur le mois. Plus précisément:
>>>
>>> A1:A100 = des dates
>>> B1:B100 = des montants
>>>
>>> C1 = une date: exactement 01.02.2009
>>>
>>> en C1, je souhaiterais avoir le total des montants correspondant au
>>> MOIS(C1).
>>>
>>> J'ai essayé avec le somme.si, mais je sèche. Je ne vois pas vraiment
>>> comment manipuler des dates dans cette fonction...
>>>
>>> Quelle est la solution selon vous?
>>>
>>> merci d'avance!
>>> rekam





Publicité
Poster une réponse
Anonyme