Somme de si

Le
EricP
Bonjour,

Je cherche à écrire "proprement" la formule suivante:
=si(b1="x";a1;0)
+ si(b2="x";a2;0)
+
+ si(b10="x";a10;0)

Je ne suis pas sur que ce qui suit soit plus clair

J'ai 2 colonnes:
la première contient des montants
la deuxième contient un "x" si je veux sélectionner le montant de la
ligne correspondante.

Je souhaite additionner en bas de la 2ème colonne les montants
sélectionnés par un "x".

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Corona
Le #19984881
Bonjour Eric,
=SOMME.SI(B2:B8;"x";A2:A8)
Bonne journée
Philippe Tulliez

EricP a écrit :
Bonjour,

Je cherche à écrire "proprement" la formule suivante:
=si(b1="x";a1;0)
+ si(b2="x";a2;0)
+ ...
+ si(b10="x";a10;0)

Je ne suis pas sur que ce qui suit soit plus clair...

J'ai 2 colonnes:
la première contient des montants
la deuxième contient un "x" si je veux sélectionner le montant de la
ligne correspondante.

Je souhaite additionner en bas de la 2ème colonne les montants
sélectionnés par un "x".

Merci d'avance


EricP
Le #19984871
Impeccable! Merci

Corona a écrit :
Bonjour Eric,
=SOMME.SI(B2:B8;"x";A2:A8)
Bonne journée
Philippe Tulliez

EricP a écrit :
Bonjour,

Je cherche à écrire "proprement" la formule suivante:
=si(b1="x";a1;0)
+ si(b2="x";a2;0)
+ ...
+ si(b10="x";a10;0)

Je ne suis pas sur que ce qui suit soit plus clair...

J'ai 2 colonnes:
la première contient des montants
la deuxième contient un "x" si je veux sélectionner le montant de la
ligne correspondante.

Je souhaite additionner en bas de la 2ème colonne les montants
sélectionnés par un "x".

Merci d'avance




garnote
Le #19986461
Bonjour Éric,

Il y a aussi (exemple) :
=SOMMEPROD((B2:B10="x")*A2:A10)

Serge


"EricP" 4a939318$0$12657$
Bonjour,

Je cherche à écrire "proprement" la formule suivante:
=si(b1="x";a1;0)
+ si(b2="x";a2;0)
+ ...
+ si(b10="x";a10;0)

Je ne suis pas sur que ce qui suit soit plus clair...

J'ai 2 colonnes:
la première contient des montants
la deuxième contient un "x" si je veux sélectionner le montant de la ligne
correspondante.

Je souhaite additionner en bas de la 2ème colonne les montants
sélectionnés par un "x".

Merci d'avance


Publicité
Poster une réponse
Anonyme