Somme SI

Le
Clochard
Bonsoir,
J'ai encore besoin de vos conseils
J'ai 30 sections comportant 3 colonnes chaque.
C3:E3, H3:J3; M3:O3; R3:T3. ainsi de suite jusqu'à ER3:ET3

En EW je dois calculer en additionnant 1 pour chaque colonne qui contient un
chiffre supérieur à 0

J'me suis dit qu'en placant cette formule j'y arriverais.
=SI(SI(F3>=1;"3")+SI(K3>=1;"3")+SI(P3>=1;"3")+SI(U3>=1;"3")+SI(Z3>=1;"3")+SI(AE3>=1;"3")+SI(AJ3>=1;"3")+SI(AO3>=1;"3")+SI(AT3>=1;"3") etc.

Malheureusement si D3 contient 0 il me donne 3 quand même ce que
j'aimerais obtenir c'est que si SI C3>0=1+ D3>0=1+E3>0=1+H3>0=1+I3>0=1
ainsi de suite jusqu'à +ET3>0=1
Ça me fait une formule de 45 kilo de long
SVPComment puis-je simplifier
--
Clochard
Aimerais bien savoir.
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Clochard
Le #4977611
J'ai oublié de mentionner qu'en F3 j'ai le total de C3:E3
en K3=H3:J3...ainsi de suite
--
Clochard
Aimerais bien savoir....
Merci!



Bonsoir,
J'ai encore besoin de vos conseils...
J'ai 30 sections comportant 3 colonnes chaque.
C3:E3, H3:J3; M3:O3; R3:T3.... ainsi de suite jusqu'à ER3:ET3

En EW je dois calculer en additionnant 1 pour chaque colonne qui contient un
chiffre supérieur à 0

J'me suis dit qu'en placant cette formule j'y arriverais....
=SI(SI(F3>=1;"3")+SI(K3>=1;"3")+SI(P3>=1;"3")+SI(U3>=1;"3")+SI(Z3>=1;"3")+SI(AE3>=1;"3")+SI(AJ3>=1;"3")+SI(AO3>=1;"3")+SI(AT3>=1;"3") etc....

Malheureusement si... D3 contient 0 il me donne 3 quand même... ce que
j'aimerais obtenir c'est que si SI C3>0=1+ D3>0=1+E3>0=1+H3>0=1+I3>0=1
ainsi de suite jusqu'à +ET3>0=1
Ça me fait une formule de 45 kilo de long...
SVP...Comment puis-je simplifier
--
Clochard
Aimerais bien savoir....
Merci!


Fredo P.
Le #4977431
Bonjour Clochard
Je ne vois que la solution d'utiliser une ligne intermédiaire.
http://cjoint.com/?kjk1ALNcvL
"Clochard"
J'ai oublié de mentionner qu'en F3 j'ai le total de C3:E3
en K3=H3:J3...ainsi de suite
--
Clochard
Aimerais bien savoir....
Merci!



Bonsoir,
J'ai encore besoin de vos conseils...
J'ai 30 sections comportant 3 colonnes chaque.
C3:E3, H3:J3; M3:O3; R3:T3.... ainsi de suite jusqu'à ER3:ET3

En EW je dois calculer en additionnant 1 pour chaque colonne qui contient
un
chiffre supérieur à 0

J'me suis dit qu'en placant cette formule j'y arriverais....
=SI(SI(F3>=1;"3")+SI(K3>=1;"3")+SI(P3>=1;"3")+SI(U3>=1;"3")+SI(Z3>=1;"3")+SI(AE3>=1;"3")+SI(AJ3>=1;"3")+SI(AO3>=1;"3")+SI(AT3>=1;"3")
etc....

Malheureusement si... D3 contient 0 il me donne 3 quand même... ce que
j'aimerais obtenir c'est que si SI C3>0=1+ D3>0=1+E3>0=1+H3>0=1+I3>0=1
ainsi de suite jusqu'à +ET3>0=1
Ça me fait une formule de 45 kilo de long...
SVP...Comment puis-je simplifier
--
Clochard
Aimerais bien savoir....
Merci!




ChristianM
Le #4977341
Bonjour,

mettre en EW3 la formule suivante :
=SOMMEPROD(((C3:ET3)>0)*(MOD(COLONNE(C3:ET3)-3;5)<3))

voilou....



"Clochard"
Bonsoir,
J'ai encore besoin de vos conseils...
J'ai 30 sections comportant 3 colonnes chaque.
C3:E3, H3:J3; M3:O3; R3:T3.... ainsi de suite jusqu'à ER3:ET3

En EW je dois calculer en additionnant 1 pour chaque colonne qui contient
un
chiffre supérieur à 0

J'me suis dit qu'en placant cette formule j'y arriverais....
=SI(SI(F3>=1;"3")+SI(K3>=1;"3")+SI(P3>=1;"3")+SI(U3>=1;"3")+SI(Z3>=1;"3")+SI(AE3>=1;"3")+SI(AJ3>=1;"3")+SI(AO3>=1;"3")+SI(AT3>=1;"3")
etc....

Malheureusement si... D3 contient 0 il me donne 3 quand même... ce que
j'aimerais obtenir c'est que si SI C3>0=1+ D3>0=1+E3>0=1+H3>0=1+I3>0=1
ainsi de suite jusqu'à +ET3>0=1
Ça me fait une formule de 45 kilo de long...
SVP...Comment puis-je simplifier
--
Clochard
Aimerais bien savoir....
Merci!


Clochard
Le #4977181
Bonjour,

Merci ChristianM, c'est exactement ce que je cherchais... ça fonctionne à
merveille....

Et merci aussi Fredo P. pour ta suggestion
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,

mettre en EW3 la formule suivante :
=SOMMEPROD(((C3:ET3)>0)*(MOD(COLONNE(C3:ET3)-3;5)<3))

voilou....



"Clochard"
Bonsoir,
J'ai encore besoin de vos conseils...
J'ai 30 sections comportant 3 colonnes chaque.
C3:E3, H3:J3; M3:O3; R3:T3.... ainsi de suite jusqu'à ER3:ET3

En EW je dois calculer en additionnant 1 pour chaque colonne qui contient
un
chiffre supérieur à 0

J'me suis dit qu'en placant cette formule j'y arriverais....
=SI(SI(F3>=1;"3")+SI(K3>=1;"3")+SI(P3>=1;"3")+SI(U3>=1;"3")+SI(Z3>=1;"3")+SI(AE3>=1;"3")+SI(AJ3>=1;"3")+SI(AO3>=1;"3")+SI(AT3>=1;"3")
etc....

Malheureusement si... D3 contient 0 il me donne 3 quand même... ce que
j'aimerais obtenir c'est que si SI C3>0=1+ D3>0=1+E3>0=1+H3>0=1+I3>0=1
ainsi de suite jusqu'à +ET3>0=1
Ça me fait une formule de 45 kilo de long...
SVP...Comment puis-je simplifier
--
Clochard
Aimerais bien savoir....
Merci!







Fredo P.
Le #4976661
Validée en matricielle le fait aussi.
=SOMME((C3:ET3>0)*(C3:ET3<3))
"ChristianM"
Bonjour,

mettre en EW3 la formule suivante :
=SOMMEPROD(((C3:ET3)>0)*(MOD(COLONNE(C3:ET3)-3;5)<3))

voilou....



"Clochard"
Bonsoir,
J'ai encore besoin de vos conseils...
J'ai 30 sections comportant 3 colonnes chaque.
C3:E3, H3:J3; M3:O3; R3:T3.... ainsi de suite jusqu'à ER3:ET3

En EW je dois calculer en additionnant 1 pour chaque colonne qui contient
un
chiffre supérieur à 0

J'me suis dit qu'en placant cette formule j'y arriverais....
=SI(SI(F3>=1;"3")+SI(K3>=1;"3")+SI(P3>=1;"3")+SI(U3>=1;"3")+SI(Z3>=1;"3")+SI(AE3>=1;"3")+SI(AJ3>=1;"3")+SI(AO3>=1;"3")+SI(AT3>=1;"3")
etc....

Malheureusement si... D3 contient 0 il me donne 3 quand même... ce que
j'aimerais obtenir c'est que si SI C3>0=1+ D3>0=1+E3>0=1+H3>0=1+I3>0=1
ainsi de suite jusqu'à +ET3>0=1
Ça me fait une formule de 45 kilo de long...
SVP...Comment puis-je simplifier
--
Clochard
Aimerais bien savoir....
Merci!






Publicité
Poster une réponse
Anonyme