Somme.Si limitée

Le
Philippe
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs de
la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation aux 3 +
petites valeurs.
Merci à vous toutes et tous.
Philippe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5235971
Bonjour.
Formule matricielle (valider avec CTRL+MAJ+Entrée) :
=SOMME(PETITE.VALEUR(SI(A1:A6="lyon";B1:B6;9^9);LIGNE(1:3)))
Cordialement.
Daniel
"Philippe" %
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs de
la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation aux 3
+ petites valeurs.
Merci à vous toutes et tous.
Philippe




JB
Le #5235891
Bonjour,

=SOMME(PETITE.VALEUR(SI(A1:A6="lyon";B1:B6);{1;2;3}))
Valider avec maj+ctrl+entrée

JB
On 1 mar, 11:09, "Philippe"
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
    (A)     (B)                        (E)
LYON    1            LYON
PARIS    2
LYON    3
LILLE     4
LYON    5
LYON    6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs de
la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation au x 3 +
petites valeurs.
Merci à vous toutes et tous.
Philippe


Philippe
Le #5235811
Merci(s) à Daniel.C et à JB
C'est éxactement ce que je cherchais.
Bonne journée à vous deux.
"Philippe" %
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs de
la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation aux 3
+ petites valeurs.
Merci à vous toutes et tous.
Philippe




Philippe
Le #5235761
Re bonjour,
Dans le même ordre d'idée des formules de Daniel.C et JB, peut-on sommer de
la même façon mais en plus ou seulement si l'on a un minimum de 3 petites
valeurs. Dans le cas contraire ne pas faire la somme.
Re-Merci de vos lumières.
"Philippe" %
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs de
la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation aux 3
+ petites valeurs.
Merci à vous toutes et tous.
Philippe




Daniel.C
Le #5235741
Toujours matricielle :
=SI(NB.SI(A1:A6;"lyon")>2;SOMME(PETITE.VALEUR(SI(A1:A6="lyon";B1:B6;9^9);LIGNE(1:3)));"")
Daniel
"Philippe" %
Re bonjour,
Dans le même ordre d'idée des formules de Daniel.C et JB, peut-on sommer
de la même façon mais en plus ou seulement si l'on a un minimum de 3
petites valeurs. Dans le cas contraire ne pas faire la somme.
Re-Merci de vos lumières.
"Philippe" %
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs
de la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation aux 3
+ petites valeurs.
Merci à vous toutes et tous.
Philippe








Philippe
Le #5235701
Milles excuses, mais la formule est erronnée.
Fichier ci-joint
http://cjoint.com/?dbsabeurda

"Daniel.C"
Toujours matricielle :
=SI(NB.SI(A1:A6;"lyon")>2;SOMME(PETITE.VALEUR(SI(A1:A6="lyon";B1:B6;9^9);LIGNE(1:3)));"")
Daniel
"Philippe" %
Re bonjour,
Dans le même ordre d'idée des formules de Daniel.C et JB, peut-on sommer
de la même façon mais en plus ou seulement si l'on a un minimum de 3
petites valeurs. Dans le cas contraire ne pas faire la somme.
Re-Merci de vos lumières.
"Philippe" %
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs
de la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation aux
3 + petites valeurs.
Merci à vous toutes et tous.
Philippe












Daniel.C
Le #5235661
SJCV n'est pas SJVC ;-))
Daniel
"Philippe"
Milles excuses, mais la formule est erronnée.
Fichier ci-joint
http://cjoint.com/?dbsabeurda

"Daniel.C"
Toujours matricielle :
=SI(NB.SI(A1:A6;"lyon")>2;SOMME(PETITE.VALEUR(SI(A1:A6="lyon";B1:B6;9^9);LIGNE(1:3)));"")
Daniel
"Philippe" %
Re bonjour,
Dans le même ordre d'idée des formules de Daniel.C et JB, peut-on sommer
de la même façon mais en plus ou seulement si l'on a un minimum de 3
petites valeurs. Dans le cas contraire ne pas faire la somme.
Re-Merci de vos lumières.
"Philippe" news: %
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites valeurs
de la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation aux
3 + petites valeurs.
Merci à vous toutes et tous.
Philippe
















Philippe
Le #5235521
Oups ! (sans commentaire)

"Daniel.C"
SJCV n'est pas SJVC ;-))
Daniel
"Philippe"
Milles excuses, mais la formule est erronnée.
Fichier ci-joint
http://cjoint.com/?dbsabeurda

"Daniel.C"
Toujours matricielle :
=SI(NB.SI(A1:A6;"lyon")>2;SOMME(PETITE.VALEUR(SI(A1:A6="lyon";B1:B6;9^9);LIGNE(1:3)));"")
Daniel
"Philippe" news: %
Re bonjour,
Dans le même ordre d'idée des formules de Daniel.C et JB, peut-on
sommer de la même façon mais en plus ou seulement si l'on a un minimum
de 3 petites valeurs. Dans le cas contraire ne pas faire la somme.
Re-Merci de vos lumières.
"Philippe" news: %
Bonjour à tous et à toutes.
Prenant le petit tableau ci-dessous :
(A) (B) (E)
LYON 1 LYON
PARIS 2
LYON 3
LILLE 4
LYON 5
LYON 6

Je désire trouver (en E1) seulement la somme des 3 plus petites
valeurs de la colonne B si la colonne A contient LYON
Je pensais à SOMMEPROD mais je n'arrive pas à trouver la limitation
aux 3 + petites valeurs.
Merci à vous toutes et tous.
Philippe




















Publicité
Poster une réponse
Anonyme