SOMME SI et RECHECHEV

Le
midomind
Bonjour à tous,

J'ai une petit souci avec une feuille Excel qui récupère des données
dans d'autre feuille.
Le problème c'est que, quand je clic sur le bouton mettre à jour les
liens à l'ouverture de mon fichier, les cellule qui contient la
formule RECHERCHEV se mettent à jours sans problème, par contre là o=
ù
j'ai ma formule avec SOMME.SI j'ai un résultat #VALEUR, donc
impossible de mettre à jours si le fichier d'origine est fermé.

D'avance merci.

je vous souhaite un bon début de semaine
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
midomind
Le #6820271
En effet, la fonction SOMME.SI exige que l'autre fichier soit chargé
en mémoire (ce qui n'est pas le cas pour la fonction RECHERCHE).

Pour détourner le problème il faut utiliser une autre formule dite
Matricielle.

Je te propose l'exemple çi dessous,pour mieux comprendre et pour
l'appliquer à ton cas:

Les formules suivantes feront la somme des valeurs contenues dans les
cellules $A$1:$A$5 de la feuille "Feuil1" du classeur "Class1.xls" si
les
cellules $B$1:$B$5 de cette même feuille contiennent la lettre "a".

1. Formule utilisant la fonction SOMME.SI() :
=SOMME.SI('C:EXCEL[CLASS1.XLS]Feuil1'!$B$1:$B$5;"a";'C:EXCEL
[CLASS1.
XLS]Feuil1'!$A$1:$A$5)

1. Formule matricielle :
{=SOMME('C:EXCELCLASS1.XLS'!$A$1:$A$5*('C:EXCELCLASS1.XLS'!
$B$1:$B$5="a"))}

ATTENTION : Cette formule doit-être validée par la combinaison de
touches
CTRL+SHIFT+ENTREE pour obtenir une formule matricielle.


Bonjour � tous,

J'ai une petit souci avec une feuille Excel qui r�cup�re d es donn�es
dans d'autre feuille.
Le probl�me c'est que, quand je clic sur le bouton mettre ï¿ ½ jour les
liens � l'ouverture de mon fichier, les cellule qui contient la
formule RECHERCHEV se mettent � jours sans probl�me, par c ontre l� o�
j'ai ma formule avec SOMME.SI j'ai un r�sultat #VALEUR, donc
impossible de mettre � jours si le fichier d'origine est fermï ¿½.

D'avance merci.

je vous souhaite un bon d�but de semaine


Publicité
Poster une réponse
Anonyme